summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-23 14:53:05 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-23 14:53:05 +0000
commit615b4b44da793e6e359cd14b2325b93aa728b3e9 (patch)
tree35d883db4130a98e063cdb57db9b03fe3068c427 /app-sci/octave
parentadded alpha (diff)
downloadhistorical-615b4b44da793e6e359cd14b2325b93aa728b3e9.tar.gz
historical-615b4b44da793e6e359cd14b2325b93aa728b3e9.tar.bz2
historical-615b4b44da793e6e359cd14b2325b93aa728b3e9.zip
touchups
Diffstat (limited to 'app-sci/octave')
-rw-r--r--app-sci/octave/octave-2.1.36-r1.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/app-sci/octave/octave-2.1.36-r1.ebuild b/app-sci/octave/octave-2.1.36-r1.ebuild
index 2e0beefb6faf..7f2657169ffe 100644
--- a/app-sci/octave/octave-2.1.36-r1.ebuild
+++ b/app-sci/octave/octave-2.1.36-r1.ebuild
@@ -1,25 +1,23 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.36-r1.ebuild,v 1.4 2002/10/20 18:40:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.1.36-r1.ebuild,v 1.5 2002/11/23 14:53:05 vapier Exp $
-IUSE=" tetex"
-
-S=${WORKDIR}/${P}
-DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations."
+DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations"
SRC_URI="ftp://ftp.octave.org/pub/octave/bleeding-edge/${P}.tar.bz2"
HOMEPAGE="http://www.octave.org/"
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2-r3
- >=media-gfx/gnuplot-3.7.1-r3
- >=dev-libs/fftw-2.1.3
- >=dev-util/gperf-2.7.2
- tetex ? ( >=tetex-1.0.7-r10 ) "
-PROVIDE="dev-lang/octave"
-
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
SLOT="0"
+IUSE="tetex"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r3
+ >=media-gfx/gnuplot-3.7.1-r3
+ >=dev-libs/fftw-2.1.3
+ >=dev-util/gperf-2.7.2
+ tetex ? ( >=tetex-1.0.7-r10 ) "
+PROVIDE="dev-lang/octave"
# NOTE: octave supports blas/lapack from intel but this is not open
# source nor is it free (as in beer OR speech) Check out...
@@ -50,10 +48,9 @@ src_compile() {
patch -p1 < ${FILESDIR}/kill-dvips.diff || die
emake || die "emake failed"
-
}
-src_install () {
+src_install() {
make \
prefix=${D}/usr \
mandir=${D}/usr/share/man \
@@ -62,7 +59,7 @@ src_install () {
use tetex && octave-install-doc
}
-octave-install-doc () {
+octave-install-doc() {
echo "Installing documentation..."
insinto /usr/share/doc/${PF}
doins doc/faq/Octave-FAQ.dvi