summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2002-11-20 23:50:43 +0000
committerHannes Mehnert <hannes@gentoo.org>2002-11-20 23:50:43 +0000
commit44ee1f9b83a017d7be1cb6030c7d2aa5a85a673a (patch)
tree2ac8fe34047104c66ebc4a866c0e43fe1aa51734 /app-sci/kmatplot
parentmarked stable (diff)
downloadhistorical-44ee1f9b83a017d7be1cb6030c7d2aa5a85a673a.tar.gz
historical-44ee1f9b83a017d7be1cb6030c7d2aa5a85a673a.tar.bz2
historical-44ee1f9b83a017d7be1cb6030c7d2aa5a85a673a.zip
added patch (bug #10976)
Diffstat (limited to 'app-sci/kmatplot')
-rw-r--r--app-sci/kmatplot/ChangeLog6
-rw-r--r--app-sci/kmatplot/files/kmatplot-0.4-inline.patch22
-rw-r--r--app-sci/kmatplot/kmatplot-0.4.ebuild5
3 files changed, 30 insertions, 3 deletions
diff --git a/app-sci/kmatplot/ChangeLog b/app-sci/kmatplot/ChangeLog
index 0e2acf69e7fc..f90a744adb7c 100644
--- a/app-sci/kmatplot/ChangeLog
+++ b/app-sci/kmatplot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/kmatplot
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/kmatplot/ChangeLog,v 1.2 2002/11/02 10:09:19 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/kmatplot/ChangeLog,v 1.3 2002/11/20 23:50:43 hannes Exp $
+
+ 21 Nov 2002; Hannes Mehnert <hannes@gentoo.org> kmatplot-0.4.ebuild:
+ added patch to fix compiling (bug #10976), thanks to afrox@centrum.cz
+ (Jan Trmal) for submission
02 Nov 2002; Hannes Mehnert <hannes@gentoo.org> kmatplot-0.4.ebuild:
marked stable
diff --git a/app-sci/kmatplot/files/kmatplot-0.4-inline.patch b/app-sci/kmatplot/files/kmatplot-0.4-inline.patch
new file mode 100644
index 000000000000..ee1ae5e92054
--- /dev/null
+++ b/app-sci/kmatplot/files/kmatplot-0.4-inline.patch
@@ -0,0 +1,22 @@
+--- kmatplot/widgets/qscontour.cpp.orig 2002-03-18 17:06:56.000000000 +0100
++++ kmatplot/widgets/qscontour.cpp 2002-04-11 18:04:26.000000000 +0200
+@@ -427,7 +427,7 @@
+
+ //-------------------------------------------------------------//
+
+-inline int QSContour::find_level_greater_than( double value )
++int QSContour::find_level_greater_than( double value )
+ // find first level > value or return level.number if all levels are lower then value
+ {
+ double *first_level = &d->level.value[0];
+--- kmatplot/widgets/qscontour.h.orig 2002-03-12 00:59:49.000000000 +0100
++++ kmatplot/widgets/qscontour.h 2002-04-11 18:04:51.000000000 +0200
+@@ -184,7 +184,7 @@
+ QSPt3f *under_pts, int *under_npts,
+ QSPt3f *cross_line = NULL, int *cross_npts = NULL );
+ inline double distance( const QSPt2f& p1, const QSPt2f& p2 );
+- inline int find_level_greater_than( double value );
++ int find_level_greater_than( double value );
+ void flush_rectangle_buffer();
+ bool draw_rectangle( const QSPt3f pts[4] );
+ };
diff --git a/app-sci/kmatplot/kmatplot-0.4.ebuild b/app-sci/kmatplot/kmatplot-0.4.ebuild
index 2450b2c0e311..eed1bb1e499c 100644
--- a/app-sci/kmatplot/kmatplot-0.4.ebuild
+++ b/app-sci/kmatplot/kmatplot-0.4.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-sci/kmatplot/kmatplot-0.4.ebuild,v 1.2 2002/11/02 10:09:19 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/kmatplot/kmatplot-0.4.ebuild,v 1.3 2002/11/20 23:50:43 hannes Exp $
-PATCHES="${FILESDIR}/${P}-gentoo.patch"
+PATCHES="${FILESDIR}/${P}-gentoo.patch
+ ${FILESDIR}/${P}-inline.patch"
inherit kde-base
need-kde 3