summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannes Mehnert <hannes@gentoo.org>2003-02-02 22:41:34 +0000
committerHannes Mehnert <hannes@gentoo.org>2003-02-02 22:41:34 +0000
commit04d1fac2b6dbab46fcbb9cb288d176952dfb9c3b (patch)
tree9f5eaa2aee027c1181e08f16272fa469495c0aa6 /app-sci/kmatplot
parentld_preload fixes for freetype... (diff)
downloadhistorical-04d1fac2b6dbab46fcbb9cb288d176952dfb9c3b.tar.gz
historical-04d1fac2b6dbab46fcbb9cb288d176952dfb9c3b.tar.bz2
historical-04d1fac2b6dbab46fcbb9cb288d176952dfb9c3b.zip
fixes #10976
Diffstat (limited to 'app-sci/kmatplot')
-rw-r--r--app-sci/kmatplot/ChangeLog5
-rw-r--r--app-sci/kmatplot/files/kmatplot-0.4-gentoo2.patch24
-rw-r--r--app-sci/kmatplot/kmatplot-0.4.ebuild5
3 files changed, 31 insertions, 3 deletions
diff --git a/app-sci/kmatplot/ChangeLog b/app-sci/kmatplot/ChangeLog
index f90a744adb7c..19982dd195f5 100644
--- a/app-sci/kmatplot/ChangeLog
+++ b/app-sci/kmatplot/ChangeLog
@@ -1,7 +1,10 @@
# ChangeLog for app-sci/kmatplot
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/kmatplot/ChangeLog,v 1.3 2002/11/20 23:50:43 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/kmatplot/ChangeLog,v 1.4 2003/02/02 22:41:34 hannes Exp $
+ 02 Feb 2003; Hannes Mehnert <hannes@gentoo.org> kmatplot-0.4.ebuild:
+ added patch to compile with qt-3.1/kde-3.1, fixes #10976 again.
+
21 Nov 2002; Hannes Mehnert <hannes@gentoo.org> kmatplot-0.4.ebuild:
added patch to fix compiling (bug #10976), thanks to afrox@centrum.cz
(Jan Trmal) for submission
diff --git a/app-sci/kmatplot/files/kmatplot-0.4-gentoo2.patch b/app-sci/kmatplot/files/kmatplot-0.4-gentoo2.patch
new file mode 100644
index 000000000000..0405a8443d75
--- /dev/null
+++ b/app-sci/kmatplot/files/kmatplot-0.4-gentoo2.patch
@@ -0,0 +1,24 @@
+--- kmatplot/widgets/qsdrvhittest.cpp 2002-02-22 00:11:52.000000000 +0000
++++ kmatplot/widgets/qsdrvhittest.cpp 2003-02-02 22:31:19.000000000 +0000
+@@ -44,7 +44,8 @@
+
+ //-------------------------------------------------------------/
+
+-QSDrvHitTest *QSDrvHitTest::copy()
++//QSDrvHitTest *QSDrvHitTest::copy()
++QSDrvQt *QSDrvHitTest::copy()
+ {
+ QSDrvHitTest *result = new QSDrvHitTest( m_hit_pos );
+ result->copySettingsFrom( this );
+--- kmatplot/widgets/qsdrvhittest.h 2002-03-11 20:59:31.000000000 +0000
++++ kmatplot/widgets/qsdrvhittest.h 2003-02-02 22:33:28.000000000 +0000
+@@ -43,7 +43,8 @@
+ public:
+ QSDrvHitTest( const QSPt2f& hitPosition, QObject *parent = NULL );
+ virtual ~QSDrvHitTest();
+- virtual QSDrvHitTest *copy();
++// virtual QSDrvHitTest *copy();
++ virtual QSDrvQt *copy();
+ void copySettingsFrom( const QSDrvHitTest *drv );
+ bool isHit() const { return m_is_hit; }
+ int hitCategory() const { return m_category; }
diff --git a/app-sci/kmatplot/kmatplot-0.4.ebuild b/app-sci/kmatplot/kmatplot-0.4.ebuild
index eed1bb1e499c..827c32a769fa 100644
--- a/app-sci/kmatplot/kmatplot-0.4.ebuild
+++ b/app-sci/kmatplot/kmatplot-0.4.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-sci/kmatplot/kmatplot-0.4.ebuild,v 1.3 2002/11/20 23:50:43 hannes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/kmatplot/kmatplot-0.4.ebuild,v 1.4 2003/02/02 22:41:34 hannes Exp $
PATCHES="${FILESDIR}/${P}-gentoo.patch
- ${FILESDIR}/${P}-inline.patch"
+ ${FILESDIR}/${P}-inline.patch
+ ${FILESDIR}/${P}-gentoo2.patch"
inherit kde-base
need-kde 3