summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2004-10-30 15:45:52 +0000
committerOlivier Fisette <ribosome@gentoo.org>2004-10-30 15:45:52 +0000
commitbb318e528b7a71304848f07eb92500f949f2a494 (patch)
tree158ca6e5ab2b70927d44c9a9eebac58fae56992c /app-sci/elph
parentQ.A. fixes (diff)
downloadhistorical-bb318e528b7a71304848f07eb92500f949f2a494.tar.gz
historical-bb318e528b7a71304848f07eb92500f949f2a494.tar.bz2
historical-bb318e528b7a71304848f07eb92500f949f2a494.zip
New version.
Diffstat (limited to 'app-sci/elph')
-rw-r--r--app-sci/elph/ChangeLog6
-rw-r--r--app-sci/elph/Manifest5
-rw-r--r--app-sci/elph/elph-0.1.4.ebuild36
-rw-r--r--app-sci/elph/files/digest-elph-0.1.41
-rw-r--r--app-sci/elph/files/elph-0.1.4-usage.patch133
5 files changed, 179 insertions, 2 deletions
diff --git a/app-sci/elph/ChangeLog b/app-sci/elph/ChangeLog
index 78acd18cd1df..7b4639772663 100644
--- a/app-sci/elph/ChangeLog
+++ b/app-sci/elph/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-sci/elph
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-sci/elph/ChangeLog,v 1.2 2004/06/24 21:57:24 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/elph/ChangeLog,v 1.3 2004/10/30 15:45:52 ribosome Exp $
+
+ 30 Oct 2004; Olivier Fisette <ribosome@gentoo.org> +elph-0.1.4.ebuild
+ +files/elph-0.1.4-usage.patch :
+ New version.
*elph-0.1.2 (22 May 2003)
diff --git a/app-sci/elph/Manifest b/app-sci/elph/Manifest
index 6dfe3b7b2295..21b4a47d2e57 100644
--- a/app-sci/elph/Manifest
+++ b/app-sci/elph/Manifest
@@ -1,4 +1,7 @@
MD5 d96d76f1560e7cdb6630b0a0f3cda349 elph-0.1.2.ebuild 682
-MD5 da3b4212781522663291b917546cd684 ChangeLog 362
+MD5 bb5ad787f0b92cdd93b8ff802aa703f7 elph-0.1.4.ebuild 937
+MD5 bf38d96495f083237d947217748f6681 ChangeLog 484
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 75fe098a9b1df66ed55f16b4cfde3922 files/elph-0.1.4-usage.patch 3909
MD5 4a7fdc7d26ff2d8fc72881383ff93fc4 files/digest-elph-0.1.2 61
+MD5 170bc1e9213d1c70d75ae92411a3567c files/digest-elph-0.1.4 61
diff --git a/app-sci/elph/elph-0.1.4.ebuild b/app-sci/elph/elph-0.1.4.ebuild
new file mode 100644
index 000000000000..18705c3ce857
--- /dev/null
+++ b/app-sci/elph/elph-0.1.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-sci/elph/elph-0.1.4.ebuild,v 1.1 2004/10/30 15:45:52 ribosome Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Estimated Locations of Pattern Hits - Motif finder program"
+HOMEPAGE="http://www.tigr.org/software/ELPH/index.shtml"
+SRC_URI="ftp://ftp.tigr.org/pub/software/ELPH/ELPH-${PV}.tar.gz"
+LICENSE="Artistic"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+S="${WORKDIR}/ELPH/sources"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-usage.patch
+ sed -i -e "s/CC := g++/CC := $(tc-getCXX)/" Makefile
+ sed -i -e "s/-fno-exceptions -fno-rtti -D_REENTRANT -g/${CXXFLAGS}/" Makefile
+ sed -i -e "s/LINKER := g++/LINKER := $(tc-getCXX)/" Makefile
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+ dobin elph
+ cd ${WORKDIR}/ELPH
+ dodoc VERSION
+ newdoc Readme.ELPH README
+}
diff --git a/app-sci/elph/files/digest-elph-0.1.4 b/app-sci/elph/files/digest-elph-0.1.4
new file mode 100644
index 000000000000..623e842d2d74
--- /dev/null
+++ b/app-sci/elph/files/digest-elph-0.1.4
@@ -0,0 +1 @@
+MD5 5065b4d6062d8654fae5337cf0ea0e01 ELPH-0.1.4.tar.gz 40181
diff --git a/app-sci/elph/files/elph-0.1.4-usage.patch b/app-sci/elph/files/elph-0.1.4-usage.patch
new file mode 100644
index 000000000000..be49e2d1ebb8
--- /dev/null
+++ b/app-sci/elph/files/elph-0.1.4-usage.patch
@@ -0,0 +1,133 @@
+--- elph.cc~ 2003-06-03 14:45:22.000000000 -0400
++++ elph.cc 2004-10-30 10:14:49.220415168 -0400
+@@ -26,11 +26,11 @@
+ period variable\n\
+ -x : print maximum positions within sequences\n\
+ -g : find significance of motif\n\
+- -t <matrix> : test if there is significant difference between the two
+- input files for a given motif matrix; <matrix> is the file
++ -t <matrix> : test if there is significant difference between the two\n\
++ input files for a given motif matrix; <matrix> is the file\n\
+ containing the motif matrix\n\
+- -l : compute Least Likely Consensus (LLC) for given motif
+- -c : in conjunction with -m option: motif is not necessarily in
++ -l : compute Least Likely Consensus (LLC) for given motif\n\
++ -c : in conjunction with -m option: motif is not necessarily in\n\
+ the closest edit distance from input motif\n\
+ LEN=n : n = length of motif\n\
+ ITERNO=n : n = no of iterations to compute the global maximum;\n\
+@@ -41,7 +41,7 @@
+ default = 1000\n\
+ "
+
+-// global variables:
++// global variables:
+ int ITER_NO=10;
+ int MAX_LOOP=500;
+ int printmax=0;
+@@ -66,7 +66,7 @@
+ seqType t;
+
+ GArgs args(argc, argv, "ho:abglvdxt:p:s:m:n:LEN=ITERNO=MAXLOOP=SGFNO=");
+-
++
+ // == Process arguments.
+
+ int e;
+@@ -83,7 +83,7 @@
+
+ if(!testfile.is_empty()) { // if testfile is defined then only compute significance between the two files
+
+- M = new Motif(infile,outf,t,matrixfile,pattern,motiflen,ITER_NO,MAX_LOOP,inlocmax,mdet);
++ M = new Motif(infile,outf,t,matrixfile,pattern,motiflen,ITER_NO,MAX_LOOP,inlocmax,mdet);
+ M->twofilesignif(gdet,testfile,SignifNo,print,pattern);
+
+ }
+@@ -93,11 +93,11 @@
+ // given motif
+
+ M = new Motif(infile,outf,t,pattern);
+- if(defLLC) {
++ if(defLLC) {
+ double llc=M->computeLLC(pattern,print);
+ fprintf(outf,"LLC = %f\n",llc);
+ }
+-
++
+ }
+ else {
+
+@@ -108,7 +108,7 @@
+ }
+
+ double globAlignProb;
+-
++
+ globAlignProb=M->findMotif(ITER_NO,MAX_LOOP,inlocmax,1,mdet);
+
+
+@@ -116,13 +116,13 @@
+ /*info=M->InfoPar(globAlignProb);
+ fprintf(outf,"MAP for motif: %.3f InfoPar=%.3f\n\n",globAlignProb,info);
+ M->printMotif();*/
+-
++
+ // optimizing
+ fprintf(stderr,"Optimizing...\n");
+ globAlignProb=M->optimize(globAlignProb,info,closest);
+ fprintf(outf,"\n\n**********************\n\nMotif after optimizing\n");
+ fprintf(outf,"MAP for motif: %.3f InfoPar=%.3f\n\n",globAlignProb,M->InfoPar(globAlignProb));
+-
++
+ if(runsignif) {
+ M->runforsignif(SignifNo,print,gdet,pattern);
+ }
+@@ -134,17 +134,17 @@
+
+ seqType Process_Options(GArgs* args)
+ {
+-
+- if (args->startNonOpt()) { //parse the non-options arguments
++
++ if (args->startNonOpt()) { //parse the non-options arguments
+ //(usually filenames)
+ infile=args->nextNonOpt();
+ }
+
+- if (infile.is_empty() || args->getOpt('h')!=NULL)
++ if (infile.is_empty() || args->getOpt('h')!=NULL)
+ GError("%s",usage); // the empty test is optional you can ignore it if you accept stdin input
+
+ testfile=args->nextNonOpt();
+-
++
+ GString outfile=args->getOpt('o');
+ if (!outfile.is_empty()) {
+ outf=fopen(outfile, "w");
+@@ -156,7 +156,7 @@
+ matrixfile=args->getOpt('t');
+
+ GString param;
+-
++
+ pattern=args->getOpt('m');
+ if(pattern.is_empty()) {
+ param=args->getOpt("LEN");
+@@ -200,7 +200,7 @@
+
+ seqType t;
+ if(args->getOpt('a')!=NULL) t=aac; else t=nucl;
+-
++
+ return(t);
+
+ }
+@@ -210,7 +210,7 @@
+ Motif *M;
+
+ double llcmax=-HUGE_VAL;
+- GString seed;
++ GString seed;
+ for(int i1=0;i1<4;i1++)
+ for(int i2=0;i2<4;i2++)
+ for(int i3=0;i3<4;i3++)