summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2005-05-03 11:17:39 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2005-05-03 11:17:39 +0000
commit9fde695f4ce9b7eb6524f8a88fd6bc236eb42420 (patch)
tree9cdf5db6a7f202a1813c893e8c37319fbf2196fd /app-pda/p3nfs/p3nfs-5.17a.ebuild
parentReadded keywords to -r2 and closed the bug. (diff)
downloadhistorical-9fde695f4ce9b7eb6524f8a88fd6bc236eb42420.tar.gz
historical-9fde695f4ce9b7eb6524f8a88fd6bc236eb42420.tar.bz2
historical-9fde695f4ce9b7eb6524f8a88fd6bc236eb42420.zip
Version bump.
Package-Manager: portage-2.0.51.21
Diffstat (limited to 'app-pda/p3nfs/p3nfs-5.17a.ebuild')
-rw-r--r--app-pda/p3nfs/p3nfs-5.17a.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-pda/p3nfs/p3nfs-5.17a.ebuild b/app-pda/p3nfs/p3nfs-5.17a.ebuild
new file mode 100644
index 000000000000..89026ce33700
--- /dev/null
+++ b/app-pda/p3nfs/p3nfs-5.17a.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/p3nfs/p3nfs-5.17a.ebuild,v 1.1 2005/05/03 11:17:39 brix Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Symbian to Unix and Linux communication program"
+HOMEPAGE="http://www.koeniglich.de/p3nfs.html"
+SRC_URI="http://www.koeniglich.de/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+DEPEND="net-nds/portmap"
+
+src_compile() {
+ append-ldflags -Wl,-z,now
+ sed -i "s:\$(LDFLAGS):${LDFLAGS}:" ${S}/nfsd/Makefile.in
+
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "emake install failed"
+
+ dodoc CHANGES README TODO
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You need to install one of the nfsapp-*.sis clients on your"
+ einfo "Symbian device to be able to mount it's filesystems."
+ einfo
+ einfo "Make sure to have portmap running before you start the"
+ einfo "p3nfsd server."
+ einfo
+}