summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2007-02-12 21:08:02 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2007-02-12 21:08:02 +0000
commitccf0457996d2366504248ffcc79fec7241cfcf85 (patch)
tree515b649622cdfd6f990a00c796436ca699cf7185 /app-pda/libopensync-plugin-syncml
parentFix broken patch, was because of $Id: lines at start. (diff)
downloadhistorical-ccf0457996d2366504248ffcc79fec7241cfcf85.tar.gz
historical-ccf0457996d2366504248ffcc79fec7241cfcf85.tar.bz2
historical-ccf0457996d2366504248ffcc79fec7241cfcf85.zip
Version bump.
Package-Manager: portage-2.1.2-r9
Diffstat (limited to 'app-pda/libopensync-plugin-syncml')
-rw-r--r--app-pda/libopensync-plugin-syncml/ChangeLog10
-rw-r--r--app-pda/libopensync-plugin-syncml/files/digest-libopensync-plugin-syncml-0.213
-rw-r--r--app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.21.ebuild47
3 files changed, 58 insertions, 2 deletions
diff --git a/app-pda/libopensync-plugin-syncml/ChangeLog b/app-pda/libopensync-plugin-syncml/ChangeLog
index 054e207fc2e9..85a595f7040b 100644
--- a/app-pda/libopensync-plugin-syncml/ChangeLog
+++ b/app-pda/libopensync-plugin-syncml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/libopensync-plugin-syncml
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-syncml/ChangeLog,v 1.1 2006/11/13 22:13:00 peper Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-syncml/ChangeLog,v 1.2 2007/02/12 21:08:02 peper Exp $
+
+*libopensync-plugin-syncml-0.21 (12 Feb 2007)
+
+ 12 Feb 2007; Piotr Jaroszyński <peper@gentoo.org>
+ +libopensync-plugin-syncml-0.21.ebuild:
+ Version bump.
*libopensync-plugin-syncml-0.20 (13 Nov 2006)
diff --git a/app-pda/libopensync-plugin-syncml/files/digest-libopensync-plugin-syncml-0.21 b/app-pda/libopensync-plugin-syncml/files/digest-libopensync-plugin-syncml-0.21
new file mode 100644
index 000000000000..159755151605
--- /dev/null
+++ b/app-pda/libopensync-plugin-syncml/files/digest-libopensync-plugin-syncml-0.21
@@ -0,0 +1,3 @@
+MD5 83725ed770b36b5beb90586cbe7661c2 libopensync-plugin-syncml-0.21.tar.bz2 234746
+RMD160 ffb2f8eac043125b9567ee15a6806ce49f85b77c libopensync-plugin-syncml-0.21.tar.bz2 234746
+SHA256 f6f34ec976a6ee2eacdb198406a12f970eb3a0f8e551bf3590a7fd20da360dfe libopensync-plugin-syncml-0.21.tar.bz2 234746
diff --git a/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.21.ebuild b/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.21.ebuild
new file mode 100644
index 000000000000..2120cd1eb432
--- /dev/null
+++ b/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.21.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-syncml/libopensync-plugin-syncml-0.21.ebuild,v 1.1 2007/02/12 21:08:02 peper Exp $
+
+inherit eutils
+
+DESCRIPTION="OpenSync SyncML Plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://dev.gentooexperimental.org/~peper/distfiles/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="http obex"
+
+DEPEND="=app-pda/libopensync-${PV}*
+ >=app-pda/libsyncml-0.4.3"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! use obex && ! use http; then
+ eerror "${CATEGORY}/${P} without support for obex nor http is unusable."
+ einfo "Please enable \"obex\" or/and \"http\" USE flags."
+ die "Please enable \"obex\" or/and \"http\" USE flags."
+ fi
+
+ if use obex && ! built_with_use app-pda/libsyncml obex; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"obex\""
+ eerror "USE flags, but app-pda/libsyncml was built without"
+ eerror "the \"obex\" USE flag."
+ einfo "Please rebuild app-pda/libsyncml with \"obex\" USE flag."
+ die "Please rebuild app-pda/libsyncml with \"obex\" USE flag."
+ fi
+
+ if use http && ! built_with_use app-pda/libsyncml http; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"http\""
+ eerror "USE flags, but app-pda/libsyncml was built without"
+ eerror "the \"http\" USE flag."
+ einfo "Please rebuild app-pda/libsyncml with \"http\" USE flag."
+ die "Please rebuild app-pda/libsyncml with \"http\" USE flag."
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog
+}