summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Jaroszyński <peper@gentoo.org>2007-12-21 23:21:54 +0000
committerPiotr Jaroszyński <peper@gentoo.org>2007-12-21 23:21:54 +0000
commit078e8f4c1e9e5a374382e05a9d142100919eba99 (patch)
tree626d3f282cde572eac6d4de97349412aba190c92 /app-pda/libopensync-plugin-irmc
parent2.6.24 patch only for fcdsl version1 thanks to Arnd Feldmueller (diff)
downloadhistorical-078e8f4c1e9e5a374382e05a9d142100919eba99.tar.gz
historical-078e8f4c1e9e5a374382e05a9d142100919eba99.tar.bz2
historical-078e8f4c1e9e5a374382e05a9d142100919eba99.zip
Add 0.35.
Package-Manager: portage-2.1.4_rc11
Diffstat (limited to 'app-pda/libopensync-plugin-irmc')
-rw-r--r--app-pda/libopensync-plugin-irmc/ChangeLog8
-rw-r--r--app-pda/libopensync-plugin-irmc/files/digest-libopensync-plugin-irmc-0.353
-rw-r--r--app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.35.ebuild52
3 files changed, 62 insertions, 1 deletions
diff --git a/app-pda/libopensync-plugin-irmc/ChangeLog b/app-pda/libopensync-plugin-irmc/ChangeLog
index 49b8f7c1854a..9c9e26ebac3b 100644
--- a/app-pda/libopensync-plugin-irmc/ChangeLog
+++ b/app-pda/libopensync-plugin-irmc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-pda/libopensync-plugin-irmc
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-irmc/ChangeLog,v 1.6 2007/11/26 20:18:45 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-irmc/ChangeLog,v 1.7 2007/12/21 23:14:39 peper Exp $
+
+*libopensync-plugin-irmc-0.35 (21 Dec 2007)
+
+ 21 Dec 2007; Piotr Jaroszyński <peper@gentoo.org>
+ +libopensync-plugin-irmc-0.35.ebuild:
+ Add 0.35.
*libopensync-plugin-irmc-9999 (26 Nov 2007)
diff --git a/app-pda/libopensync-plugin-irmc/files/digest-libopensync-plugin-irmc-0.35 b/app-pda/libopensync-plugin-irmc/files/digest-libopensync-plugin-irmc-0.35
new file mode 100644
index 000000000000..a8083c8cb7b5
--- /dev/null
+++ b/app-pda/libopensync-plugin-irmc/files/digest-libopensync-plugin-irmc-0.35
@@ -0,0 +1,3 @@
+MD5 52a43bf6cecaf7c6249038b61038cbc9 libopensync-plugin-irmc-0.35.tar.bz2 49799
+RMD160 b289b736115115bdfce65e5bb6c42b140451ea52 libopensync-plugin-irmc-0.35.tar.bz2 49799
+SHA256 59de0befc6a7dd2f048b573d14060dc281b05e106d2122ebc6ddafd626ce5fe0 libopensync-plugin-irmc-0.35.tar.bz2 49799
diff --git a/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.35.ebuild b/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.35.ebuild
new file mode 100644
index 000000000000..fd20e2c6d7ca
--- /dev/null
+++ b/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.35.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/libopensync-plugin-irmc/libopensync-plugin-irmc-0.35.ebuild,v 1.1 2007/12/21 23:14:39 peper Exp $
+
+inherit eutils cmake-utils
+
+DESCRIPTION="OpenSync IrMC plugin"
+HOMEPAGE="http://www.opensync.org/"
+SRC_URI="http://www.opensync.org/download/releases/${PV}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="bluetooth irda"
+
+DEPEND="=app-pda/libopensync-${PV}*
+ >=dev-libs/openobex-1.0
+ bluetooth? ( net-wireless/bluez-libs )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if ! use irda && ! use bluetooth; then
+ eerror "${CATEGORY}/${P} without support for bluetooth nor irda is unusable."
+ eerror "Please enable \"bluetooth\" or/and \"irda\" USE flags."
+ die "Please enable \"bluetoot\" or/and \"irda\" USE flags."
+ fi
+
+ if use bluetooth && ! built_with_use dev-libs/openobex bluetooth; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"bluetooth\""
+ eerror "USE flag, but dev-libs/openobex was built without"
+ eerror "the \"bluetooth\" USE flag."
+ eerror "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ die "Please rebuild dev-libs/openobex with \"bluetooth\" USE flag."
+ fi
+
+ if use irda && ! built_with_use dev-libs/openobex irda; then
+ eerror "You are trying to build ${CATEGORY}/${P} with the \"irda\""
+ eerror "USE flag, but dev-libs/openobex was built without"
+ eerror "the \"irda\" USE flag."
+ eerror "Please rebuild dev-libs/openobex with \"irda\" USE flag."
+ die "Please rebuild dev-libs/openobex with \"irda\" USE flag."
+ fi
+}
+
+src_compile() {
+ local mycmakeargs="
+ $(cmake-utils_use_enable bluetooth BLUETOOTH)
+ $(cmake-utils_use_enable irda IRDA)"
+
+ cmake-utils_src_compile
+}