summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-06 16:16:54 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-06 16:16:54 +0000
commit8805436aef6ac874ea22356de842d715b40ac53a (patch)
treee4eacbab70c17c44d8700204b55d88949218e24f /app-office/texmaker
parentVersion bump, thanks to Carles, Alexandre and Brandon (bug #356473). (diff)
downloadhistorical-8805436aef6ac874ea22356de842d715b40ac53a.tar.gz
historical-8805436aef6ac874ea22356de842d715b40ac53a.tar.bz2
historical-8805436aef6ac874ea22356de842d715b40ac53a.zip
Version Bump
Package-Manager: portage-2.2.0_alpha90/cvs/Linux x86_64
Diffstat (limited to 'app-office/texmaker')
-rw-r--r--app-office/texmaker/ChangeLog8
-rw-r--r--app-office/texmaker/files/texmaker-3.3.2-hunspell.patch167
-rw-r--r--app-office/texmaker/texmaker-3.3.2.ebuild70
3 files changed, 244 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index e496cb3498de..9e58abbfeb7d 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.94 2012/02/28 20:41:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.95 2012/03/06 16:16:54 jlec Exp $
+
+*texmaker-3.3.2 (06 Mar 2012)
+
+ 06 Mar 2012; Justin Lecher <jlec@gentoo.org> +texmaker-3.3.2.ebuild,
+ +files/texmaker-3.3.2-hunspell.patch:
+ Version Bump
*texmaker-3.3.1 (28 Feb 2012)
diff --git a/app-office/texmaker/files/texmaker-3.3.2-hunspell.patch b/app-office/texmaker/files/texmaker-3.3.2-hunspell.patch
new file mode 100644
index 000000000000..9b811cd01443
--- /dev/null
+++ b/app-office/texmaker/files/texmaker-3.3.2-hunspell.patch
@@ -0,0 +1,167 @@
+ configdialog.cpp | 4 ++--
+ latexeditor.h | 2 +-
+ latexeditorview.h | 2 +-
+ latexhighlighter.h | 2 +-
+ spellerdialog.h | 2 +-
+ texmaker.h | 2 +-
+ texmaker.pro | 42 ++++++------------------------------------
+ 7 files changed, 13 insertions(+), 43 deletions(-)
+
+diff --git a/configdialog.cpp b/configdialog.cpp
+index 3b91fd0..338b166 100644
+--- a/configdialog.cpp
++++ b/configdialog.cpp
+@@ -210,9 +210,9 @@ void ConfigDialog::browseAspell()
+ QDir spelldir(QCoreApplication::applicationDirPath());
+ #else
+ #ifdef DEBIAN_SPELLDIR
+-QDir spelldir(PREFIX"/share/myspell/dicts");
++QDir spelldir("@GENTOO_PORTAGE_EPREFIX@/usr/share/myspell");
+ #else
+-QDir spelldir(PREFIX"/share/texmaker");
++QDir spelldir("@GENTOO_PORTAGE_EPREFIX@/usr/share/texmaker");
+ #endif
+ #endif
+
+diff --git a/latexeditor.h b/latexeditor.h
+index e053390..0e82f08 100644
+--- a/latexeditor.h
++++ b/latexeditor.h
+@@ -33,7 +33,7 @@
+
+ #include "latexhighlighter.h"
+ #include "textblockselection.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ typedef int UserBookmarkList[3];
+
+diff --git a/latexeditorview.h b/latexeditorview.h
+index fb8d7d4..716b466 100644
+--- a/latexeditorview.h
++++ b/latexeditorview.h
+@@ -22,7 +22,7 @@
+ #include "gotolinewidget.h"
+ #include "replacewidget.h"
+ #include "minisplitter.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ class LatexEditorView : public QWidget {
+ Q_OBJECT
+diff --git a/latexhighlighter.h b/latexhighlighter.h
+index e0b91b1..74ec42a 100644
+--- a/latexhighlighter.h
++++ b/latexhighlighter.h
+@@ -20,7 +20,7 @@
+ #include <QColor>
+ #include <QTextBlockUserData>
+ //#include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ class QTextDocument;
+ class LatexEditor;
+diff --git a/spellerdialog.h b/spellerdialog.h
+index 83248ae..cd16dad 100644
+--- a/spellerdialog.h
++++ b/spellerdialog.h
+@@ -13,7 +13,7 @@
+
+ #include "ui_spellerdialog.h"
+ #include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ #include <QTextCursor>
+
+diff --git a/texmaker.h b/texmaker.h
+index 584be7f..b0069a4 100644
+--- a/texmaker.h
++++ b/texmaker.h
+@@ -48,7 +48,7 @@
+ #include "usertagslistwidget.h"
+ #include "xmltagslistwidget.h"
+ #include "logeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+ #include "browser.h"
+ #include "pdfviewerwidget.h"
+ #include "pdfviewer.h"
+diff --git a/texmaker.pro b/texmaker.pro
+index 17d0a24..28ad193 100644
+--- a/texmaker.pro
++++ b/texmaker.pro
+@@ -4,7 +4,8 @@ TARGET = texmaker
+ QT += network \
+ xml \
+ webkit
+-CONFIG += qt warn_off release
++CONFIG += qt warn_off release link_pkgconfig
++PKGCONFIG = hunspell
+ TEXMAKERVERSION=3.3.2
+ DEFINES += TEXMAKERVERSION=\\\"$${TEXMAKERVERSION}\\\"
+ DEFINES += HAVE_SPLASH
+@@ -67,25 +68,6 @@ HEADERS += texmaker.h \
+ synctex_parser_utils.h \
+ usertagslistwidget.h \
+ addtagdialog.h \
+- hunspell/affentry.hxx \
+- hunspell/affixmgr.hxx \
+- hunspell/atypes.hxx \
+- hunspell/baseaffix.hxx \
+- hunspell/csutil.hxx \
+- hunspell/dictmgr.hxx \
+- hunspell/hashmgr.hxx \
+- hunspell/htypes.hxx \
+- hunspell/hunspell.hxx \
+- hunspell/hunspell.h \
+- hunspell/langnum.hxx \
+- hunspell/license.hunspell \
+- hunspell/phonet.hxx \
+- hunspell/suggestmgr.hxx \
+- hunspell/license.myspell \
+- hunspell/filemgr.hxx \
+- hunspell/hunzip.hxx \
+- hunspell/replist.hxx \
+- hunspell/w_char.hxx \
+ singleapp/qtlocalpeer.h \
+ singleapp/qtlockedfile.h \
+ singleapp/qtsingleapplication.h \
+@@ -171,18 +153,6 @@ SOURCES += main.cpp \
+ synctex_parser_utils.c \
+ usertagslistwidget.cpp \
+ addtagdialog.cpp \
+- hunspell/affentry.cxx \
+- hunspell/affixmgr.cxx \
+- hunspell/csutil.cxx \
+- hunspell/dictmgr.cxx \
+- hunspell/hashmgr.cxx \
+- hunspell/hunspell.cxx \
+- hunspell/phonet.cxx \
+- hunspell/suggestmgr.cxx \
+- hunspell/utf_info.cxx \
+- hunspell/filemgr.cxx \
+- hunspell/replist.cxx \
+- hunspell/hunzip.cxx \
+ singleapp/qtlocalpeer.cpp \
+ singleapp/qtlockedfile.cpp \
+ singleapp/qtsingleapplication.cpp \
+@@ -276,13 +246,13 @@ isEmpty( ICONDIR ) {
+ ICONDIR=/usr/share/pixmaps
+ }
+
+-INCLUDEPATH += /usr/include/poppler/qt4
+-LIBS += -L/usr/lib -lpoppler-qt4
+-LIBS += -L/usr/lib -lz
++INCLUDEPATH += @GENTOO_PORTAGE_EPREFIX@/usr/include/poppler/qt4
++LIBS += -lpoppler-qt4
++LIBS += -lz
+ DEFINES += PREFIX=\\\"$${PREFIX}\\\"
+ target.path = $${PREFIX}/bin
+
+-#DEFINES += DEBIAN_SPELLDIR
++DEFINES += DEBIAN_SPELLDIR
+
+
+ INSTALLS = target
diff --git a/app-office/texmaker/texmaker-3.3.2.ebuild b/app-office/texmaker/texmaker-3.3.2.ebuild
new file mode 100644
index 000000000000..df5ae1dabf9d
--- /dev/null
+++ b/app-office/texmaker/texmaker-3.3.2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-3.3.2.ebuild,v 1.1 2012/03/06 16:16:54 jlec Exp $
+
+EAPI="3"
+
+inherit base prefix qt4-r2 versionator
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+MY_P="${P}"
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+ app-text/poppler[qt4]
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXext
+ >=x11-libs/qt-gui-4.6.1:4
+ >=x11-libs/qt-core-4.6.1:4
+ >=x11-libs/qt-webkit-4.6.1:4
+ >=app-text/hunspell-1.2.4"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-hunspell.patch" )
+
+src_prepare() {
+ qt4-r2_src_prepare
+ eprefixify ${PN}.pro configdialog.cpp
+}
+
+src_install() {
+ emake INSTALL_ROOT="${ED}" install || die "make install failed"
+
+ insinto /usr/share/pixmaps/texmaker
+ doins utilities/texmaker*.png || die "doins failed."
+ doins utilities/texmaker.svg || die "doins failed."
+
+ dodoc utilities/AUTHORS utilities/CHANGELOG.txt || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "${EPREFIX}/usr/share/${PN}/usermanual_en.html"
+}