summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Buisse <nattfodd@gentoo.org>2006-07-18 17:02:29 +0000
committerAlexandre Buisse <nattfodd@gentoo.org>2006-07-18 17:02:29 +0000
commitd416ab4bdc6ad683bb0f3c82850535674b91822d (patch)
tree6b9d31b2901f63ce5dfa9ed07d2b31977364b935 /app-office/pybliographer/pybliographer-1.2.9.ebuild
parentStable on alpha. (diff)
downloadhistorical-d416ab4bdc6ad683bb0f3c82850535674b91822d.tar.gz
historical-d416ab4bdc6ad683bb0f3c82850535674b91822d.tar.bz2
historical-d416ab4bdc6ad683bb0f3c82850535674b91822d.zip
Bump to 1.2.9 (bug #130696).
Package-Manager: portage-2.1.1_pre3-r1
Diffstat (limited to 'app-office/pybliographer/pybliographer-1.2.9.ebuild')
-rw-r--r--app-office/pybliographer/pybliographer-1.2.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-office/pybliographer/pybliographer-1.2.9.ebuild b/app-office/pybliographer/pybliographer-1.2.9.ebuild
new file mode 100644
index 000000000000..8b485d00c49f
--- /dev/null
+++ b/app-office/pybliographer/pybliographer-1.2.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/pybliographer/pybliographer-1.2.9.ebuild,v 1.1 2006/07/18 17:02:29 nattfodd Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="Pybliographer is a tool for working with bibliographic databases"
+HOMEPAGE="http://pybliographer.org/"
+SRC_URI="mirror://sourceforge/pybliographer/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+
+IUSE=""
+
+# gnome2.eclass
+USE_DESTDIR=1
+DOCS="AUTHORS ChangeLog* NEWS TODO README"
+
+DEPEND="virtual/python
+ >=dev-libs/glib-2
+ >=app-text/recode-3.6-r1
+ >=dev-python/gnome-python-2
+ >=dev-python/python-bibtex-1.2.2
+ app-text/scrollkeeper"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-1.2.4-gentoo.diff
+}
+
+src_install() {
+ # fix for access violation due to eclass change
+ gnome2_src_install scrollkeeper_localstate_dir=${D}/var/lib/scrollkeeper/
+}