summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-07-06 08:13:26 +0000
committerDan Armak <danarmak@gentoo.org>2002-07-06 08:13:26 +0000
commit34f909188572ebb38abbc031019e9d66b47d032b (patch)
tree93618ba40178d0dba8c05f5abb628b05c012bfee /app-office/lyx/lyx-1.2.0.20020705.ebuild
parentrepoman QA issues (diff)
downloadhistorical-34f909188572ebb38abbc031019e9d66b47d032b.tar.gz
historical-34f909188572ebb38abbc031019e9d66b47d032b.tar.bz2
historical-34f909188572ebb38abbc031019e9d66b47d032b.zip
A snapshot of the lyx cvs's 1.2.x (1.2.0+bugfixes, stable only) tree that fixes #3538.
Diffstat (limited to 'app-office/lyx/lyx-1.2.0.20020705.ebuild')
-rw-r--r--app-office/lyx/lyx-1.2.0.20020705.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-office/lyx/lyx-1.2.0.20020705.ebuild b/app-office/lyx/lyx-1.2.0.20020705.ebuild
new file mode 100644
index 000000000000..e7b818b78a02
--- /dev/null
+++ b/app-office/lyx/lyx-1.2.0.20020705.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.2.0.20020705.ebuild,v 1.3 2002/07/06 08:13:26 danarmak Exp $
+
+S=${WORKDIR}/lyx-devel
+DESCRIPTION="LyX is an WYSIWYM frontend for LaTeX"
+SRC_URI="mirror://gentoo//${P}.tar.bz2"
+HOMEPAGE="http://www.lyx.org/"
+LICENSE=GPL-2
+
+# This lyx-base ebuild only depends on the absolutely necessary packages.
+# The acompanying lyx-utils ebuild depends on lyx-base and on everything
+# else that lyx can use.
+DEPEND="virtual/x11
+ x11-libs/xforms
+ app-text/tetex
+ >=sys-devel/perl-5
+ nls? ( sys-devel/gettext )
+ app-text/aiksaurus"
+RDEPEND="$DEPEND
+ app-text/ghostscript
+ app-text/xpdf
+ app-text/ispell
+ app-text/gv
+ app-text/latex2html
+ media-gfx/imagemagick
+ cups? ( virtual/lpr )
+ app-text/rcs
+ dev-util/cvs
+ app-text/sgmltools-lite
+ app-text/noweb
+ app-text/chktex"
+
+src_compile() {
+
+ use nls || myconf="${myconf} --disable-nls"
+ [ -n "$DEBUG" ] && myconf="$myconf --enable-debug" || myconf="$myconf --disable-debug"
+
+ # -O3 and higher breaks
+ export CXXFLAGS="${CXXFLAGS//-O[3..9]/-O2}"
+ export CFLAGS="${CFLAGS//-O[3..9]/-O2}"
+
+ ./autogen.sh
+
+ ./configure --host=${CHOST} --prefix=/usr ${myconf} || die "./configure failed"
+ #--infodir='$(prefix)/share/info' \
+ #--with-extra-inc=/usr/X11R6/include \
+ #--mandir='$(prefix)/share/man' \
+ emake || die "emake failed"
+}
+
+src_install () {
+ # The 'install-strip' target is provided by the LyX makefile
+ # for stripping installed binaries. Use prefix= instead of
+ # DESTDIR=, otherwise it violates the sandbox in the po directory.
+ make prefix=${D}/usr install
+ dodoc README* UPGRADING INSTALL* ChangeLog NEW COPYING ANNOUNCE ABOUT-NLS
+}
+