summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-07-30 17:58:50 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-07-30 17:58:50 +0000
commitcbebc48512c3383549dbf5fbdfa025c2b067068c (patch)
treeb2ab9713bb21fad07677a36139791bad5e7d68e3 /app-office/koffice
parentalpha/ia64 stable wrt #185691 (diff)
downloadhistorical-cbebc48512c3383549dbf5fbdfa025c2b067068c.tar.gz
historical-cbebc48512c3383549dbf5fbdfa025c2b067068c.tar.bz2
historical-cbebc48512c3383549dbf5fbdfa025c2b067068c.zip
Fix for bug 187139.
Package-Manager: portage-2.1.3_rc9
Diffstat (limited to 'app-office/koffice')
-rw-r--r--app-office/koffice/ChangeLog8
-rw-r--r--app-office/koffice/files/digest-koffice-1.6.3-r13
-rw-r--r--app-office/koffice/files/koffice-xpdf-CVE-2007-3387.diff20
-rw-r--r--app-office/koffice/koffice-1.6.3-r1.ebuild103
4 files changed, 133 insertions, 1 deletions
diff --git a/app-office/koffice/ChangeLog b/app-office/koffice/ChangeLog
index 7c3e710723a8..ddd363a099b8 100644
--- a/app-office/koffice/ChangeLog
+++ b/app-office/koffice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.227 2007/07/26 16:55:51 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.228 2007/07/30 17:58:50 carlo Exp $
+
+*koffice-1.6.3-r1 (30 Jul 2007)
+
+ 30 Jul 2007; Carsten Lohrke <carlo@gentoo.org>
+ +files/koffice-xpdf-CVE-2007-3387.diff, +koffice-1.6.3-r1.ebuild:
+ Fix for bug 187139.
26 Jul 2007; Markus Rothe <corsair@gentoo.org> koffice-1.6.3.ebuild:
Stable on ppc64; bug #178697
diff --git a/app-office/koffice/files/digest-koffice-1.6.3-r1 b/app-office/koffice/files/digest-koffice-1.6.3-r1
new file mode 100644
index 000000000000..0dc1fc75f716
--- /dev/null
+++ b/app-office/koffice/files/digest-koffice-1.6.3-r1
@@ -0,0 +1,3 @@
+MD5 386d388094734f9759977c3267098e30 koffice-1.6.3.tar.bz2 56829391
+RMD160 e474ba48fa983fafb61ad58fb79cddda69ec6908 koffice-1.6.3.tar.bz2 56829391
+SHA256 c3975f0a59f50aaa5547f1709b6fad54f746fd06815859b374676b426dce12cb koffice-1.6.3.tar.bz2 56829391
diff --git a/app-office/koffice/files/koffice-xpdf-CVE-2007-3387.diff b/app-office/koffice/files/koffice-xpdf-CVE-2007-3387.diff
new file mode 100644
index 000000000000..ded0e07205a7
--- /dev/null
+++ b/app-office/koffice/files/koffice-xpdf-CVE-2007-3387.diff
@@ -0,0 +1,20 @@
+--- filters/kword/pdf/xpdf/xpdf/Stream.cc
++++ filters/kword/pdf/xpdf/xpdf/Stream.cc
+@@ -413,13 +413,11 @@ StreamPredictor::StreamPredictor(Stream
+ predLine = NULL;
+ ok = gFalse;
+
+- if (width <= 0 || nComps <= 0 || nBits <= 0 ||
+- nComps >= INT_MAX / nBits ||
+- width >= INT_MAX / nComps / nBits)
+- return;
+-
+ nVals = width * nComps;
+- if (nVals * nBits + 7 <= 0)
++ if (width <= 0 || nComps <= 0 || nBits <= 0 ||
++ nComps >= 4 || nBits > 16 ||
++ width >= INT_MAX / nComps ||
++ nVals >= (INT_MAX - 7) / nBits)
+ return;
+
+ pixBytes = (nComps * nBits + 7) >> 3;
diff --git a/app-office/koffice/koffice-1.6.3-r1.ebuild b/app-office/koffice/koffice-1.6.3-r1.ebuild
new file mode 100644
index 000000000000..83e7981f8916
--- /dev/null
+++ b/app-office/koffice/koffice-1.6.3-r1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.6.3-r1.ebuild,v 1.1 2007/07/30 17:58:50 carlo Exp $
+
+inherit kde
+
+RV="${PV}"
+MY_P="koffice-${RV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="KOffice is an integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+SRC_URI="mirror://kde/stable/koffice-${PV}/src/${P}.tar.bz2"
+#SRC_URI="mirror://kde/unstable/koffice-${PV/_/-}/src/${MY_P}.tar.bz2"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# See bug #130442.
+#IUSE="doc mysql opengl postgres"
+IUSE="doc mysql postgres"
+
+RDEPEND=">=media-libs/freetype-2
+ media-libs/fontconfig
+ media-libs/libart_lgpl
+ dev-libs/libxml2
+ dev-libs/libxslt
+ sys-libs/readline
+ mysql? ( virtual/mysql )
+ postgres? ( <dev-libs/libpqxx-2.6.9 )
+ virtual/python
+ dev-lang/ruby
+ >=app-text/wv2-0.1.9
+ >=app-text/libwpd-0.8.2
+ >=media-gfx/imagemagick-6.2.5.5
+ >=media-libs/lcms-1.15
+ media-libs/tiff
+ media-libs/jpeg
+ >=media-libs/openexr-1.2.2-r2
+ media-libs/libpng
+ >=media-libs/libexif-0.6.13-r1
+ virtual/opengl
+ virtual/glu"
+# opengl? ( virtual/opengl virtual/glu )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+# add blockers on split packages derived from this one
+for x in $(get-child-packages ${CATEGORY}/${PN}); do
+ DEPEND="${DEPEND} !${x}"
+ RDEPEND="${RDEPEND} !${x}"
+done
+
+need-kde 3.45
+
+# TODO: kword sql plugin needs Qt compiled with sql support
+# the dependency on python is needed for scripting support in kexi
+# and for kivio/kiviopart/kiviosdk.
+
+PATCHES="${FILESDIR}/koffice-xpdf-CVE-2007-3387.diff"
+
+pkg_setup() {
+ # use opengl &&
+ if ! built_with_use =x11-libs/qt-3* opengl ; then
+ eerror "You need to build x11-libs/qt with opengl use flag enabled."
+ die
+ fi
+}
+
+src_unpack() {
+ kde_src_unpack
+ # FIXME - disable broken tests for now
+ sed -i -e "s:TESTSDIR =.*:TESTSDIR=:" ${S}/krita/core/Makefile.am \
+ `ls ${S}/krita/colorspaces/*/Makefile.am`
+ sed -i -e "s:toolbar tests:toolbar:" ${S}/kplato/Makefile.am
+
+ if ! [[ $(xhost >> /dev/null 2>/dev/null) ]] ; then
+ einfo "User ${USER} has no X access, disabling some tests."
+ sed -e "s:SUBDIRS = . tests:SUBDIRS = .:" -i lib/store/Makefile.am || die "sed failed"
+ sed -e "s:SUBDIRS = kohyphen . tests:SUBDIRS = kohyphen .:" -i lib/kotext/Makefile.am || die "sed failed"
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_enable mysql) $(use_enable postgres pgsql)"
+ # $(use_enable opengl gl)"
+
+ kde_src_compile
+ if use doc; then
+ make apidox || die
+ fi
+}
+
+src_install() {
+ kde_src_install
+ if use doc; then
+ make DESTDIR="${D}" install-apidox || die
+ fi
+
+ dodoc changes-*
+}