summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-06-06 20:07:59 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-06-06 20:07:59 +0000
commit69d21841a309c7e5dfb5fdccb0af0fee7e20b507 (patch)
treefc1413be4b0982d28c085a95e70f10571fc00b07 /app-office/ical
parentStable on sparc. (diff)
downloadhistorical-69d21841a309c7e5dfb5fdccb0af0fee7e20b507.tar.gz
historical-69d21841a309c7e5dfb5fdccb0af0fee7e20b507.tar.bz2
historical-69d21841a309c7e5dfb5fdccb0af0fee7e20b507.zip
Fix compile error reported by Daniel Webert <daniel_webert@web.de> in bug #52883, which was caused by the sed statement not actually acting on any files. The fix was found by stan <stan@saticed.me.uk>. Additionally, man pages were going into /usr/man not /usr/share/man, so fixed that too.
Diffstat (limited to 'app-office/ical')
-rw-r--r--app-office/ical/ChangeLog8
-rw-r--r--app-office/ical/Manifest4
-rw-r--r--app-office/ical/ical-2.2.1.ebuild7
3 files changed, 13 insertions, 6 deletions
diff --git a/app-office/ical/ChangeLog b/app-office/ical/ChangeLog
index 148d3ddacbbc..175a3c43d892 100644
--- a/app-office/ical/ChangeLog
+++ b/app-office/ical/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/ical
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ChangeLog,v 1.6 2004/03/15 04:11:06 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ChangeLog,v 1.7 2004/06/06 20:07:59 seemant Exp $
+
+ 06 Jun 2004; Seemant Kulleen <seemant@gentoo.org> ical-2.2.1.ebuild:
+ Fix compile error reported by Daniel Webert <daniel_webert@web.de> in bug
+ #52883, which was caused by the sed statement not actually acting on any
+ files. The fix was found by stan <stan@saticed.me.uk>. Additionally, man pages
+ were going into /usr/man not /usr/share/man, so fixed that too.
14 Mar 2004; Seemant Kulleen <seemant@gentoo.org> ical-2.2.1.ebuild:
clean ups for bug #44712 by Michael Sterret <mr_bones_@gentoo.org>
diff --git a/app-office/ical/Manifest b/app-office/ical/Manifest
index e5a3283874f0..1a90b688f034 100644
--- a/app-office/ical/Manifest
+++ b/app-office/ical/Manifest
@@ -1,3 +1,3 @@
+MD5 371491ee5bed5ad9e8474716530f5da2 ical-2.2.1.ebuild 1195
+MD5 fa267a5c147bb410b80b39887ab705d1 ChangeLog 1199
MD5 d2bc892a42d09ce669a9fc5419279a6b files/digest-ical-2.2.1 136
-MD5 781b8bf2b5264d10f3f3fce6277ed510 ChangeLog 830
-MD5 9e4fa21310c4745e176a33d3ddcfb5a5 ical-2.2.1.ebuild 1160
diff --git a/app-office/ical/ical-2.2.1.ebuild b/app-office/ical/ical-2.2.1.ebuild
index b98a476d6a37..dae80b2d7e03 100644
--- a/app-office/ical/ical-2.2.1.ebuild
+++ b/app-office/ical/ical-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ical-2.2.1.ebuild,v 1.7 2004/04/07 18:50:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/ical/ical-2.2.1.ebuild,v 1.8 2004/06/06 20:07:59 seemant Exp $
inherit eutils
@@ -34,7 +34,7 @@ src_unpack() {
sed -i \
-e "s: \@TCL_LIBS\@::" \
-e "s:mkdir:mkdir -p:" \
- Makefile.in
+ ${S}/Makefile.in
has_version '=dev-lang/tcl-8.4*' && epatch ${MY_P}-tcl8.4.patch
}
@@ -46,5 +46,6 @@ src_compile() {
}
src_install() {
- einstall || die "install failed"
+ einstall \
+ MANDIR=${D}/usr/share/man || die "install failed"
}