summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2005-12-06 22:16:45 +0000
committerAlin Năstac <mrness@gentoo.org>2005-12-06 22:16:45 +0000
commita9d032dc2a897d121fcfda029034fad997b278d5 (patch)
treec2e240669192ef75a3006da56a2945987fe5e43c /app-mobilephone
parentremove old version (diff)
downloadhistorical-a9d032dc2a897d121fcfda029034fad997b278d5.tar.gz
historical-a9d032dc2a897d121fcfda029034fad997b278d5.tar.bz2
historical-a9d032dc2a897d121fcfda029034fad997b278d5.zip
Rename list_delete function to list_delete_at - the old name is used in mysql-4.1. See bug #114483.
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/kannel/ChangeLog7
-rw-r--r--app-mobilephone/kannel/Manifest17
-rw-r--r--app-mobilephone/kannel/files/kannel-1.4.0-mysql-list.patch186
-rw-r--r--app-mobilephone/kannel/kannel-1.4.0.ebuild4
4 files changed, 209 insertions, 5 deletions
diff --git a/app-mobilephone/kannel/ChangeLog b/app-mobilephone/kannel/ChangeLog
index d39d72864379..38e12ae123bd 100644
--- a/app-mobilephone/kannel/ChangeLog
+++ b/app-mobilephone/kannel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/kannel
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/kannel/ChangeLog,v 1.3 2005/10/23 17:09:49 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/kannel/ChangeLog,v 1.4 2005/12/06 22:16:45 mrness Exp $
+
+ 06 Dec 2005; Alin Nastac <mrness@gentoo.org>
+ +files/kannel-1.4.0-mysql-list.patch, kannel-1.4.0.ebuild:
+ Rename list_delete function to list_delete_at - the old name is used in
+ mysql-4.1. See bug #114483.
23 Oct 2005; Konstantin Arkhipov <voxus@gentoo.org> kannel-1.4.0.ebuild:
Added to ~amd64.
diff --git a/app-mobilephone/kannel/Manifest b/app-mobilephone/kannel/Manifest
index 5a2a4164d548..3225e3b6ff64 100644
--- a/app-mobilephone/kannel/Manifest
+++ b/app-mobilephone/kannel/Manifest
@@ -1,6 +1,17 @@
-MD5 6937888d37c0507690a2c62479eb2c62 ChangeLog 589
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 46e07d5fc3939036bccefba3c8ab4a1c ChangeLog 803
+MD5 8e6557d777542beebd0e35c01bdc156c metadata.xml 389
+MD5 b66c40044356888f58a83e491406a6fc kannel-1.4.0.ebuild 2264
MD5 a7c05f05df99dd759d119b393cbe59e0 files/digest-kannel-1.4.0 66
MD5 b77f55cded4c364d155c302e81eb07c6 files/kannel-confd 366
MD5 0b79d37344165b8743061f68a18959ce files/kannel-initd 1529
-MD5 5eaf56bd451ab3d093761e2781699344 kannel-1.4.0.ebuild 2220
-MD5 8e6557d777542beebd0e35c01bdc156c metadata.xml 389
+MD5 600c73cb97d9ffdce59537ee94229ee7 files/kannel-1.4.0-mysql-list.patch 7291
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFDlg3oNSP4Vda7IdsRAm7jAJ9KPYMfLUCu1EjzPagyA2+QBcb5hgCfX0nK
+t0hDeA+KiPVnf1BgLslXJps=
+=cA+E
+-----END PGP SIGNATURE-----
diff --git a/app-mobilephone/kannel/files/kannel-1.4.0-mysql-list.patch b/app-mobilephone/kannel/files/kannel-1.4.0-mysql-list.patch
new file mode 100644
index 000000000000..4553aaed25fc
--- /dev/null
+++ b/app-mobilephone/kannel/files/kannel-1.4.0-mysql-list.patch
@@ -0,0 +1,186 @@
+diff -Nru gateway-1.4.0.orig/checks/check_list.c gateway-1.4.0/checks/check_list.c
+--- gateway-1.4.0.orig/checks/check_list.c 2004-01-22 16:08:24.000000000 +0200
++++ gateway-1.4.0/checks/check_list.c 2005-12-06 23:52:08.521615000 +0200
+@@ -155,7 +155,7 @@
+
+ while (list_len(list) > 0) {
+ item = list_get(list, 0);
+- list_delete(list, 0, 1);
++ list_delete_at(list, 0, 1);
+ warning(0, "main: %ld %ld %ld", (long) item->producer,
+ item->num, item->index);
+ }
+diff -Nru gateway-1.4.0.orig/gw/bb_smscconn.c gateway-1.4.0/gw/bb_smscconn.c
+--- gateway-1.4.0.orig/gw/bb_smscconn.c 2004-11-18 18:31:32.000000000 +0200
++++ gateway-1.4.0/gw/bb_smscconn.c 2005-12-06 23:51:42.752004500 +0200
+@@ -631,7 +631,7 @@
+ }
+
+ /* drop old connection from the active smsc list */
+- list_delete(smsc_list, i, 1);
++ list_delete_at(smsc_list, i, 1);
+ /* destroy the connection */
+ smscconn_destroy(conn);
+ list_insert(smsc_list, i, new_conn);
+diff -Nru gateway-1.4.0.orig/gw/dlr_mem.c gateway-1.4.0/gw/dlr_mem.c
+--- gateway-1.4.0.orig/gw/dlr_mem.c 2004-08-08 22:50:18.000000000 +0300
++++ gateway-1.4.0/gw/dlr_mem.c 2005-12-06 23:51:54.400732500 +0200
+@@ -102,7 +102,7 @@
+ gw_rwlock_wrlock(&rwlock);
+ len = list_len(dlr_waiting_list);
+ for (i=0; i < len; i++)
+- list_delete(dlr_waiting_list, i, 1);
++ list_delete_at(dlr_waiting_list, i, 1);
+ gw_rwlock_unlock(&rwlock);
+ }
+
+@@ -171,7 +171,7 @@
+ dlr = list_get(dlr_waiting_list, i);
+
+ if (dlr_mem_entry_match(dlr, smsc, ts, dst) == 0) {
+- list_delete(dlr_waiting_list, i, 1);
++ list_delete_at(dlr_waiting_list, i, 1);
+ dlr_entry_destroy(dlr);
+ break;
+ }
+diff -Nru gateway-1.4.0.orig/gw/smsc/smsc_soap.c gateway-1.4.0/gw/smsc/smsc_soap.c
+--- gateway-1.4.0.orig/gw/smsc/smsc_soap.c 2004-08-28 21:09:19.000000000 +0300
++++ gateway-1.4.0/gw/smsc/smsc_soap.c 2005-12-06 23:51:59.533053250 +0200
+@@ -1955,7 +1955,7 @@
+ debug("bb.soap.init_query",0,"SOAP[%s]: init_query getting a client",octstr_get_cstr(privdata->name));
+
+ /* client is not busy - get it */
+- list_delete(privdata->soap_client, index, 1);
++ list_delete_at(privdata->soap_client, index, 1);
+ break;
+ }
+ cur_client = NULL;
+diff -Nru gateway-1.4.0.orig/gwlib/dbpool.c gateway-1.4.0/gwlib/dbpool.c
+--- gateway-1.4.0.orig/gwlib/dbpool.c 2004-06-08 13:25:16.000000000 +0300
++++ gateway-1.4.0/gwlib/dbpool.c 2005-12-06 23:46:43.589308000 +0200
+@@ -311,7 +311,7 @@
+ pconn = list_get(p->pool, i);
+ if (p->db_ops->check(pconn->conn) != 0) {
+ /* something was wrong, reinitialize the connection */
+- list_delete(p->pool, i, 1);
++ list_delete_at(p->pool, i, 1);
+ dbpool_conn_destroy(pconn);
+ p->curr_size--;
+ reinit++;
+diff -Nru gateway-1.4.0.orig/gwlib/http.c gateway-1.4.0/gwlib/http.c
+--- gateway-1.4.0.orig/gwlib/http.c 2004-08-11 19:41:29.000000000 +0300
++++ gateway-1.4.0/gwlib/http.c 2005-12-06 23:47:02.922516250 +0200
+@@ -2707,7 +2707,7 @@
+ /* Delete old header */
+ header = list_get(headers, i);
+ octstr_destroy(header);
+- list_delete(headers, i, 1);
++ list_delete_at(headers, i, 1);
+
+ /* Adds comma and new value to old header value */
+ octstr_append(value, octstr_imm(", "));
+@@ -2722,7 +2722,7 @@
+ /* Delete this header */
+ header = list_get(headers, j);
+ octstr_destroy(header);
+- list_delete(headers, j, 1);
++ list_delete_at(headers, j, 1);
+ j--;
+ }
+ }
+@@ -2833,7 +2833,7 @@
+ while (i < list_len(headers)) {
+ h = list_get(headers, i);
+ if (header_is_called(h, name)) {
+- list_delete(headers, i, 1);
++ list_delete_at(headers, i, 1);
+ octstr_destroy(h);
+ count++;
+ } else
+@@ -3087,7 +3087,7 @@
+ if (octstr_get_char(element, pos) == '=') {
+ octstr_append_char(auth_scheme, ';');
+ octstr_append(auth_scheme, element);
+- list_delete(result, i, 1);
++ list_delete_at(result, i, 1);
+ octstr_destroy(element);
+ } else {
+ unsigned char semicolon = ';';
+diff -Nru gateway-1.4.0.orig/gwlib/list.c gateway-1.4.0/gwlib/list.c
+--- gateway-1.4.0.orig/gwlib/list.c 2004-08-11 19:41:29.000000000 +0300
++++ gateway-1.4.0/gwlib/list.c 2005-12-06 23:47:16.827385250 +0200
+@@ -226,7 +226,7 @@
+ }
+
+
+-void list_delete(List *list, long pos, long count)
++void list_delete_at(List *list, long pos, long count)
+ {
+ lock(list);
+ delete_items_from_list(list, pos, count);
+diff -Nru gateway-1.4.0.orig/gwlib/list.h gateway-1.4.0/gwlib/list.h
+--- gateway-1.4.0.orig/gwlib/list.h 2004-06-28 12:53:38.000000000 +0300
++++ gateway-1.4.0/gwlib/list.h 2005-12-06 23:45:40.361356500 +0200
+@@ -176,7 +176,7 @@
+ * Delete items from the list. Note that this does _not_ free the memory
+ * for the items, they are just dropped from the list.
+ */
+-void list_delete(List *list, long pos, long count);
++void list_delete_at(List *list, long pos, long count);
+
+
+ /*
+diff -Nru gateway-1.4.0.orig/wap/cookies.c gateway-1.4.0/wap/cookies.c
+--- gateway-1.4.0.orig/wap/cookies.c 2004-03-11 20:02:39.000000000 +0200
++++ gateway-1.4.0/wap/cookies.c 2005-12-06 23:46:05.638936250 +0200
+@@ -393,7 +393,7 @@
+
+ /* We have a match according to 4.3.3 - discard the old one */
+ cookie_destroy(value);
+- list_delete(cookies, pos, 1);
++ list_delete_at(cookies, pos, 1);
+
+ /* Discard the new cookie also if max-age is 0 - set if expiry date is up */
+ if (cookie->max_age == 0) {
+@@ -445,7 +445,7 @@
+ debug("wap.wsp.http", 0, "expire_cookies: Expired cookie (%s)",
+ octstr_get_cstr(value->name));
+ cookie_destroy(value);
+- list_delete(cookies, pos, 1);
++ list_delete_at(cookies, pos, 1);
+ }
+ }
+ }
+diff -Nru gateway-1.4.0.orig/wap/wsp_headers.c gateway-1.4.0/wap/wsp_headers.c
+--- gateway-1.4.0.orig/wap/wsp_headers.c 2004-08-08 23:39:56.000000000 +0300
++++ gateway-1.4.0/wap/wsp_headers.c 2005-12-06 23:46:13.303415250 +0200
+@@ -2041,7 +2041,7 @@
+ Parameter *parm = list_get(parms, i);
+ if (octstr_case_compare(realm, parm->key) == 0) {
+ realmparm = parm;
+- list_delete(parms, i, 1);
++ list_delete_at(parms, i, 1);
+ break;
+ }
+ }
+diff -Nru gateway-1.4.0.orig/wap/wsp_session.c gateway-1.4.0/wap/wsp_session.c
+--- gateway-1.4.0.orig/wap/wsp_session.c 2004-01-22 16:08:25.000000000 +0200
++++ gateway-1.4.0/wap/wsp_session.c 2005-12-06 23:46:30.436486000 +0200
+@@ -816,7 +816,7 @@
+ bad_cap:
+ error(0, "WSP: Found illegal value in capabilities reply.");
+ wsp_cap_dump(cap);
+- list_delete(caps, i, 1);
++ list_delete_at(caps, i, 1);
+ i--;
+ wsp_cap_destroy(cap);
+ continue;
+@@ -964,7 +964,7 @@
+
+ count = wsp_cap_count(req, cap->id, cap->name);
+ if (count == 0 && is_default_cap(cap)) {
+- list_delete(caps, i, 1);
++ list_delete_at(caps, i, 1);
+ wsp_cap_destroy(cap);
+ } else {
+ i++;
diff --git a/app-mobilephone/kannel/kannel-1.4.0.ebuild b/app-mobilephone/kannel/kannel-1.4.0.ebuild
index c7ca06514ffc..4349907d02ec 100644
--- a/app-mobilephone/kannel/kannel-1.4.0.ebuild
+++ b/app-mobilephone/kannel/kannel-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/kannel/kannel-1.4.0.ebuild,v 1.6 2005/10/23 17:09:49 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/kannel/kannel-1.4.0.ebuild,v 1.7 2005/12/06 22:16:45 mrness Exp $
inherit eutils
DESCRIPTION="Powerful SMS and WAP gateway"
@@ -38,6 +38,8 @@ pkg_setup() {
src_unpack() {
unpack ${A}
+ epatch ${FILESDIR}/${P}-mysql-list.patch
+
cd ${S}
#by default, use current directory for logging
sed -i -e 's:/tmp/::' doc/examples/kannel.conf