summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-01-01 18:30:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-01-01 18:30:30 +0000
commitc9d3cd9ded750c8cf287c3515dfda6f8f584921d (patch)
tree7946cbbfee056ef7d932e7476833779927ecafb0 /app-misc
parentBump too (diff)
downloadhistorical-c9d3cd9ded750c8cf287c3515dfda6f8f584921d.tar.gz
historical-c9d3cd9ded750c8cf287c3515dfda6f8f584921d.tar.bz2
historical-c9d3cd9ded750c8cf287c3515dfda6f8f584921d.zip
quoting
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/cdspeed/cdspeed-0.4.ebuild6
-rw-r--r--app-misc/cw/cw-1.0.15.ebuild9
-rw-r--r--app-misc/delay/delay-1.6.ebuild10
-rw-r--r--app-misc/glimpse/glimpse-4.18.5.ebuild6
-rw-r--r--app-misc/gnutu/gnutu-2.0.ebuild8
-rw-r--r--app-misc/ithought/ithought-0.0.5-r1.ebuild14
-rw-r--r--app-misc/misterhouse/misterhouse-2.103.ebuild6
-rw-r--r--app-misc/mtail/mtail-1.1.1-r1.ebuild12
-rw-r--r--app-misc/ondir/ondir-0.2.2.ebuild6
-rw-r--r--app-misc/ps3pf_utils/Manifest6
-rw-r--r--app-misc/vifm/vifm-0.2a.ebuild49
-rw-r--r--app-misc/vifm/vifm-0.3a.ebuild17
-rw-r--r--app-misc/vifm/vifm-0.4.ebuild9
13 files changed, 54 insertions, 104 deletions
diff --git a/app-misc/cdspeed/cdspeed-0.4.ebuild b/app-misc/cdspeed/cdspeed-0.4.ebuild
index fffd98a2aae7..65107ac5d4fb 100644
--- a/app-misc/cdspeed/cdspeed-0.4.ebuild
+++ b/app-misc/cdspeed/cdspeed-0.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cdspeed/cdspeed-0.4.ebuild,v 1.7 2009/09/23 15:59:54 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cdspeed/cdspeed-0.4.ebuild,v 1.8 2010/01/01 18:30:02 ssuominen Exp $
DESCRIPTION="Change the speed of your CD drive"
HOMEPAGE="http://linuxfocus.org/~guido/"
@@ -17,7 +17,7 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i \
-e 's:^CFLAGS=.*:CFLAGS=$(E_CFLAGS):' \
Makefile || die "sed Makefile failed"
diff --git a/app-misc/cw/cw-1.0.15.ebuild b/app-misc/cw/cw-1.0.15.ebuild
index 3f43a93dd942..d3fee4a89124 100644
--- a/app-misc/cw/cw-1.0.15.ebuild
+++ b/app-misc/cw/cw-1.0.15.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cw/cw-1.0.15.ebuild,v 1.8 2009/09/23 16:00:44 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cw/cw-1.0.15.ebuild,v 1.9 2010/01/01 18:29:41 ssuominen Exp $
inherit toolchain-funcs
@@ -17,7 +17,8 @@ DEPEND=">=sys-apps/sed-4"
RDEPEND=""
src_unpack() {
- unpack ${A} && cd ${S}
+ unpack ${A}
+ cd "${S}"
sed -i 's|\(CWLIB=\)/usr/local/lib/cw|\1/usr/lib/cw|' bin/colorcfg || \
die "sed failed"
}
@@ -38,7 +39,7 @@ src_install() {
doman man/*
dodoc CHANGES CONTRIB INSTALL README PLATFORM doc/README*
- cd ${S}/bin
+ cd "${S}"/bin
dobin cw cwu colorcfg
# app-misc/color currently conflicts; hopefully 'colors' is safe
newbin color colors
diff --git a/app-misc/delay/delay-1.6.ebuild b/app-misc/delay/delay-1.6.ebuild
index 6e77637cc213..9e0d3f876c41 100644
--- a/app-misc/delay/delay-1.6.ebuild
+++ b/app-misc/delay/delay-1.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/delay/delay-1.6.ebuild,v 1.20 2009/09/23 16:01:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/delay/delay-1.6.ebuild,v 1.21 2010/01/01 18:27:32 ssuominen Exp $
inherit toolchain-funcs
@@ -13,8 +13,6 @@ SLOT="0"
KEYWORDS="~alpha amd64 ~ia64 mips ppc ppc64 sparc x86"
IUSE=""
-DEPEND=""
-
src_compile() {
sed -i -e "s/#include <stdio.h>/&\n#include <stdlib.h>/" delay.c
tc-export CC
@@ -23,6 +21,6 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install || die
- dodoc ChangeLog README INSTALL
+ make DESTDIR="${D}" install || die
+ dodoc ChangeLog README
}
diff --git a/app-misc/glimpse/glimpse-4.18.5.ebuild b/app-misc/glimpse/glimpse-4.18.5.ebuild
index d5d3e51839cd..04e32d701109 100644
--- a/app-misc/glimpse/glimpse-4.18.5.ebuild
+++ b/app-misc/glimpse/glimpse-4.18.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/glimpse/glimpse-4.18.5.ebuild,v 1.11 2008/01/11 21:00:12 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/glimpse/glimpse-4.18.5.ebuild,v 1.12 2010/01/01 18:21:45 ssuominen Exp $
inherit flag-o-matic eutils
@@ -18,7 +18,7 @@ RDEPEND="!dev-libs/tre
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i \
-e "s:CC=.*:CC=$(tc-getCC):" \
-e 's:-O3 -fomit-frame-pointer:$(OPTIMIZEFLAGS):' \
diff --git a/app-misc/gnutu/gnutu-2.0.ebuild b/app-misc/gnutu/gnutu-2.0.ebuild
index dd3bcf1a240b..238de64571f3 100644
--- a/app-misc/gnutu/gnutu-2.0.ebuild
+++ b/app-misc/gnutu/gnutu-2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gnutu/gnutu-2.0.ebuild,v 1.2 2006/01/01 09:48:23 chriswhite Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gnutu/gnutu-2.0.ebuild,v 1.3 2010/01/01 18:21:13 ssuominen Exp $
inherit mono eutils
@@ -23,9 +23,9 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-event.patch
# lmao :/
- rm ${S}/pixmaps/Makefile.am~
+ rm "${S}"/pixmaps/Makefile.am~
}
src_install() {
- make install DESTDIR=${D} || die
+ make install DESTDIR="${D}" || die
}
diff --git a/app-misc/ithought/ithought-0.0.5-r1.ebuild b/app-misc/ithought/ithought-0.0.5-r1.ebuild
index d5027eb044a2..9144f6c9ba9f 100644
--- a/app-misc/ithought/ithought-0.0.5-r1.ebuild
+++ b/app-misc/ithought/ithought-0.0.5-r1.ebuild
@@ -1,11 +1,9 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ithought/ithought-0.0.5-r1.ebuild,v 1.20 2005/06/05 11:50:37 hansmi Exp $
-
-#emerge doesn't yet support things like a5
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ithought/ithought-0.0.5-r1.ebuild,v 1.21 2010/01/01 18:23:49 ssuominen Exp $
MY_P=${P/0.0./a}
-S=${WORKDIR}/${MY_P}
+
DESCRIPTION="An internet-aware personal thought manager"
HOMEPAGE="http://ithought.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
@@ -18,7 +16,9 @@ IUSE=""
DEPEND="=x11-libs/gtk+-1.2*
dev-libs/libxml2"
+S=${WORKDIR}/${MY_P}
+
src_install() {
- make DESTDIR=${D} install || die
- dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
}
diff --git a/app-misc/misterhouse/misterhouse-2.103.ebuild b/app-misc/misterhouse/misterhouse-2.103.ebuild
index f63edb0faa57..488402f50a79 100644
--- a/app-misc/misterhouse/misterhouse-2.103.ebuild
+++ b/app-misc/misterhouse/misterhouse-2.103.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/misterhouse/misterhouse-2.103.ebuild,v 1.5 2007/07/12 03:35:11 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/misterhouse/misterhouse-2.103.ebuild,v 1.6 2010/01/01 18:18:01 ssuominen Exp $
DESCRIPTION="Mister House, an open source home automation program with X10 support"
HOMEPAGE="http://misterhouse.sf.net/"
@@ -30,7 +30,7 @@ src_install() {
cp -r "${S}/bin" "${D}/opt/misterhouse"
cp -r "${S}/code" "${D}/opt/misterhouse"
cp -r "${S}/data" "${D}/opt/misterhouse"
- for a in ${S}/docs/*; do
+ for a in "${S}"/docs/*; do
dodoc ${a}
done
dosym /usr/share/doc/${PF} /opt/misterhouse/docs
diff --git a/app-misc/mtail/mtail-1.1.1-r1.ebuild b/app-misc/mtail/mtail-1.1.1-r1.ebuild
index a57905005444..0161b722953c 100644
--- a/app-misc/mtail/mtail-1.1.1-r1.ebuild
+++ b/app-misc/mtail/mtail-1.1.1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/mtail/mtail-1.1.1-r1.ebuild,v 1.14 2008/02/03 15:30:00 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/mtail/mtail-1.1.1-r1.ebuild,v 1.15 2010/01/01 18:22:54 ssuominen Exp $
inherit eutils
@@ -19,11 +19,11 @@ RDEPEND="dev-lang/python"
src_unpack() {
unpack ${P}.tgz
- cd ${S}
- epatch ${FILESDIR}/${P}-remove-blanks.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-remove-blanks.patch
}
src_install() {
- dobin mtail
- dodoc CHANGES mtailrc.sample README ${DISTDIR}/mtailrc-syslog.sample
+ dobin mtail || die
+ dodoc CHANGES mtailrc.sample README "${DISTDIR}"/mtailrc-syslog.sample
}
diff --git a/app-misc/ondir/ondir-0.2.2.ebuild b/app-misc/ondir/ondir-0.2.2.ebuild
index 00ecb9665ad5..9b7f89aea68e 100644
--- a/app-misc/ondir/ondir-0.2.2.ebuild
+++ b/app-misc/ondir/ondir-0.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/ondir/ondir-0.2.2.ebuild,v 1.10 2009/09/23 16:06:18 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/ondir/ondir-0.2.2.ebuild,v 1.11 2010/01/01 18:30:30 ssuominen Exp $
inherit toolchain-funcs
@@ -17,7 +17,7 @@ DEPEND="sys-apps/sed"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
sed -i \
-e "s:\(/man/.*$\):/share\1:g" \
-e "s:-g:${CFLAGS}:" Makefile || die "sed Makefile failed"
diff --git a/app-misc/ps3pf_utils/Manifest b/app-misc/ps3pf_utils/Manifest
index 25b79d750417..336d838b8d64 100644
--- a/app-misc/ps3pf_utils/Manifest
+++ b/app-misc/ps3pf_utils/Manifest
@@ -1,8 +1,8 @@
DIST ps3-utils-2.2.0.tar.bz2 361144 RMD160 f5cec86271ca31fa25ab2575b512492dbc0638ec SHA1 48fd45d44cd55ab22a2c3f64cce198b07fae05fa SHA256 b457354fd828229aedfb243fe0df748c2778f295ec1a4297e2cfa47b5b666b8b
DIST ps3-utils-2.3.tar.bz2 351066 RMD160 f959a32fa169f395b928991775d3525cc991dee4 SHA1 4f7eddc0a07880b951aa0b3295c7af1aa113814f SHA256 c44a84da3cf37ecc69b36f6079a814e680cf37c74cb7d55f457635adb8209351
DIST ps3pf_utils-2.1.1.tar.bz2 980229 RMD160 64611660e571e5ce51ba75d4b7cca18fa4b565f4 SHA1 74dcbfcdd9a90918fc5980306b57cae5aeb3c84b SHA256 9fc907b3b82198ae2ca45699885f1b7f4d28c7d8df1b8ef96ba3cd8476f0cd49
-EBUILD ps3pf_utils-2.1.1.ebuild 880 RMD160 be4b3931ac9c5cee9bc9a183dfbb7e49075efd3b SHA1 5b394c42419af1601b63db869094b634be26b4ce SHA256 f0eb11ca33f77874d3cf8efb162adb904c28fb395778403993d92e1d4433b643
-EBUILD ps3pf_utils-2.2.0.ebuild 856 RMD160 1d4f4bbc007489c6e2d57eaae2c8edc4b6b91f51 SHA1 8efa24b0ff82ba78c01b77a02d17f1f1770965ec SHA256 f5c518cadff1155ce192cd1107ede08ab824d6b0d398eca84b10940bcd4a4fcc
-EBUILD ps3pf_utils-2.3.ebuild 855 RMD160 843a7a26e609676e53396e50fa1409f0b0ebf8b8 SHA1 14b737d86dc53ca43d9440b0092bc03f67f4c37c SHA256 7eba27a7c0bdf6ae82e979a7e2463b012cd635b2c3dc2b2603ae2161bee797f6
+EBUILD ps3pf_utils-2.1.1.ebuild 677 RMD160 c56d0f80aa75ceb96610ed8c027acf110f4f6935 SHA1 b72cfdc7ca55c449dbf019f2089630259fc25564 SHA256 41a9ca73af942d5e4ff699b18d7ba13a77b816ea5e5673a992185b7daaeb84ac
+EBUILD ps3pf_utils-2.2.0.ebuild 645 RMD160 2a35be509bbb5d31b4502603d057d1e65c517551 SHA1 6519839f47d6e3558c318a0a8ff6fb2ad7b0e216 SHA256 99a457fa1247297c351069b54290a523b4d2fa6a2ce13366ee90da7fc15aa753
+EBUILD ps3pf_utils-2.3.ebuild 694 RMD160 c4775a9c9d6bf91f958db229e98968a7185f7c15 SHA1 561037ec8739acad52ed24816dba5d07082ff2ad SHA256 a960e44b6ad2241f31e081bd707e7d3c96b6bfd5b2d91109bff4f2e25fc12aea
MISC ChangeLog 669 RMD160 dde17bd032abbb3aa243df9b7f0273c9350f8e83 SHA1 818551132143fa8b6fe9325e0c1db0dd9edfa99f SHA256 e73c5b5d90341f0b9cb1af54af4c48c803e5973d4a6ae1e11f468e47b69bc676
MISC metadata.xml 245 RMD160 8638b7d90df2c413afd9c975553010d6bfa97965 SHA1 52046272a686ecad1b7223b29d6701e5118ae3ff SHA256 a09ece2e39954e335916376b6a82a1c14d4168b114ebbfbf2d50ee27ef06fd26
diff --git a/app-misc/vifm/vifm-0.2a.ebuild b/app-misc/vifm/vifm-0.2a.ebuild
deleted file mode 100644
index b8d82493cd5e..000000000000
--- a/app-misc/vifm/vifm-0.2a.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/vifm/vifm-0.2a.ebuild,v 1.11 2008/03/18 18:36:11 armin76 Exp $
-
-DESCRIPTION="Console file manager with vi/vim-like keybindings"
-HOMEPAGE="http://vifm.sourceforge.net/"
-SRC_URI="mirror://sourceforge/vifm/${P}.tar.gz"
-LICENSE="GPL-2"
-SLOT="0"
-
-KEYWORDS="amd64 ~ppc s390 x86"
-IUSE=""
-DEPEND=">=sys-apps/sed-4.0"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
- sed -i -e "s:(datadir)/@PACKAGE@:(datadir)/${P}:" \
- Makefile.in
-
- cd ${S}/src
- sed -i -e "s:(datadir)/@PACKAGE@:(datadir)/${P}:" \
- Makefile.in
-
- sed -i -e "s:/usr/local/share/vifm:/usr/share/${P}:g" \
- config.c
-}
-
-src_compile() {
- econf || die
- emake || die
-}
-
-src_install() {
- einstall || die
-
- dodoc INSTALL AUTHORS TODO README
-}
-pkg_postinst() {
- elog "To use vim to view the vifm help, copy /usr/share/${P}/vifm.txt"
- elog "to ~/.vim/doc/ and run ':helptags ~/.vim/doc' in vim"
- elog "Then edit ~/.vifm/vifmrc${PV/a/} and set USE_VIM_HELP=1"
- elog ""
- elog "To use the vifm plugin in vim, copy /usr/share/${P}/vifm.vim to"
- elog "/usr/share/vim/vim62/"
-}
diff --git a/app-misc/vifm/vifm-0.3a.ebuild b/app-misc/vifm/vifm-0.3a.ebuild
index 66a893137dff..9202035c9f11 100644
--- a/app-misc/vifm/vifm-0.3a.ebuild
+++ b/app-misc/vifm/vifm-0.3a.ebuild
@@ -1,27 +1,26 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/vifm/vifm-0.3a.ebuild,v 1.4 2008/10/27 05:48:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/vifm/vifm-0.3a.ebuild,v 1.5 2010/01/01 18:17:30 ssuominen Exp $
DESCRIPTION="Console file manager with vi/vim-like keybindings"
HOMEPAGE="http://vifm.sourceforge.net/"
SRC_URI="mirror://sourceforge/vifm/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="amd64 ~ppc s390 x86"
IUSE=""
-DEPEND=">=sys-apps/sed-4.0"
-S="${WORKDIR}/${P}"
+DEPEND=">=sys-apps/sed-4.0"
src_unpack() {
unpack ${A}
+ cd "${S}"
- cd ${S}
sed -i -e "s:(datadir)/@PACKAGE@:(datadir)/${P}:" \
Makefile.in
- cd ${S}/src
+ cd "${S}"/src
sed -i -e "s:(datadir)/@PACKAGE@:(datadir)/${P}:" \
Makefile.in
@@ -31,9 +30,9 @@ src_unpack() {
src_install() {
einstall || die
-
- dodoc INSTALL AUTHORS TODO README
+ dodoc AUTHORS TODO README
}
+
pkg_postinst() {
elog "To use vim to view the vifm help, copy /usr/share/${P}/vifm.txt"
elog "to ~/.vim/doc/ and run ':helptags ~/.vim/doc' in vim"
diff --git a/app-misc/vifm/vifm-0.4.ebuild b/app-misc/vifm/vifm-0.4.ebuild
index cb7d5a9aa3c3..6e04ce6c9a76 100644
--- a/app-misc/vifm/vifm-0.4.ebuild
+++ b/app-misc/vifm/vifm-0.4.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/vifm/vifm-0.4.ebuild,v 1.1 2008/09/23 01:03:42 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/vifm/vifm-0.4.ebuild,v 1.2 2010/01/01 18:17:30 ssuominen Exp $
DESCRIPTION="Console file manager with vi/vim-like keybindings"
HOMEPAGE="http://vifm.sourceforge.net/"
SRC_URI="mirror://sourceforge/vifm/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="~amd64 ~ppc ~s390 ~x86"
IUSE=""
+
DEPEND="sys-apps/sed
sys-libs/ncurses"
@@ -25,7 +26,7 @@ src_unpack() {
src_install() {
einstall || die
- dodoc INSTALL AUTHORS TODO README
+ dodoc AUTHORS TODO README
}
pkg_postinst() {