summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 21:00:46 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 21:00:46 +0000
commita871cd12d67b676f4f1e502ac21e010dfb37ff6e (patch)
treed983763714b31b14af020de7d7a81bff91d8d597 /app-misc
parentnew version (diff)
downloadhistorical-a871cd12d67b676f4f1e502ac21e010dfb37ff6e.tar.gz
historical-a871cd12d67b676f4f1e502ac21e010dfb37ff6e.tar.bz2
historical-a871cd12d67b676f4f1e502ac21e010dfb37ff6e.zip
Changed econf||die to econf
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/joy2key/joy2key-1.6.ebuild8
-rw-r--r--app-misc/jpilot/jpilot-0.99.2-r1.ebuild18
-rw-r--r--app-misc/jpilot/jpilot-0.99.3.ebuild18
3 files changed, 19 insertions, 25 deletions
diff --git a/app-misc/joy2key/joy2key-1.6.ebuild b/app-misc/joy2key/joy2key-1.6.ebuild
index e9376e496ff4..b7097f792e4a 100644
--- a/app-misc/joy2key/joy2key-1.6.ebuild
+++ b/app-misc/joy2key/joy2key-1.6.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/joy2key/joy2key-1.6.ebuild,v 1.10 2002/10/20 18:40:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/joy2key/joy2key-1.6.ebuild,v 1.11 2002/11/30 20:58:52 vapier Exp $
-IUSE="X"
-
-S=${WORKDIR}/${P}
DESCRIPTION="An application that translates joystick events to keyboard events"
SRC_URI="http://www-unix.oit.umass.edu/~tetron/technology/joy2key/${P}.tar.gz"
HOMEPAGE="http://www-unix.out.umass.edu/~tetron/technology/joy2key/"
@@ -12,6 +9,7 @@ HOMEPAGE="http://www-unix.out.umass.edu/~tetron/technology/joy2key/"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86"
+IUSE="X"
DEPEND="X? ( virtual/x11 )"
@@ -20,7 +18,7 @@ src_compile() {
use X || myconf="--disable-X"
CFLAGS=${CFLAGS/-O?/}
- econf ${myconf} || die
+ econf ${myconf}
make || die
}
diff --git a/app-misc/jpilot/jpilot-0.99.2-r1.ebuild b/app-misc/jpilot/jpilot-0.99.2-r1.ebuild
index d8273b67c685..bbe3568cb8d2 100644
--- a/app-misc/jpilot/jpilot-0.99.2-r1.ebuild
+++ b/app-misc/jpilot/jpilot-0.99.2-r1.ebuild
@@ -1,26 +1,26 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jpilot/jpilot-0.99.2-r1.ebuild,v 1.10 2002/10/20 18:40:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jpilot/jpilot-0.99.2-r1.ebuild,v 1.11 2002/11/30 20:59:40 vapier Exp $
SYNCMAL="0.71"
MALSYNC="2.0.7"
-S=${WORKDIR}/${P}
DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
SRC_URI="http://jpilot.org/${P}.tar.gz
http://www.tomw.org/malsync/malsync_${MALSYNC}.src.tar.gz
http://jasonday.home.att.net/code/syncmal/jpilot-syncmal_${SYNCMAL}.tar.gz"
HOMEPAGE="http://jpilot.org/"
-IUSE="nls"
# In order to use the malsync plugin you'll need to refer to the homepage
# for jpilot-syncmal http://jasonday.home.att.net/code/syncmal/
# And you'll also need an avangto account.
-DEPEND="=x11-libs/gtk+-1.2* >=dev-libs/pilot-link-0.9.5"
-
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ppc"
+IUSE="nls"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=dev-libs/pilot-link-0.9.5"
src_unpack() {
unpack ${P}.tar.gz
@@ -32,18 +32,16 @@ src_unpack() {
src_compile() {
use nls || NLS_OPTION="--disable-nls"
-
- econf ${NLS_OPTION} || die
+ econf ${NLS_OPTION}
# make sure we use $CFLAGS
mv Makefile Makefile.old
sed -e "s/-g -O2/${CFLAGS}/" Makefile.old > Makefile
-
emake || die
# build malsync plugin
cd ${S}/jpilot-syncmal_${SYNCMAL}
- econf || die
+ econf
emake || die
}
@@ -51,7 +49,7 @@ src_install() {
# work around for broken Makefile
dodir /usr/bin
- einstall || die
+ einstall
insinto /usr/lib/jpilot/plugins
doins jpilot-syncmal_${SYNCMAL}/.libs/libsyncmal.so
diff --git a/app-misc/jpilot/jpilot-0.99.3.ebuild b/app-misc/jpilot/jpilot-0.99.3.ebuild
index 4a4d76d1a0eb..941084d8fc12 100644
--- a/app-misc/jpilot/jpilot-0.99.3.ebuild
+++ b/app-misc/jpilot/jpilot-0.99.3.ebuild
@@ -1,26 +1,26 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/jpilot/jpilot-0.99.3.ebuild,v 1.1 2002/11/18 05:35:36 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/jpilot/jpilot-0.99.3.ebuild,v 1.2 2002/11/30 21:00:46 vapier Exp $
SYNCMAL="0.71"
MALSYNC="2.0.7"
-S=${WORKDIR}/${P}
DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
SRC_URI="http://jpilot.org/${P}.tar.gz
http://www.tomw.org/malsync/malsync_${MALSYNC}.src.tar.gz
http://jasonday.home.att.net/code/syncmal/jpilot-syncmal_${SYNCMAL}.tar.gz"
HOMEPAGE="http://jpilot.org/"
-IUSE="nls"
# In order to use the malsync plugin you'll need to refer to the homepage
# for jpilot-syncmal http://jasonday.home.att.net/code/syncmal/
# And you'll also need an avangto account.
-DEPEND="=x11-libs/gtk+-1.2* >=dev-libs/pilot-link-0.11.5"
-
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86"
+IUSE="nls"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ >=dev-libs/pilot-link-0.11.5"
src_unpack() {
unpack ${P}.tar.gz
@@ -32,18 +32,16 @@ src_unpack() {
src_compile() {
use nls || NLS_OPTION="--disable-nls"
-
- econf ${NLS_OPTION} || die
+ econf ${NLS_OPTION}
# make sure we use $CFLAGS
mv Makefile Makefile.old
sed -e "s/-g -O2/${CFLAGS}/" Makefile.old > Makefile
-
emake || die
# build malsync plugin
cd ${S}/jpilot-syncmal_${SYNCMAL}
- econf || die
+ econf
emake || die
}
@@ -51,7 +49,7 @@ src_install() {
# work around for broken Makefile
dodir /usr/bin
- einstall || die
+ einstall
insinto /usr/lib/jpilot/plugins
doins jpilot-syncmal_${SYNCMAL}/.libs/libsyncmal.so