summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-04-08 03:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-04-08 03:52:02 +0000
commit2eca167bd0e5e1a1a719e39559b2d777f3fbe16c (patch)
tree262ccc86ed5bf8f022c2d42987414926d729dbac /app-misc/gtypist/gtypist-2.5.ebuild
parentAdded new ebuild: (diff)
downloadhistorical-2eca167bd0e5e1a1a719e39559b2d777f3fbe16c.tar.gz
historical-2eca167bd0e5e1a1a719e39559b2d777f3fbe16c.tar.bz2
historical-2eca167bd0e5e1a1a719e39559b2d777f3fbe16c.zip
New ebuild.
Diffstat (limited to 'app-misc/gtypist/gtypist-2.5.ebuild')
-rw-r--r--app-misc/gtypist/gtypist-2.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-misc/gtypist/gtypist-2.5.ebuild b/app-misc/gtypist/gtypist-2.5.ebuild
new file mode 100644
index 000000000000..54373c3c34fb
--- /dev/null
+++ b/app-misc/gtypist/gtypist-2.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Matthew Kennedy <mkennedy@gentoo.org>
+# Author: Matthew Kennedy <mbkennedy@ieee.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.4 2002/03/12 16:05:09 tod Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNU Typist (also called gtypist) is a universal typing tutor."
+SRC_URI="ftp://ftp.gnu.org/gnu/gtypist/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/gtypist/gtypist.html"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2"
+
+src_compile() {
+ local myconf
+
+ # gtypist uses a built in gettext
+ use nls && myconf="--enable-nls" || \
+ myconf="--disable-nls"
+
+ # gtypist also produces some Emacs/XEmacs editing modes if
+ # emacs/xemacs is present. if emacs/xemacs is not present then
+ # these emacs modes are not compiled or installed.
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README TODO THANKS
+}