summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-10-28 05:59:25 +0000
committerMike Frysinger <vapier@gentoo.org>2002-10-28 05:59:25 +0000
commit56fac1159083f6ba70d83e1cd2da3ad6d052548c (patch)
treee880b356fe5d58a13bbdb6158c114970803e55d0 /app-misc/figlet
parentVersion bump (diff)
downloadhistorical-56fac1159083f6ba70d83e1cd2da3ad6d052548c.tar.gz
historical-56fac1159083f6ba70d83e1cd2da3ad6d052548c.tar.bz2
historical-56fac1159083f6ba70d83e1cd2da3ad6d052548c.zip
+x fix from #9804
Diffstat (limited to 'app-misc/figlet')
-rw-r--r--app-misc/figlet/ChangeLog8
-rw-r--r--app-misc/figlet/figlet-22-r1.ebuild40
-rw-r--r--app-misc/figlet/files/digest-figlet-22-r11
-rw-r--r--app-misc/figlet/files/figlet-22-r1-gentoo.diff40
4 files changed, 87 insertions, 2 deletions
diff --git a/app-misc/figlet/ChangeLog b/app-misc/figlet/ChangeLog
index f04f0ae0c300..02061327e78a 100644
--- a/app-misc/figlet/ChangeLog
+++ b/app-misc/figlet/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for app-misc/figlet
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/ChangeLog,v 1.1 2002/02/01 21:53:08 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/ChangeLog,v 1.2 2002/10/28 05:59:25 vapier Exp $
+
+*figlet-22-r1 (28 Oct 2002)
+
+ 28 Oct 2002; Mike Frysinger <vapier@gentoo.org> :
+ Added fix from #9804 (not all scripts were installed +x)
*figlet-22 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/app-misc/figlet/figlet-22-r1.ebuild b/app-misc/figlet/figlet-22-r1.ebuild
new file mode 100644
index 000000000000..e3bce5abf1bd
--- /dev/null
+++ b/app-misc/figlet/figlet-22-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/figlet/figlet-22-r1.ebuild,v 1.1 2002/10/28 05:59:25 vapier Exp $
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="FIGlet is a program for making large letters out of ordinary text"
+SRC_URI="ftp://ftp.plig.org/pub/figlet/program/unix/${PN}${PV}.tar.gz"
+HOMEPAGE="http://st-www.cs.uiuc.edu/users/chai/figlet.html"
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="x86 sparc64"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PF}-gentoo.diff || die
+ sed "s/CFLAGS = -g/CFLAGS = ${CFLAGS}/g" < Makefile > Makefile.new
+ mv -f Makefile.new Makefile
+}
+
+
+src_compile() {
+ make clean || die
+ make figlet || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/share/man/man6
+ chmod +x figlist showfigfonts
+ make \
+ DESTDIR=${D}/usr/bin \
+ MANDIR=${D}/usr/share/man/man6 \
+ DEFAULTFONTDIR=${D}/usr/share/figlet \
+ install || die
+
+ dodoc Artistic-license.txt FTP-NOTE README showfigfonts figmagic figfont.txt
+}
diff --git a/app-misc/figlet/files/digest-figlet-22-r1 b/app-misc/figlet/files/digest-figlet-22-r1
new file mode 100644
index 000000000000..0a0dfce1b86b
--- /dev/null
+++ b/app-misc/figlet/files/digest-figlet-22-r1
@@ -0,0 +1 @@
+MD5 63afcf43505fbe0c9a936ee3b97d4288 figlet22.tar.gz 166966
diff --git a/app-misc/figlet/files/figlet-22-r1-gentoo.diff b/app-misc/figlet/files/figlet-22-r1-gentoo.diff
new file mode 100644
index 000000000000..515861a64d7f
--- /dev/null
+++ b/app-misc/figlet/files/figlet-22-r1-gentoo.diff
@@ -0,0 +1,40 @@
+diff -Nur figlet22/Makefile figlet22-new/Makefile
+--- figlet22/Makefile Tue Feb 18 16:02:28 1997
++++ figlet22-new/Makefile Thu Apr 26 22:27:46 2001
+@@ -13,22 +13,29 @@
+ CFLAGS = -g
+
+ # Where the executables should be put
+-DESTDIR = /usr/games
++ifndef DESTDIR
++ DESTDIR = /usr/bin/
++endif
+
+ # Where the man page should be put
+-MANDIR = /usr/man/man6
++ifndef MANDIR
++ MANDIR = /usr/share/man/man6
++endif
+
+ # Where figlet will search first for fonts (the ".flf" files).
+-DEFAULTFONTDIR = $(DESTDIR)/lib/figlet.dir
++ifndef DEFAULTFONTDIR
++ DEFAULTFONTDIR = /usr/share/figlet
++endif
+ # Use this definition if you can't put things in /usr/games
+-DEFAULTFONTDIR = fonts
++#DEFAULTFONTDIR = fonts
+
+ # The filename of the font to be used if no other is specified
+ # (standard.flf is recommended, but any other can be used).
+ # This font file should reside in the directory specified by
+ # DEFAULTFONTDIR.
+-DEFAULTFONTFILE = standard.flf
+-
++ifndef DEFAULTFONTFILE
++ DEFAULTFONTFILE = standard.flf
++endif
+ ##
+ ## END OF CONFIGURATION SECTION
+ ##
+Binary files figlet22/figlet and figlet22-new/figlet differ