summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 03:45:42 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 03:45:42 +0000
commited34e375961396c31c32ea54685059966d51665e (patch)
tree318409b3268d5b5cf241ef4ccc6ea1c977e22b7c /app-misc/colortail
parentQA - fix use invocation (diff)
downloadhistorical-ed34e375961396c31c32ea54685059966d51665e.tar.gz
historical-ed34e375961396c31c32ea54685059966d51665e.tar.bz2
historical-ed34e375961396c31c32ea54685059966d51665e.zip
change glibc to libc and clean up other horribly ugly ebuilds
Diffstat (limited to 'app-misc/colortail')
-rw-r--r--app-misc/colortail/colortail-0.3.0-r2.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/app-misc/colortail/colortail-0.3.0-r2.ebuild b/app-misc/colortail/colortail-0.3.0-r2.ebuild
index 5add8d4b7d58..dd5f9c1327fe 100644
--- a/app-misc/colortail/colortail-0.3.0-r2.ebuild
+++ b/app-misc/colortail/colortail-0.3.0-r2.ebuild
@@ -1,23 +1,24 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/colortail/colortail-0.3.0-r2.ebuild,v 1.11 2004/06/24 22:06:36 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/colortail/colortail-0.3.0-r2.ebuild,v 1.12 2004/06/28 03:30:17 vapier Exp $
+
+inherit eutils
-S=${WORKDIR}/${P}
DESCRIPTION="Colortail custom colors your log files and works like tail"
-SRC_URI="http://www.student.hk-r.se/~pt98jan/colortail-0.3.0.tar.gz"
HOMEPAGE="http://www.student.hk-r.se/~pt98jan/colortail.html"
+SRC_URI="http://www.student.hk-r.se/~pt98jan/colortail-0.3.0.tar.gz"
-DEPEND="virtual/glibc"
-
-SLOT="0"
LICENSE="GPL-2"
-IUSE=""
+SLOT="0"
KEYWORDS="x86 ppc"
+IUSE=""
+
+DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd ${S}
- patch -p1 < ${FILESDIR}/${P}-gcc3.patch || die "Patching failed"
+ epatch ${FILESDIR}/${P}-gcc3.patch
}
src_compile() {
@@ -25,8 +26,7 @@ src_compile() {
make || die
}
-src_install() {
-
+src_install() {
make DESTDIR=${D} install || die
dodoc README example-conf/conf*
dodir /usr/bin/wrappers
@@ -34,8 +34,7 @@ src_install() {
}
pkg_postinst() {
- einfo
- if grep /usr/bin/wrappers /etc/profile > /dev/null
+ if grep /usr/bin/wrappers ${ROOT}/etc/profile > /dev/null
then
einfo "/etc/profile already updated for wrappers"
else
@@ -44,5 +43,4 @@ pkg_postinst() {
einfo "#Put /usr/bin/wrappers in path before /usr/bin"
einfo 'export PATH=/usr/bin/wrappers:${PATH}'
fi
- einfo
}