summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2005-11-01 14:26:12 +0000
committerCaleb Tennis <caleb@gentoo.org>2005-11-01 14:26:12 +0000
commite32fe9bdd0c73c7d3c31e694e7cdba1624239914 (patch)
treec4dc72b69eab0e17f9192c36a8816626d5e3323d /app-misc/alexandria/alexandria-0.6.1.ebuild
parentStable on x86. (diff)
downloadhistorical-e32fe9bdd0c73c7d3c31e694e7cdba1624239914.tar.gz
historical-e32fe9bdd0c73c7d3c31e694e7cdba1624239914.tar.bz2
historical-e32fe9bdd0c73c7d3c31e694e7cdba1624239914.zip
Version bump
Package-Manager: portage-2.0.53_rc7
Diffstat (limited to 'app-misc/alexandria/alexandria-0.6.1.ebuild')
-rw-r--r--app-misc/alexandria/alexandria-0.6.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-misc/alexandria/alexandria-0.6.1.ebuild b/app-misc/alexandria/alexandria-0.6.1.ebuild
new file mode 100644
index 000000000000..4633aab51076
--- /dev/null
+++ b/app-misc/alexandria/alexandria-0.6.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/alexandria/alexandria-0.6.1.ebuild,v 1.1 2005/11/01 14:26:12 caleb Exp $
+
+inherit ruby gnome2 eutils
+
+IUSE=""
+
+DESCRIPTION="A GNOME application to help you manage your book collection"
+HOMEPAGE="http://alexandria.rubyforge.org/"
+SRC_URI="http://rubyforge.org/frs/download.php/6308/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+USE_RUBY="ruby18"
+
+DOCS="AUTHORS COPYING ChangeLog HACKING NEWS README TODO"
+
+RDEPEND=">=dev-lang/ruby-1.8.0
+ >=dev-ruby/ruby-gettext-0.6.1
+ >=dev-ruby/ruby-gnome2-0.12.0
+ >=dev-ruby/ruby-libglade2-0.12.0
+ >=dev-ruby/ruby-gconf2-0.12.0
+ >=dev-ruby/ruby-gdkpixbuf2-0.12.0
+ >=dev-ruby/ruby-amazon-0.8.3
+ >=dev-ruby/ruby-zoom-0.2.0"
+
+src_compile() {
+ ruby install.rb config || die
+ ruby install.rb setup || die
+}
+
+src_install() {
+ export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL="1"
+ ruby install.rb config --prefix=${D}/usr || die
+ ruby install.rb install || die
+
+ make_desktop_entry alexandria "Alexandria" "/usr/share/${PN}/icons/alexandria_small.png" "Utility"
+}
+
+pkg_postinst() {
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+
+ gnome2_gconf_install
+
+ # For the next line see bug #76726
+ ${ROOT}/usr/bin/gconftool-2 --shutdown
+}