summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-05-25 15:10:52 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-05-25 15:10:52 +0000
commit9a4cd1678813fce57d53bcc783ab3c54f1552509 (patch)
tree14d81b11a5f2b7bce521c783f3fddee72fee646f /app-i18n/jmcce/jmcce-1.4_rc2.ebuild
parentnow uses mirror://kernel (diff)
downloadhistorical-9a4cd1678813fce57d53bcc783ab3c54f1552509.tar.gz
historical-9a4cd1678813fce57d53bcc783ab3c54f1552509.tar.bz2
historical-9a4cd1678813fce57d53bcc783ab3c54f1552509.zip
massive chinese input support addition! watch out debian, here we come!
Diffstat (limited to 'app-i18n/jmcce/jmcce-1.4_rc2.ebuild')
-rw-r--r--app-i18n/jmcce/jmcce-1.4_rc2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-i18n/jmcce/jmcce-1.4_rc2.ebuild b/app-i18n/jmcce/jmcce-1.4_rc2.ebuild
new file mode 100644
index 000000000000..8b177a2c06b3
--- /dev/null
+++ b/app-i18n/jmcce/jmcce-1.4_rc2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/jmcce/jmcce-1.4_rc2.ebuild,v 1.1 2003/05/25 15:10:52 liquidx Exp $
+
+MY_PV=${PV/_rc/RC}
+S=${WORKDIR}/${PN}-${MY_PV}
+DESCRIPTION="A Chinese Console supporting BIG5, GB and Japanese input."
+HOMEPAGE="http://jmcce.slat.org"
+SRC_URI="http://zope.slat.org/Project/Jmcce/DOWNLOAD/${PN}-${MY_PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=media-libs/svgalib-1.4.3
+ >=sys-libs/ncurses-4.2"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_compile() {
+ cd ${S}
+
+ ./genconf.sh
+ econf --sysconfdir=/etc/jmcce
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /etc/jmcce
+
+ make DESTDIR=${D} install || die "install failed"
+
+ dodir /usr/share/doc
+ mv ${D}/usr/share/doc/jmcce-1.4RC2 ${D}/usr/share/doc/${PF}
+ doman doc/jmcce.1
+}
+
+