summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-28 02:08:21 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-28 02:08:21 +0000
commit4c2ff3169fe7344c216dc840cc1071248eb017cb (patch)
tree0177f54977ae5df9e2b739ccb5a725d79c355f33 /app-i18n/canna
parentQA - fix use invocation (diff)
downloadhistorical-4c2ff3169fe7344c216dc840cc1071248eb017cb.tar.gz
historical-4c2ff3169fe7344c216dc840cc1071248eb017cb.tar.bz2
historical-4c2ff3169fe7344c216dc840cc1071248eb017cb.zip
touch the libc
Diffstat (limited to 'app-i18n/canna')
-rw-r--r--app-i18n/canna/canna-3.6_p4.ebuild17
-rw-r--r--app-i18n/canna/canna-3.7.ebuild17
-rw-r--r--app-i18n/canna/canna-3.7_p1.ebuild17
-rw-r--r--app-i18n/canna/canna-3.7_p2.ebuild17
4 files changed, 25 insertions, 43 deletions
diff --git a/app-i18n/canna/canna-3.6_p4.ebuild b/app-i18n/canna/canna-3.6_p4.ebuild
index 809dc148e34e..720f8bd42b84 100644
--- a/app-i18n/canna/canna-3.6_p4.ebuild
+++ b/app-i18n/canna/canna-3.6_p4.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6_p4.ebuild,v 1.16 2004/06/24 21:43:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.6_p4.ebuild,v 1.17 2004/06/28 01:41:41 vapier Exp $
inherit cannadic eutils
-IUSE="doc"
-
MY_P="Canna${PV//[._]/}"
DESCRIPTION="A client-server based Kana-Kanji conversion system"
@@ -14,13 +12,14 @@ SRC_URI="mirror://sourceforge.jp/canna/6059/${MY_P}.tar.gz"
LICENSE="as-is"
SLOT="0"
-KEYWORDS="x86 alpha ppc sparc"
+KEYWORDS="x86 ppc sparc alpha"
+IUSE="doc"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
doc? ( app-text/ptex )"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
S="${WORKDIR}/${MY_P}"
@@ -99,8 +98,7 @@ src_install() {
fperms 775 /var/lib/canna/dic/{user,group}
}
-pkg_prerm () {
-
+pkg_prerm() {
if [ -S /tmp/.iroha_unix/IROHA ] ; then
einfo
einfo "Stopping Canna for safe unmerge"
@@ -109,8 +107,7 @@ pkg_prerm () {
fi
}
-pkg_postrm () {
-
+pkg_postrm() {
if [ -f /usr/sbin/cannaserver ] ; then
update-cannadic-dir
einfo
diff --git a/app-i18n/canna/canna-3.7.ebuild b/app-i18n/canna/canna-3.7.ebuild
index dfd154694458..4aab418e040d 100644
--- a/app-i18n/canna/canna-3.7.ebuild
+++ b/app-i18n/canna/canna-3.7.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.7.ebuild,v 1.11 2004/06/24 21:43:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.7.ebuild,v 1.12 2004/06/28 01:41:41 vapier Exp $
inherit cannadic eutils
-IUSE="doc"
-
MY_P="Canna${PV//./}"
DESCRIPTION="A client-server based Kana-Kanji conversion system"
@@ -15,12 +13,13 @@ SRC_URI="mirror://sourceforge.jp/canna/7240/${MY_P}.tar.bz2"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86 ppc ~sparc alpha amd64"
+IUSE="doc"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
doc? ( app-text/ptex )"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
S="${WORKDIR}/${MY_P}"
@@ -36,7 +35,6 @@ src_unpack() {
}
src_compile() {
-
xmkmf || die
# Remove VENDORNAME, see bug #48229
@@ -105,7 +103,6 @@ src_install() {
}
pkg_postinst() {
-
update-cannadic-dir
einfo
einfo "Canna dictionary format has been changed."
@@ -113,8 +110,7 @@ pkg_postinst() {
einfo
}
-pkg_prerm () {
-
+pkg_prerm() {
if [ -S /tmp/.iroha_unix/IROHA ] ; then
# make sure cannaserver get stopped because otherwise
# we cannot stop it with /etc/init.d after emerge -C canna
@@ -126,8 +122,7 @@ pkg_prerm () {
fi
}
-pkg_postrm () {
-
+pkg_postrm() {
if [ -f /usr/sbin/cannaserver -a -e ${T}/canna.cookie ] ; then
#update-cannadic-dir
einfo
diff --git a/app-i18n/canna/canna-3.7_p1.ebuild b/app-i18n/canna/canna-3.7_p1.ebuild
index d66dd326f52f..9f3aa7fdbb27 100644
--- a/app-i18n/canna/canna-3.7_p1.ebuild
+++ b/app-i18n/canna/canna-3.7_p1.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.7_p1.ebuild,v 1.5 2004/06/24 21:43:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.7_p1.ebuild,v 1.6 2004/06/28 01:41:41 vapier Exp $
inherit cannadic eutils
-IUSE="doc"
-
MY_P="Canna${PV//./}"
DESCRIPTION="A client-server based Kana-Kanji conversion system"
@@ -15,12 +13,13 @@ SRC_URI="mirror://sourceforge.jp/canna/7449/${MY_P/_/}.tar.bz2"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86 ppc ~sparc alpha ~amd64"
+IUSE="doc"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
doc? ( app-text/ptex )"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
S="${WORKDIR}/${MY_P/_/}"
@@ -36,7 +35,6 @@ src_unpack() {
}
src_compile() {
-
xmkmf || die
# Remove VENDORNAME, see bug #48229
@@ -105,7 +103,6 @@ src_install() {
}
pkg_postinst() {
-
update-cannadic-dir
einfo
einfo "Canna dictionary format has been changed."
@@ -113,8 +110,7 @@ pkg_postinst() {
einfo
}
-pkg_prerm () {
-
+pkg_prerm() {
if [ -S /tmp/.iroha_unix/IROHA ] ; then
# make sure cannaserver get stopped because otherwise
# we cannot stop it with /etc/init.d after emerge -C canna
@@ -126,8 +122,7 @@ pkg_prerm () {
fi
}
-pkg_postrm () {
-
+pkg_postrm() {
if [ -f /usr/sbin/cannaserver -a -e ${T}/canna.cookie ] ; then
#update-cannadic-dir
einfo
diff --git a/app-i18n/canna/canna-3.7_p2.ebuild b/app-i18n/canna/canna-3.7_p2.ebuild
index adb43032ae32..133c6cc18d5f 100644
--- a/app-i18n/canna/canna-3.7_p2.ebuild
+++ b/app-i18n/canna/canna-3.7_p2.ebuild
@@ -1,11 +1,9 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.7_p2.ebuild,v 1.4 2004/06/24 21:43:53 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/canna/canna-3.7_p2.ebuild,v 1.5 2004/06/28 01:41:41 vapier Exp $
inherit cannadic eutils
-IUSE="doc"
-
MY_P="Canna${PV//./}"
DESCRIPTION="A client-server based Kana-Kanji conversion system"
@@ -15,12 +13,13 @@ SRC_URI="mirror://sourceforge.jp/canna/9558/${MY_P/_/}.tar.bz2"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86 ppc ~sparc ~alpha ~amd64"
+IUSE="doc"
-DEPEND="virtual/glibc
+DEPEND="virtual/libc
virtual/x11
>=sys-apps/sed-4
doc? ( app-text/ptex )"
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
S="${WORKDIR}/${MY_P/_/}"
@@ -36,7 +35,6 @@ src_unpack() {
}
src_compile() {
-
xmkmf || die
#make libCannaDir=../lib/canna canna || die
@@ -102,7 +100,6 @@ src_install() {
}
pkg_postinst() {
-
update-cannadic-dir
einfo
einfo "Canna dictionary format has been changed."
@@ -110,8 +107,7 @@ pkg_postinst() {
einfo
}
-pkg_prerm () {
-
+pkg_prerm() {
if [ -S /tmp/.iroha_unix/IROHA ] ; then
# make sure cannaserver get stopped because otherwise
# we cannot stop it with /etc/init.d after emerge -C canna
@@ -123,8 +119,7 @@ pkg_prerm () {
fi
}
-pkg_postrm () {
-
+pkg_postrm() {
if [ -f /usr/sbin/cannaserver -a -e ${T}/canna.cookie ] ; then
#update-cannadic-dir
einfo