summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-09-25 18:40:28 +0000
committerMamoru Komachi <usata@gentoo.org>2003-09-25 18:40:28 +0000
commit9e0dedbeaed0ac7446c5f5323bf048bfe41b4971 (patch)
tree8946560110be66ed5ec90d0c5dc3e2701edd02e8 /app-i18n/anthy-ss
parentNew ebuild. Split snapshots from app-i18n/anthy (because of frequent updates) (diff)
downloadhistorical-9e0dedbeaed0ac7446c5f5323bf048bfe41b4971.tar.gz
historical-9e0dedbeaed0ac7446c5f5323bf048bfe41b4971.tar.bz2
historical-9e0dedbeaed0ac7446c5f5323bf048bfe41b4971.zip
New ebuild. Split snapshots from app-i18n/anthy (because of frequent updates)
Diffstat (limited to 'app-i18n/anthy-ss')
-rw-r--r--app-i18n/anthy-ss/Manifest4
-rw-r--r--app-i18n/anthy-ss/anthy-ss-4524.ebuild71
-rw-r--r--app-i18n/anthy-ss/files/50anthy-gentoo.el5
-rw-r--r--app-i18n/anthy-ss/files/digest-anthy-ss-45241
-rw-r--r--app-i18n/anthy-ss/metadata.xml21
5 files changed, 101 insertions, 1 deletions
diff --git a/app-i18n/anthy-ss/Manifest b/app-i18n/anthy-ss/Manifest
index 181bf8583913..72e5b5e24f14 100644
--- a/app-i18n/anthy-ss/Manifest
+++ b/app-i18n/anthy-ss/Manifest
@@ -1,3 +1,5 @@
-MD5 a1c1e425a3349295a84e4e925d3d5975 anthy-ss-4524.ebuild 1358
+MD5 b448f83cf0b7c04260de08ce95b30805 anthy-ss-4524.ebuild 1502
+MD5 ca30b7ef075f2fc650499a1a074aa91f metadata.xml 818
+MD5 d6d2761e2fdf62744f213d5938668e72 ChangeLog 521
MD5 d91fcb424ec63b588900d2d88a8bcee2 files/50anthy-gentoo.el 99
MD5 eb98e0463fbc96e00ae0d27e10f68e7e files/digest-anthy-ss-4524 63
diff --git a/app-i18n/anthy-ss/anthy-ss-4524.ebuild b/app-i18n/anthy-ss/anthy-ss-4524.ebuild
new file mode 100644
index 000000000000..c2a960d521cb
--- /dev/null
+++ b/app-i18n/anthy-ss/anthy-ss-4524.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/anthy-ss/anthy-ss-4524.ebuild,v 1.1 2003/09/25 18:40:22 usata Exp $
+
+inherit elisp-common
+
+IUSE="emacs"
+
+MY_P="${P/-ss/}"
+
+DESCRIPTION="Anthy -- free and secure Japanese input system"
+HOMEPAGE="http://anthy.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/anthy/6092/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+SLOT="0"
+S="${WORKDIR}/${MY_P}"
+
+DEPEND="virtual/glibc
+ emacs? ( virtual/emacs )
+ !app-i18n/anthy"
+
+src_compile() {
+
+ local myconf
+ local cannadicdir=/var/lib/canna/dic/canna
+
+ use emacs || myconf="${myconf} EMACS=no"
+
+ if has_version 'app-dicts/canna-zipcode'; then
+ einfo "Adding zipcode.t and jigyosyo.t to anthy.dic."
+ cp ${cannadicdir}/{zipcode,jigyosyo}.t mkanthydic
+ sed -i -e "/^EXTRA_DICS/s|$| zipcode.t jigyosyo.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ if has_version 'app-dicts/canna-2ch'; then
+ einfo "Adding nichan.ctd to anthy.dic."
+ cp ${cannadicdir}/nichan.ctd mkanthydic/2ch.t
+ sed -i -e "/^EXTRA_DICS/s|$| 2ch.t|" \
+ mkanthydic/Makefile.{in,am}
+ fi
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ einstall || die
+
+ use emacs && elisp-site-file-install ${FILESDIR}/50anthy-gentoo.el
+
+ dodoc AUTHORS ChangeLog DIARY INSTALL NEWS README \
+ doc/[A-Z0-9][A-Z0-9]* doc/protocol.txt
+
+}
+
+pkg_postinst() {
+
+ use emacs && elisp-site-regen
+
+}
+
+pkg_postrm() {
+
+ use emacs && elisp-site-regen
+
+}
diff --git a/app-i18n/anthy-ss/files/50anthy-gentoo.el b/app-i18n/anthy-ss/files/50anthy-gentoo.el
new file mode 100644
index 000000000000..a166df146539
--- /dev/null
+++ b/app-i18n/anthy-ss/files/50anthy-gentoo.el
@@ -0,0 +1,5 @@
+
+;;; anthy site-lisp configuration
+
+(set-language-info "Japanese" 'input-method "japanese-anthy")
+
diff --git a/app-i18n/anthy-ss/files/digest-anthy-ss-4524 b/app-i18n/anthy-ss/files/digest-anthy-ss-4524
new file mode 100644
index 000000000000..ff35c576db62
--- /dev/null
+++ b/app-i18n/anthy-ss/files/digest-anthy-ss-4524
@@ -0,0 +1 @@
+MD5 2b73b2dc13a8d7f4c8f0412eb21a742c anthy-4524.tar.gz 1419917
diff --git a/app-i18n/anthy-ss/metadata.xml b/app-i18n/anthy-ss/metadata.xml
new file mode 100644
index 000000000000..dc6cd3786f28
--- /dev/null
+++ b/app-i18n/anthy-ss/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cjk</herd>
+<herd>emacs</herd>
+<maintainer>
+ <email>usata@gentoo.org</email>
+ <name>Mamoru KOMACHI</name>
+ <description>I created the ebuild to test app-i18n/uim but I'm not a
+ full Anthy user at the moment, so I'd like someone to help testing
+ and managing these ebuilds.
+ </description>
+</maintainer>
+<longdescription>
+Anthy is a free and secure Japanese kana-kanji server. This ebuild
+includes cannadic as a server-side dictionary, so you don't need any
+extra package to run it. You can use anthy with app-i18n/jmode (XIM),
+app-i18n/uim(XIM, GTK+ immodule) and emacs (to enable Anthy support
+for emacs, build this package with emacs USE flag).
+</longdescription>
+</pkgmetadata>