summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2009-03-22 23:27:12 +0000
committerLuca Barbato <lu_zero@gentoo.org>2009-03-22 23:27:12 +0000
commit3ec7ba1a9ad1d295191029c4198923391dcfd735 (patch)
treeebc137acf93390adc3b190144143fb04fbce7637 /app-emulation
parentbugfix release (diff)
downloadhistorical-3ec7ba1a9ad1d295191029c4198923391dcfd735.tar.gz
historical-3ec7ba1a9ad1d295191029c4198923391dcfd735.tar.bz2
historical-3ec7ba1a9ad1d295191029c4198923391dcfd735.zip
bugfix release
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-user/ChangeLog7
-rw-r--r--app-emulation/qemu-user/qemu-user-0.10.1.ebuild71
-rw-r--r--app-emulation/qemu/ChangeLog7
-rw-r--r--app-emulation/qemu/qemu-0.10.1.ebuild17
4 files changed, 100 insertions, 2 deletions
diff --git a/app-emulation/qemu-user/ChangeLog b/app-emulation/qemu-user/ChangeLog
index af3e6e5a9cc4..e2e69d3646f3 100644
--- a/app-emulation/qemu-user/ChangeLog
+++ b/app-emulation/qemu-user/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-user
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.36 2009/03/12 13:12:59 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/ChangeLog,v 1.37 2009/03/22 23:25:57 lu_zero Exp $
+
+*qemu-user-0.10.1 (22 Mar 2009)
+
+ 22 Mar 2009; Luca Barbato <lu_zero@gentoo.org> +qemu-user-0.10.1.ebuild:
+ Bugfix release
12 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org>
qemu-user-0.10.0.ebuild:
diff --git a/app-emulation/qemu-user/qemu-user-0.10.1.ebuild b/app-emulation/qemu-user/qemu-user-0.10.1.ebuild
new file mode 100644
index 000000000000..3fcf893fc5ba
--- /dev/null
+++ b/app-emulation/qemu-user/qemu-user-0.10.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-user/qemu-user-0.10.1.ebuild,v 1.1 2009/03/22 23:25:57 lu_zero Exp $
+
+inherit eutils flag-o-matic
+
+MY_PN=${PN/-user/}
+MY_P=${P/-user/}
+
+SRC_URI="http://savannah.nongnu.org/download/${MY_PN}/${MY_P}.tar.gz"
+
+DESCRIPTION="Open source dynamic translator"
+HOMEPAGE="http://bellard.org/qemu/index.html"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc64"
+IUSE=""
+RESTRICT="strip test"
+
+DEPEND="app-text/texi2html
+ !<=app-emulation/qemu-0.7.0"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ # prevent docs to get automatically installed
+ sed -i '/$(DESTDIR)$(docdir)/d' Makefile
+ # Alter target makefiles to accept CFLAGS set via flag-o
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target
+ [[ -x /sbin/paxctl ]] && \
+ sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
+ Makefile.target
+ # avoid strip
+ sed -i 's/$(INSTALL) -m 755 -s/$(INSTALL) -m 755/' Makefile
+}
+
+src_compile() {
+ local mycc conf_opts
+
+ conf_opts="--enable-linux-user"
+ conf_opts="${conf_opts} --disable-darwin-user --disable-bsd-user"
+ conf_opts="${conf_opts} --disable-system"
+ conf_opts="${conf_opts} --disable-vnc-tls"
+ conf_opts="$conf_opts --disable-curses"
+ conf_opts="$conf_opts --disable-gfx-check --disable-sdl"
+ conf_opts="$conf_opts --disable-vde"
+ conf_opts="$conf_opts --disable-kqemu"
+# use fdt || conf_opts="--disable-fdt"
+
+ conf_opts="$conf_opts --prefix=/usr --disable-bluez --disable-kvm"
+
+ filter-flags -fpie -fstack-protector
+
+ ./configure ${conf_opts} || die "econf failed"
+
+ emake || die "emake qemu failed"
+
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ rm -fR "${D}/usr/share"
+ dohtml qemu-doc.html
+ dohtml qemu-tech.html
+}
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index 798cf65a179f..8cd664b14dc1 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.61 2009/03/09 09:54:50 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.62 2009/03/22 23:27:12 lu_zero Exp $
+
+*qemu-0.10.1 (22 Mar 2009)
+
+ 22 Mar 2009; Luca Barbato <lu_zero@gentoo.org> +qemu-0.10.1.ebuild:
+ Bugfix release
*qemu-0.10.0 (09 Mar 2009)
diff --git a/app-emulation/qemu/qemu-0.10.1.ebuild b/app-emulation/qemu/qemu-0.10.1.ebuild
new file mode 100644
index 000000000000..9b4b3a39f79d
--- /dev/null
+++ b/app-emulation/qemu/qemu-0.10.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.10.1.ebuild,v 1.1 2009/03/22 23:27:12 lu_zero Exp $
+
+DESCRIPTION="qemu emulator and abi wrapper meta ebuild"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="~app-emulation/qemu-softmmu-${PV}
+ ~app-emulation/qemu-user-${PV}
+ !<=app-emulation/qemu-0.7.0"