summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-07-19 20:29:48 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-07-19 20:29:48 +0000
commit0e04c96cde15327b1f15f450843f4711f70eac6b (patch)
tree6bcc2b8fa7e18dbab881fc0000b47e1f259819de /app-emulation/zinc
parentcloses typo reported in bug #5266 (diff)
downloadhistorical-0e04c96cde15327b1f15f450843f4711f70eac6b.tar.gz
historical-0e04c96cde15327b1f15f450843f4711f70eac6b.tar.bz2
historical-0e04c96cde15327b1f15f450843f4711f70eac6b.zip
New package. Fixes #3674. Submitted by Derek Greentree
Diffstat (limited to 'app-emulation/zinc')
-rw-r--r--app-emulation/zinc/ChangeLog13
-rw-r--r--app-emulation/zinc/files/digest-zinc-0.91
-rw-r--r--app-emulation/zinc/zinc-0.9.ebuild29
3 files changed, 43 insertions, 0 deletions
diff --git a/app-emulation/zinc/ChangeLog b/app-emulation/zinc/ChangeLog
new file mode 100644
index 000000000000..d82bf039e40f
--- /dev/null
+++ b/app-emulation/zinc/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/zinc
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/zinc/ChangeLog,v 1.1 2002/07/19 20:29:48 rphillips Exp $
+
+*zinc-0.9 (9 Jul 2002)
+
+ 9 Jul 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/zinc/files/digest-zinc-0.9 b/app-emulation/zinc/files/digest-zinc-0.9
new file mode 100644
index 000000000000..aa19b33843c9
--- /dev/null
+++ b/app-emulation/zinc/files/digest-zinc-0.9
@@ -0,0 +1 @@
+MD5 99becb4600a032559cace1fb96cd5cd1 zinc-0.9-linux.tar.bz2 242490
diff --git a/app-emulation/zinc/zinc-0.9.ebuild b/app-emulation/zinc/zinc-0.9.ebuild
new file mode 100644
index 000000000000..dd55344cc0af
--- /dev/null
+++ b/app-emulation/zinc/zinc-0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/zinc/zinc-0.9.ebuild,v 1.1 2002/07/19 20:29:48 rphillips Exp $
+
+S="${WORKDIR}/zinc"
+A="${P}-linux.tar.bz2"
+DESCRIPTION="ZiNc is an x86 binary-only emulator for the Sony ZN-1, ZN-2, and Namco System 11 arcade systems."
+SRC_URI="http://www.emuhype.com/files/${A}"
+HOMEPAGE="http://www.emuhype.com"
+DEPEND="=sys-apps/baselayout-1.8.0"
+RDEPEND="${DEPEND}"
+KEYWORDS="x86"
+LICENSE="proprietary"
+SLOT="0"
+
+src_unpack() {
+ if [ ${ARCH} != "x86" ]; then
+ echo "Binary-only x86 package" && die
+ fi
+ unpack ${A}
+ cd ${S}
+}
+
+src_install() {
+ exeinto /opt/bin
+ doexe zinc
+ dolib.so libcontrolznc.so librendererznc.so libsoundznc.so
+}
+