summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-07 22:59:51 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-07 22:59:51 +0000
commit2cf4ffc5166313db2664619f75f4b08fd38bc8c2 (patch)
tree8927df58ca583c4383a7eea7bd980302b8bc785f /app-emulation/wine
parent~alpha keyword. (diff)
downloadhistorical-2cf4ffc5166313db2664619f75f4b08fd38bc8c2.tar.gz
historical-2cf4ffc5166313db2664619f75f4b08fd38bc8c2.tar.bz2
historical-2cf4ffc5166313db2664619f75f4b08fd38bc8c2.zip
export ABI for x86 on amd64
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/Manifest4
-rw-r--r--app-emulation/wine/wine-20050211.ebuild18
-rw-r--r--app-emulation/wine/wine-20050310.ebuild18
3 files changed, 24 insertions, 16 deletions
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
index 96a14f5a5b0a..3e33c45ef7d0 100644
--- a/app-emulation/wine/Manifest
+++ b/app-emulation/wine/Manifest
@@ -1,8 +1,8 @@
MD5 449230b44a85c482406dc3bec7b22618 ChangeLog 16151
MD5 6525c48ba09d08599432ea6c299e52f4 metadata.xml 354
-MD5 1749fa66eacf187afe3a527ccd52fdb3 wine-20050310.ebuild 3446
+MD5 bb4a47756de44f34185f67f6811be7dc wine-20050310.ebuild 3490
MD5 a2e7f0a049e239a834ca73d33763d35b wine-20041019-r3.ebuild 2912
-MD5 74c00f955a5c41a9dab6866eae39231d wine-20050211.ebuild 3488
+MD5 b6bd8c2117807060fda541463d4aac98 wine-20050211.ebuild 3532
MD5 fed189385cde1893fc5c53f2e6b655af wine-20050111-r1.ebuild 3113
MD5 67846279ad436d5d70d0857d29c5fabf files/20050211-docs.patch 719
MD5 1668a758aa2007cb99a773b3c5c844c9 files/winearts-kdecvs-fix.patch 325
diff --git a/app-emulation/wine/wine-20050211.ebuild b/app-emulation/wine/wine-20050211.ebuild
index b243b8669052..2c69f2a9b4a1 100644
--- a/app-emulation/wine/wine-20050211.ebuild
+++ b/app-emulation/wine/wine-20050211.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.8 2005/03/29 01:35:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050211.ebuild,v 1.9 2005/04/07 22:59:51 vapier Exp $
inherit eutils flag-o-matic
@@ -39,12 +39,16 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- if use amd64 && ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
+ if use amd64 ; then
+ if ! has_m32; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
+ else
+ export ABI=x86
+ fi
fi
}
diff --git a/app-emulation/wine/wine-20050310.ebuild b/app-emulation/wine/wine-20050310.ebuild
index b4c6b3efc207..aa2711f54cfc 100644
--- a/app-emulation/wine/wine-20050310.ebuild
+++ b/app-emulation/wine/wine-20050310.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310.ebuild,v 1.6 2005/03/29 01:35:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-20050310.ebuild,v 1.7 2005/04/07 22:59:51 vapier Exp $
inherit eutils flag-o-matic
@@ -39,12 +39,16 @@ DEPEND="${RDEPEND}
sys-devel/flex"
pkg_setup() {
- if use amd64 && ! has_m32; then
- eerror "Your compiler seems to be unable to compile 32bit code."
- eerror "Make sure you compile gcc with:"
- echo
- eerror " USE=multilib FEATURES=-sandbox"
- die "Cannot produce 32bit code"
+ if use amd64 ; then
+ if ! has_m32; then
+ eerror "Your compiler seems to be unable to compile 32bit code."
+ eerror "Make sure you compile gcc with:"
+ echo
+ eerror " USE=multilib FEATURES=-sandbox"
+ die "Cannot produce 32bit code"
+ else
+ export ABI=x86
+ fi
fi
}