summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-08-20 12:57:49 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-08-20 12:57:49 +0000
commit5e6e53c500b628a434939bf1016f78ccd56371d7 (patch)
tree614dbf17960f35de499656ebfceb3f10dea663d8 /app-emulation/vmware-workstation/files
parentsecurity update (diff)
downloadhistorical-5e6e53c500b628a434939bf1016f78ccd56371d7.tar.gz
historical-5e6e53c500b628a434939bf1016f78ccd56371d7.tar.bz2
historical-5e6e53c500b628a434939bf1016f78ccd56371d7.zip
security update
Diffstat (limited to 'app-emulation/vmware-workstation/files')
-rw-r--r--app-emulation/vmware-workstation/files/3.2.1.2242/90vmware3
-rw-r--r--app-emulation/vmware-workstation/files/3.2.1.2242/VMwareWorkstation.desktop12
-rw-r--r--app-emulation/vmware-workstation/files/3.2.1.2242/vmware73
-rw-r--r--app-emulation/vmware-workstation/files/3.2.1.2242/vmware-config.pl-gcc-generalized.patch60
-rw-r--r--app-emulation/vmware-workstation/files/3.2.1.2242/vmware-glibc-2.3.2-compat.c32
-rw-r--r--app-emulation/vmware-workstation/files/3.2.1.2242/vmware.pngbin0 -> 470 bytes
-rw-r--r--app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.1.22422
7 files changed, 182 insertions, 0 deletions
diff --git a/app-emulation/vmware-workstation/files/3.2.1.2242/90vmware b/app-emulation/vmware-workstation/files/3.2.1.2242/90vmware
new file mode 100644
index 000000000000..8e00d2bb0587
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/3.2.1.2242/90vmware
@@ -0,0 +1,3 @@
+PATH=/opt/vmware/bin
+ROOTPATH=/opt/vmware/bin
+MANPATH=/opt/vmware/man
diff --git a/app-emulation/vmware-workstation/files/3.2.1.2242/VMwareWorkstation.desktop b/app-emulation/vmware-workstation/files/3.2.1.2242/VMwareWorkstation.desktop
new file mode 100644
index 000000000000..9e42f9c1b4c6
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/3.2.1.2242/VMwareWorkstation.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=VMware Workstation
+Comment=VMware Workstation
+GenericName=Virtual PC Emulator
+Exec=vmware
+Icon=/opt/vmware/lib/icon/vmware.png
+Path=
+Terminal=0
+TerminalOptions=
+Type=Application
+X-KDE-SubstituteUID=false
+X-KDE-Username=
diff --git a/app-emulation/vmware-workstation/files/3.2.1.2242/vmware b/app-emulation/vmware-workstation/files/3.2.1.2242/vmware
new file mode 100644
index 000000000000..8f32d2adb9bc
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/3.2.1.2242/vmware
@@ -0,0 +1,73 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/files/3.2.1.2242/vmware,v 1.1 2003/08/20 12:57:37 aliz Exp $
+
+depend() {
+ need localmount
+ use logger net
+}
+
+vmware-prettify() {
+ # Yea, the code is ugly but the output is pretty
+ state=$1
+ waserror=0
+ msgtype=0
+ while read line
+ do
+ [ "$line" == "" ] && continue
+ if [ "$msgtype" -le "0" ]
+ then
+ if [ "$msgtype" == "-1" ]
+ then
+ ewarn $line
+ continue
+ fi
+ if [ "${line/*:*/}" == "" ]
+ then
+ einfon $line
+ echo
+ eend 0
+ msgtype=1
+ else
+ ewarn $line
+ msgtype=-1
+ waserror=1
+ fi
+ continue
+ fi
+
+ # Strip out anything after the <esc> code
+ message=`echo $line | sed -e "s/^\(.*\).*$/\1/"`
+ einfon " $message"
+ echo
+
+ echo $line | grep done > /dev/null
+ status=$?
+ eend $status
+
+ if [ "$status" != "0" ]
+ then
+ logger -p local0.err -t vmware-${state} "$line"
+ waserror=$status
+ fi
+ done
+ if [ "$msgtype" == "-1" ]
+ then
+ eend 1 "VMware is not properly configured! See above."
+ fi
+ return $waserror
+}
+
+start() {
+ test -x /etc/vmware/init.d/vmware || \
+ eend 1 "vmware init script not found. Aborting" || return 1
+
+ /etc/vmware/init.d/vmware start | vmware-prettify start
+ return $?
+}
+
+stop() {
+ /etc/vmware/init.d/vmware stop | vmware-prettify stop
+ return $?
+}
diff --git a/app-emulation/vmware-workstation/files/3.2.1.2242/vmware-config.pl-gcc-generalized.patch b/app-emulation/vmware-workstation/files/3.2.1.2242/vmware-config.pl-gcc-generalized.patch
new file mode 100644
index 000000000000..f2a0239f4c7b
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/3.2.1.2242/vmware-config.pl-gcc-generalized.patch
@@ -0,0 +1,60 @@
+--- bin/vmware-config.pl.orig 2002-12-16 12:15:35.000000000 -0500
++++ bin/vmware-config.pl 2002-12-16 13:30:29.000000000 -0500
+@@ -1487,21 +1487,21 @@
+ }
+
+ $gcc_version = direct_command(shell_string($gHelper{'gcc'})
+- . ' --version');
++ . ' -dumpversion');
+ chomp($gcc_version);
+ @gcc_version_num = split(/\./, $gcc_version);
+- if ($gcc_version_num[0] >= 3) {
+- if (get_answer('As of April 2002, gcc version 3 and later is not yet a '
+- . 'supported compiler by the Linux kernel development '
+- . 'team. Have a look at Documentation/Changes in your '
+- . 'kernel source directory to get the correct compiler '
+- . 'installed. Do you want to go with compiler "'
+- . $gHelper{'gcc'} . '" version ' . $gcc_version . '?',
+- 'yesno', 'no') eq 'no') {
+- print wrap('Unable to continue.' . "\n\n", 0);
+- module_error();
+- }
+- }
++# if ($gcc_version_num[0] >= 3) {
++# if (get_answer('As of April 2002, gcc version 3 and later is not yet a '
++# . 'supported compiler by the Linux kernel development '
++# . 'team. Have a look at Documentation/Changes in your '
++# . 'kernel source directory to get the correct compiler '
++# . 'installed. Do you want to go with compiler "'
++# . $gHelper{'gcc'} . '" version ' . $gcc_version . '?',
++# 'yesno', 'no') eq 'no') {
++# print wrap('Unable to continue.' . "\n\n", 0);
++# module_error();
++# }
++# }
+
+ # When installing the modules, kernels 2.4+ setup a symlink to the kernel
+ # source directory
+@@ -1526,6 +1526,22 @@
+ module_error();
+ }
+
++ my $makefile="$build_dir/$name-only/Makefile";
++ my $gcc_replace="";
++ $gcc_version = direct_command(shell_string($gHelper{'gcc'})
++ . ' -dumpversion');
++ chomp($gcc_version);
++ @gcc_version_num = split(/\./, $gcc_version);
++ if ($gcc_version_num[0] >= 3) {
++ $gcc_replace="-e 's:-malign-:-falign-:g'";
++ }
++ system("/usr/bin/cp $makefile $makefile.old");
++ system("/usr/bin/sed" .
++ " -e 's:CC) --version:CC) -dumpversion:'" .
++ " -e 's:-m486:-march=i486:'" .
++ " -e 's:-Wall -Wstrict-prototypes::'" .
++ " $gcc_replace" .
++ " $makefile.old > $makefile");
+ print wrap('Building the ' . $name . ' module.' . "\n\n", 0);
+ if (system(shell_string($gHelper{'make'}) . ' -C ' . shell_string($build_dir . '/' . $name . '-only') . ' auto-build ' . (($gSystem{'smp'} eq 'yes') ? 'SUPPORT_SMP=1 ' : '') . shell_string('HEADER_DIR=' . db_get_answer('HEADER_DIR')) . ' ' . shell_string('CC=' . $gHelper{'gcc'}) . ' ' . shell_string('GREP=' . $gHelper{'grep'}))) {
+ print wrap('Unable to build the ' . $name . ' module.' . "\n\n", 0);
diff --git a/app-emulation/vmware-workstation/files/3.2.1.2242/vmware-glibc-2.3.2-compat.c b/app-emulation/vmware-workstation/files/3.2.1.2242/vmware-glibc-2.3.2-compat.c
new file mode 100644
index 000000000000..3499be2e5972
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/3.2.1.2242/vmware-glibc-2.3.2-compat.c
@@ -0,0 +1,32 @@
+/*
+ * Build with: gcc -W -Wall -shared -o q.so q.c
+ */
+
+#include <dlfcn.h>
+#include <sys/mman.h>
+#include <stdlib.h>
+#include <stdio.h>
+
+void go(void) __attribute__((constructor));
+
+void go(void) {
+ void* qh;
+ unsigned char *__real_errno_location, *__vm_errno_location;
+
+ qh = dlopen("libc.so.6", RTLD_GLOBAL);
+ __real_errno_location = dlsym(qh, "__errno_location");
+ __vm_errno_location = dlsym(NULL, "__errno_location");
+ printf("Got eroloc %p & %p\n", __vm_errno_location, __real_errno_location);
+ if (__real_errno_location && __vm_errno_location && __real_errno_location != __vm_errno_location) {
+ unsigned int errnobase = (int)__vm_errno_location;
+ unsigned int mpbase = errnobase & ~0xFFF;
+ unsigned int mplen = 4096;
+ if (errnobase + 5 > mpbase + mplen) {
+ mplen = mplen + 4096;
+ }
+ mprotect((void*)mpbase, mplen, PROT_READ|PROT_WRITE|PROT_EXEC);
+ *__vm_errno_location = 0xE9;
+ *(int*)(__vm_errno_location + 1) = __real_errno_location - __vm_errno_location - 5;
+ mprotect((void*)mpbase, mplen, PROT_READ|PROT_EXEC);
+ }
+}
diff --git a/app-emulation/vmware-workstation/files/3.2.1.2242/vmware.png b/app-emulation/vmware-workstation/files/3.2.1.2242/vmware.png
new file mode 100644
index 000000000000..06672aa3f0bf
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/3.2.1.2242/vmware.png
Binary files differ
diff --git a/app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.1.2242 b/app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.1.2242
new file mode 100644
index 000000000000..fb628ebc2c2f
--- /dev/null
+++ b/app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.1.2242
@@ -0,0 +1,2 @@
+MD5 56dccf022582a374cf2eac06796115cf VMware-workstation-3.2.1-2242.tar.gz 12577292
+MD5 3643c9d1297443dc980f7bfc4caa577d vmware-any-any-update38.tar.gz 186190