summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-26 00:05:08 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-26 00:05:08 +0000
commit1b5b439fcc40523f7e8b9e14fe364df64825945f (patch)
tree342e32f1a1a904afb8dce752037d40e44654f10b /app-emulation/vmware-workstation/files
parent2.5/2.6 kernel support (diff)
downloadhistorical-1b5b439fcc40523f7e8b9e14fe364df64825945f.tar.gz
historical-1b5b439fcc40523f7e8b9e14fe364df64825945f.tar.bz2
historical-1b5b439fcc40523f7e8b9e14fe364df64825945f.zip
old 3.2.0 is gone
Diffstat (limited to 'app-emulation/vmware-workstation/files')
-rw-r--r--app-emulation/vmware-workstation/files/3.2.0.2230-r1/90vmware3
-rw-r--r--app-emulation/vmware-workstation/files/3.2.0.2230-r1/VMwareWorkstation.desktop12
-rw-r--r--app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware73
-rw-r--r--app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware-config.pl-gcc-generalized.patch60
-rw-r--r--app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware.pngbin470 -> 0 bytes
-rw-r--r--app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.0.2230-r11
6 files changed, 0 insertions, 149 deletions
diff --git a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/90vmware b/app-emulation/vmware-workstation/files/3.2.0.2230-r1/90vmware
deleted file mode 100644
index 8e00d2bb0587..000000000000
--- a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/90vmware
+++ /dev/null
@@ -1,3 +0,0 @@
-PATH=/opt/vmware/bin
-ROOTPATH=/opt/vmware/bin
-MANPATH=/opt/vmware/man
diff --git a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/VMwareWorkstation.desktop b/app-emulation/vmware-workstation/files/3.2.0.2230-r1/VMwareWorkstation.desktop
deleted file mode 100644
index 9e42f9c1b4c6..000000000000
--- a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/VMwareWorkstation.desktop
+++ /dev/null
@@ -1,12 +0,0 @@
-[Desktop Entry]
-Name=VMware Workstation
-Comment=VMware Workstation
-GenericName=Virtual PC Emulator
-Exec=vmware
-Icon=/opt/vmware/lib/icon/vmware.png
-Path=
-Terminal=0
-TerminalOptions=
-Type=Application
-X-KDE-SubstituteUID=false
-X-KDE-Username=
diff --git a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware b/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware
deleted file mode 100644
index f86be6a09b33..000000000000
--- a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware
+++ /dev/null
@@ -1,73 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware,v 1.3 2003/02/14 22:35:37 vapier Exp $
-
-depend() {
- need localmount
- use logger net
-}
-
-vmware-prettify() {
- # Yea, the code is ugly but the output is pretty
- state=$1
- waserror=0
- msgtype=0
- while read line
- do
- [ "$line" == "" ] && continue
- if [ "$msgtype" -le "0" ]
- then
- if [ "$msgtype" == "-1" ]
- then
- ewarn $line
- continue
- fi
- if [ "${line/*:*/}" == "" ]
- then
- einfon $line
- echo
- eend 0
- msgtype=1
- else
- ewarn $line
- msgtype=-1
- waserror=1
- fi
- continue
- fi
-
- # Strip out anything after the <esc> code
- message=`echo $line | sed -e "s/^\(.*\).*$/\1/"`
- einfon " $message"
- echo
-
- echo $line | grep done > /dev/null
- status=$?
- eend $status
-
- if [ "$status" != "0" ]
- then
- logger -p local0.err -t vmware-${state} "$line"
- waserror=$status
- fi
- done
- if [ "$msgtype" == "-1" ]
- then
- eend 1 "VMware is not properly configured! See above."
- fi
- return $waserror
-}
-
-start() {
- test -x /etc/vmware/init.d/vmware || \
- eend 1 "vmware init script not found. Aborting" || return 1
-
- /etc/vmware/init.d/vmware start | vmware-prettify start
- return $?
-}
-
-stop() {
- /etc/vmware/init.d/vmware stop | vmware-prettify stop
- return $?
-}
diff --git a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware-config.pl-gcc-generalized.patch b/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware-config.pl-gcc-generalized.patch
deleted file mode 100644
index f2a0239f4c7b..000000000000
--- a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware-config.pl-gcc-generalized.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- bin/vmware-config.pl.orig 2002-12-16 12:15:35.000000000 -0500
-+++ bin/vmware-config.pl 2002-12-16 13:30:29.000000000 -0500
-@@ -1487,21 +1487,21 @@
- }
-
- $gcc_version = direct_command(shell_string($gHelper{'gcc'})
-- . ' --version');
-+ . ' -dumpversion');
- chomp($gcc_version);
- @gcc_version_num = split(/\./, $gcc_version);
-- if ($gcc_version_num[0] >= 3) {
-- if (get_answer('As of April 2002, gcc version 3 and later is not yet a '
-- . 'supported compiler by the Linux kernel development '
-- . 'team. Have a look at Documentation/Changes in your '
-- . 'kernel source directory to get the correct compiler '
-- . 'installed. Do you want to go with compiler "'
-- . $gHelper{'gcc'} . '" version ' . $gcc_version . '?',
-- 'yesno', 'no') eq 'no') {
-- print wrap('Unable to continue.' . "\n\n", 0);
-- module_error();
-- }
-- }
-+# if ($gcc_version_num[0] >= 3) {
-+# if (get_answer('As of April 2002, gcc version 3 and later is not yet a '
-+# . 'supported compiler by the Linux kernel development '
-+# . 'team. Have a look at Documentation/Changes in your '
-+# . 'kernel source directory to get the correct compiler '
-+# . 'installed. Do you want to go with compiler "'
-+# . $gHelper{'gcc'} . '" version ' . $gcc_version . '?',
-+# 'yesno', 'no') eq 'no') {
-+# print wrap('Unable to continue.' . "\n\n", 0);
-+# module_error();
-+# }
-+# }
-
- # When installing the modules, kernels 2.4+ setup a symlink to the kernel
- # source directory
-@@ -1526,6 +1526,22 @@
- module_error();
- }
-
-+ my $makefile="$build_dir/$name-only/Makefile";
-+ my $gcc_replace="";
-+ $gcc_version = direct_command(shell_string($gHelper{'gcc'})
-+ . ' -dumpversion');
-+ chomp($gcc_version);
-+ @gcc_version_num = split(/\./, $gcc_version);
-+ if ($gcc_version_num[0] >= 3) {
-+ $gcc_replace="-e 's:-malign-:-falign-:g'";
-+ }
-+ system("/usr/bin/cp $makefile $makefile.old");
-+ system("/usr/bin/sed" .
-+ " -e 's:CC) --version:CC) -dumpversion:'" .
-+ " -e 's:-m486:-march=i486:'" .
-+ " -e 's:-Wall -Wstrict-prototypes::'" .
-+ " $gcc_replace" .
-+ " $makefile.old > $makefile");
- print wrap('Building the ' . $name . ' module.' . "\n\n", 0);
- if (system(shell_string($gHelper{'make'}) . ' -C ' . shell_string($build_dir . '/' . $name . '-only') . ' auto-build ' . (($gSystem{'smp'} eq 'yes') ? 'SUPPORT_SMP=1 ' : '') . shell_string('HEADER_DIR=' . db_get_answer('HEADER_DIR')) . ' ' . shell_string('CC=' . $gHelper{'gcc'}) . ' ' . shell_string('GREP=' . $gHelper{'grep'}))) {
- print wrap('Unable to build the ' . $name . ' module.' . "\n\n", 0);
diff --git a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware.png b/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware.png
deleted file mode 100644
index 06672aa3f0bf..000000000000
--- a/app-emulation/vmware-workstation/files/3.2.0.2230-r1/vmware.png
+++ /dev/null
Binary files differ
diff --git a/app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.0.2230-r1 b/app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.0.2230-r1
deleted file mode 100644
index 3fcf4a53a48b..000000000000
--- a/app-emulation/vmware-workstation/files/digest-vmware-workstation-3.2.0.2230-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 be6a12e7c835d027adfe533e1744759e VMware-workstation-3.2.0-2230.tar.gz 12575521