summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2003-03-23 07:48:49 +0000
committerHanno Boeck <hanno@gentoo.org>2003-03-23 07:48:49 +0000
commitc69bc8cd8f5fd316d4c666ca24c23018d4715cd9 (patch)
treebc2d832f6066cf3fa30281809fa47dc9f39dc6da /app-emulation/vice
parentBumped to stable for ppc (diff)
downloadhistorical-c69bc8cd8f5fd316d4c666ca24c23018d4715cd9.tar.gz
historical-c69bc8cd8f5fd316d4c666ca24c23018d4715cd9.tar.bz2
historical-c69bc8cd8f5fd316d4c666ca24c23018d4715cd9.zip
new version of vice
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/ChangeLog7
-rw-r--r--app-emulation/vice/files/digest-vice-1.111
-rw-r--r--app-emulation/vice/vice-1.11.ebuild50
3 files changed, 57 insertions, 1 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index 5f5594feb55d..f07ac4ef9054 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/vice
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.3 2003/02/12 04:03:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.4 2003/03/23 07:48:49 hanno Exp $
+
+*vice-1.11 (23 Mar 2003)
+
+ 23 Mar 2003; Hanno Boeck <hanno@gentoo.org> vice-1.11.ebuild:
+ New version.
*vice-1.10 (08 Nov 2002)
diff --git a/app-emulation/vice/files/digest-vice-1.11 b/app-emulation/vice/files/digest-vice-1.11
new file mode 100644
index 000000000000..2e36fd6e877c
--- /dev/null
+++ b/app-emulation/vice/files/digest-vice-1.11
@@ -0,0 +1 @@
+MD5 580817b28097b0897e48463d4fc510aa vice-1.11.tar.gz 3185213
diff --git a/app-emulation/vice/vice-1.11.ebuild b/app-emulation/vice/vice-1.11.ebuild
new file mode 100644
index 000000000000..2fc5e7cda957
--- /dev/null
+++ b/app-emulation/vice/vice-1.11.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.11.ebuild,v 1.1 2003/03/23 07:48:49 hanno Exp $
+
+IUSE="sdl nls gnome"
+
+DESCRIPTION="The Versatile Commodore 8-bit Emulator"
+HOMEPAGE="http://viceteam.bei.t-online.de/"
+SRC_URI="ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/VICE/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=x11-base/xfree-4.0
+ sdl? ( media-libs/libsdl )
+ gnome? ( gnome-base/libgnomeui )"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ local myconf="--enable-fullscreen"
+ use sdl && myconf="${myconf} --with-sdl"
+ use gnome && myconf="${myconf} --enable-gnomeui"
+ use nls || myconf="${myconf} --disable-nls"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man ${myconf} || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dohtml ${D}/usr/lib/vice/doc/*.html
+ dodoc \
+ ${D}/usr/lib/vice/doc/NLS-Howto.txt \
+ ${D}/usr/lib/vice/doc/Readme.beos \
+ ${D}/usr/lib/vice/doc/Readme.dos \
+ ${D}/usr/lib/vice/doc/Win32-Howto.txt \
+ ${D}/usr/lib/vice/doc/mon.txt
+
+ rm ${D}/usr/lib/vice/doc -rf
+}