summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-02-11 21:04:54 +0000
committerDavid Holm <dholm@gentoo.org>2004-02-11 21:04:54 +0000
commitc821b9f439dc847f8593c1e9cac09201b3582c47 (patch)
tree1f4262cb589867b7456930e732a6eb8731c8dd64 /app-emulation/uae
parentAdding cpu-1.4.3, new digests and metadata.xml (diff)
downloadhistorical-c821b9f439dc847f8593c1e9cac09201b3582c47.tar.gz
historical-c821b9f439dc847f8593c1e9cac09201b3582c47.tar.bz2
historical-c821b9f439dc847f8593c1e9cac09201b3582c47.zip
Commited some compilation fixes
Diffstat (limited to 'app-emulation/uae')
-rw-r--r--app-emulation/uae/ChangeLog6
-rw-r--r--app-emulation/uae/Manifest4
-rw-r--r--app-emulation/uae/uae-0.8.23_pre20040129.ebuild14
3 files changed, 18 insertions, 6 deletions
diff --git a/app-emulation/uae/ChangeLog b/app-emulation/uae/ChangeLog
index 8b4198145640..75728b1ab145 100644
--- a/app-emulation/uae/ChangeLog
+++ b/app-emulation/uae/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/uae
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.11 2004/02/09 09:54:04 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/ChangeLog,v 1.12 2004/02/11 21:04:54 dholm Exp $
+
+ 11 Feb 2004; David Holm <dholm@gentoo.org> uae-0.8.23_pre20040129.ebuild:
+ Added SDL configure flags as suggested by Jonathan Heaney and compilation fix
+ suggested by Lars Schünzel.
*uae-0.8.23_pre20040129 (09 Feb 2004)
diff --git a/app-emulation/uae/Manifest b/app-emulation/uae/Manifest
index 3cbb9e038539..ca2ca2017012 100644
--- a/app-emulation/uae/Manifest
+++ b/app-emulation/uae/Manifest
@@ -1,7 +1,7 @@
-MD5 c45feac28085e8008217be55be36193f ChangeLog 1725
+MD5 3e0aec72b9d5113d431b4e55a248cb3d ChangeLog 1912
MD5 9942fdc6d0c4e617f237b18ed3f71768 uae-0.8.22.ebuild 1251
MD5 c94a58ae3e3cb3fe70e08de53e086a21 metadata.xml 642
-MD5 d536594d3915acc6500c7ec26b2f1b43 uae-0.8.23_pre20040129.ebuild 1174
+MD5 a79fb678ea1d364d3105b6fbc3ddacc4 uae-0.8.23_pre20040129.ebuild 1348
MD5 b2fac0f21ee34abaa6279cf7ad023119 files/digest-uae-0.8.22 62
MD5 4d3af2d2cc2945b006249066cb8c7adb files/uae-patch.diff 364
MD5 24ce02be9243fef32739ff76bd9ba84c files/digest-uae-0.8.23_pre20040129 73
diff --git a/app-emulation/uae/uae-0.8.23_pre20040129.ebuild b/app-emulation/uae/uae-0.8.23_pre20040129.ebuild
index 792695d87cad..31cb77615881 100644
--- a/app-emulation/uae/uae-0.8.23_pre20040129.ebuild
+++ b/app-emulation/uae/uae-0.8.23_pre20040129.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.23_pre20040129.ebuild,v 1.2 2004/02/09 10:55:02 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uae/uae-0.8.23_pre20040129.ebuild,v 1.3 2004/02/11 21:04:54 dholm Exp $
+
+inherit flag-o-matic
MY_PV="0.8.23-20040129"
S="${WORKDIR}/${PN}-${MY_PV}"
-DESCRIPTION="An amiga emulator"
+DESCRIPTION="The Umiquious Amiga Emulator"
HOMEPAGE="http://www.rcdrummond.net/uae/"
SRC_URI="http://www.rcdrummond.net/uae/uae-${MY_PV}/uae-${MY_PV}.tar.bz2"
@@ -21,7 +23,13 @@ src_compile() {
ewarn "Compiling the CPU-core requires a substantial amount of RAM."
ewarn "Make sure that you have at least 512MB of RAM+SWAP available."
- econf || die "./configure failed"
+ replace-flags "-O3" "-O2"
+ use sdl && myconf="--with-sdl-sound --with-sdl-gfx"
+
+ econf ${myconf} \
+ --enable-threads \
+ --enable-scsi-device \
+ || die "./configure failed"
emake -j1 || die "emake failed"
}