summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2005-05-25 20:41:48 +0000
committerLuca Barbato <lu_zero@gentoo.org>2005-05-25 20:41:48 +0000
commitb810b73513c988c2d75e2e088ac55e5d4acc55cf (patch)
tree5bf2ed1f8d20f63a82f06dd87df4181ccfab230a /app-emulation/qemu
parentNew upstream version (diff)
downloadhistorical-b810b73513c988c2d75e2e088ac55e5d4acc55cf.tar.gz
historical-b810b73513c988c2d75e2e088ac55e5d4acc55cf.tar.bz2
historical-b810b73513c988c2d75e2e088ac55e5d4acc55cf.zip
Fix/workaround for the newer glibc
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/ChangeLog6
-rw-r--r--app-emulation/qemu/Manifest5
-rw-r--r--app-emulation/qemu/files/qemu-0.7.0-errno.patch11
-rw-r--r--app-emulation/qemu/qemu-0.7.0.ebuild8
4 files changed, 24 insertions, 6 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index d99cc88b93a3..3f512b0e2ceb 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/qemu
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.34 2005/05/18 23:44:49 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.35 2005/05/25 20:41:48 lu_zero Exp $
+
+ 25 May 2005; Luca Barbato <lu_zero@gentoo.org>
+ +files/qemu-0.7.0-errno.patch, qemu-0.7.0.ebuild:
+ Fix for the errno issues in helper2.c
18 May 2005; Luca Barbato <lu_zero@gentoo.org> qemu-0.7.0.ebuild:
Add a notice about the qemu group, thanks to Leung Ki Chi
diff --git a/app-emulation/qemu/Manifest b/app-emulation/qemu/Manifest
index 949d99889acf..a46b42931f83 100644
--- a/app-emulation/qemu/Manifest
+++ b/app-emulation/qemu/Manifest
@@ -1,9 +1,10 @@
MD5 898131aae735c3477ff2f9c6882f1178 metadata.xml 223
MD5 518988ab13f6b610696b8706d31d2fb9 qemu-0.6.0.ebuild 1895
-MD5 db5d17d2fe23107a479302bc41c1d73b qemu-0.7.0.ebuild 4131
+MD5 d07d5638a05e71a6a73275347d4de072 qemu-0.7.0.ebuild 4205
MD5 b035e8de3718e77cc27918198bf49fb6 qemu-0.6.1-r1.ebuild 2143
MD5 e65dab4abb0028ab15d60ecd60ca4ba9 qemu-0.6.1.ebuild 2071
-MD5 750fc5fae23fc385af27f15b4719c997 ChangeLog 4438
+MD5 4170b3bec034e62f4642b9e962494676 ChangeLog 4580
+MD5 3202f7445799cce82ccaac9749e1443d files/qemu-0.7.0-errno.patch 487
MD5 1f8638d68cffbd8b96df97dcb0868b88 files/digest-qemu-0.6.1-r1 63
MD5 ede1278e0122a8439c156bd1380a37d5 files/qemu_gcc34.patch.gz 406
MD5 0b85ac42eaa41830ac9b4eccf4a118bd files/qemu-0.6.0-sigaction.patch 677
diff --git a/app-emulation/qemu/files/qemu-0.7.0-errno.patch b/app-emulation/qemu/files/qemu-0.7.0-errno.patch
new file mode 100644
index 000000000000..291adc1725b5
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-0.7.0-errno.patch
@@ -0,0 +1,11 @@
+diff -ruN qemu-0.7.0.orig/target-i386/helper2.c qemu-0.7.0/target-i386/helper2.c
+--- qemu-0.7.0.orig/target-i386/helper2.c 2005-04-27 22:52:05.000000000 +0200
++++ qemu-0.7.0/target-i386/helper2.c 2005-05-25 22:07:50.000000000 +0200
+@@ -17,6 +17,7 @@
+ * License along with this library; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
++#include <errno.h>
+ #include <stdarg.h>
+ #include <stdlib.h>
+ #include <stdio.h>
diff --git a/app-emulation/qemu/qemu-0.7.0.ebuild b/app-emulation/qemu/qemu-0.7.0.ebuild
index 385ff3a715c2..dd58e1ea617c 100644
--- a/app-emulation/qemu/qemu-0.7.0.ebuild
+++ b/app-emulation/qemu/qemu-0.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.7.0.ebuild,v 1.7 2005/05/18 23:44:49 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.7.0.ebuild,v 1.8 2005/05/25 20:41:48 lu_zero Exp $
inherit eutils flag-o-matic linux-mod toolchain-funcs
@@ -55,13 +55,15 @@ src_unpack() {
cd ${S}/kqemu
epatch ${FILESDIR}/kqemu-sysfs.patch
fi
-
-# if use qvm86; then
+ # if use qvm86; then
# mv ${WORKDIR}/qvm86 ${S}
# cd ${S}
# epatch qvm86/patch.qvm86
# fi
cd ${S}
+ #Fix errno mismatch on glibc-2.3.5
+ epatch ${FILESDIR}/${P}-errno.patch
+
# Alter target makefiles to accept CFLAGS set via flag-o.
sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
Makefile Makefile.target tests/Makefile