summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-01-03 16:54:51 +0000
committerChuck Short <zul@gentoo.org>2004-01-03 16:54:51 +0000
commit5bac14e4795401856cd7f972cad6d7e93881432e (patch)
treebc163754430b5dacc0c75ec363b39fe40ab7ba54 /app-emulation/qemu
parentInitial version, closes #37047. (diff)
downloadhistorical-5bac14e4795401856cd7f972cad6d7e93881432e.tar.gz
historical-5bac14e4795401856cd7f972cad6d7e93881432e.tar.bz2
historical-5bac14e4795401856cd7f972cad6d7e93881432e.zip
Initial version, closes #37047.
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/Manifest4
-rw-r--r--app-emulation/qemu/files/digest-qemu-0.5.11
-rw-r--r--app-emulation/qemu/metadata.xml8
-rw-r--r--app-emulation/qemu/qemu-0.5.1.ebuild49
4 files changed, 61 insertions, 1 deletions
diff --git a/app-emulation/qemu/Manifest b/app-emulation/qemu/Manifest
index 2282a306e7b2..ce9d6760577f 100644
--- a/app-emulation/qemu/Manifest
+++ b/app-emulation/qemu/Manifest
@@ -1,2 +1,4 @@
-MD5 5f9f157d328bb1dde969bff4d69f8f44 qemu-0.5.1.ebuild 1182
+MD5 79647c0f036503aca228ef4a8d3d866c qemu-0.5.1.ebuild 1276
+MD5 a1475c399654fe6f30cc4c1003aee3b0 ChangeLog 424
+MD5 7e285f080272b311b0eb8b0028928e07 metadata.xml 219
MD5 88e94451ca673f24fe04a290f6675c88 files/digest-qemu-0.5.1 62
diff --git a/app-emulation/qemu/files/digest-qemu-0.5.1 b/app-emulation/qemu/files/digest-qemu-0.5.1
new file mode 100644
index 000000000000..33ce566cef33
--- /dev/null
+++ b/app-emulation/qemu/files/digest-qemu-0.5.1
@@ -0,0 +1 @@
+MD5 b18b24b24ca7c40aabb4aa211b50527b qemu-0.5.1.tar.gz 503435
diff --git a/app-emulation/qemu/metadata.xml b/app-emulation/qemu/metadata.xml
new file mode 100644
index 000000000000..d66bb0cd26df
--- /dev/null
+++ b/app-emulation/qemu/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>zul@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-emulation/qemu/qemu-0.5.1.ebuild b/app-emulation/qemu/qemu-0.5.1.ebuild
new file mode 100644
index 000000000000..b757a0f4f469
--- /dev/null
+++ b/app-emulation/qemu/qemu-0.5.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.5.1.ebuild,v 1.1 2004/01/03 16:54:38 zul Exp $
+
+DESCRIPTION="Multi-platform & multi-targets dynamic translator"
+SRC_URI="http://fabrice.bellard.free.fr/qemu/qemu-0.5.1.tar.gz"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+
+KEYWORDS="~x86 ~ppc -alpha -sparc -arm"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+IUSE=""
+
+DEPEND="virtual/glibc
+ media-libs/libsdl"
+RDEPEND=""
+
+RESTRICT="nostrip"
+
+TARGET_LIST="arm-user i386-user i386-softmmu ppc-user sparc-user"
+
+src_compile () {
+ ./configure --prefix=/usr \
+ --target-list="${TARGET_LIST}" || die "could not configure"
+ make || die "make failed"
+}
+
+src_install() {
+ dobin qemu-mkcow
+ dodir /usr/share/qemu
+ insinto /usr/share/qemu
+ doins pc-bios/bios.bin pc-bios/vgabios.bin
+ doman qemu.1
+
+ dobin arm-user/qemu-arm
+ dobin i386-user/qemu-i386
+ dobin sparc-user/qemu-sparc
+ dobin ppc-user/qemu-ppc
+ dobin sparc-user/qemu-sparc
+
+ dobin i386-softmmu/qemu
+
+ dodoc README README.distrib *.html linux.sh
+}
+
+pkg_postinstall() {
+ echo ">> You will need the Universal TUN/TAP driver compiled into"
+ echo ">> kernel or as a module to use the virtual network device."
+}