summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2005-09-11 02:25:08 +0000
committerLuca Barbato <lu_zero@gentoo.org>2005-09-11 02:25:08 +0000
commit9659a2cec3fced2f8a9a125863620a0b7a11af50 (patch)
treeca91a1ddd7c70de4aba02b5d9948624b23c6d41e /app-emulation/qemu-softmmu
parentNew version (diff)
downloadhistorical-9659a2cec3fced2f8a9a125863620a0b7a11af50.tar.gz
historical-9659a2cec3fced2f8a9a125863620a0b7a11af50.tar.bz2
historical-9659a2cec3fced2f8a9a125863620a0b7a11af50.zip
New version
Package-Manager: portage-1.589-cvs
Diffstat (limited to 'app-emulation/qemu-softmmu')
-rw-r--r--app-emulation/qemu-softmmu/ChangeLog7
-rw-r--r--app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.7.22
-rw-r--r--app-emulation/qemu-softmmu/qemu-softmmu-0.7.2.ebuild143
3 files changed, 151 insertions, 1 deletions
diff --git a/app-emulation/qemu-softmmu/ChangeLog b/app-emulation/qemu-softmmu/ChangeLog
index 0419a88a7f2b..da5a725ec1b2 100644
--- a/app-emulation/qemu-softmmu/ChangeLog
+++ b/app-emulation/qemu-softmmu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu-softmmu
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.6 2005/08/19 21:37:02 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/ChangeLog,v 1.7 2005/09/11 02:25:08 lu_zero Exp $
+
+*qemu-softmmu-0.7.2 (11 Sep 2005)
+
+ 11 Sep 2005; Luca Barbato <lu_zero@gentoo.org> +qemu-softmmu-0.7.2.ebuild:
+ New release
19 Aug 2005; Aron Griffis <agriffis@gentoo.org>
qemu-softmmu-0.7.1-r1.ebuild:
diff --git a/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.7.2 b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.7.2
new file mode 100644
index 000000000000..2e8374c40c48
--- /dev/null
+++ b/app-emulation/qemu-softmmu/files/digest-qemu-softmmu-0.7.2
@@ -0,0 +1,2 @@
+MD5 7d69dd96edf7ae5298a9a7283a0e9fb8 qemu-0.7.2.tar.gz 1341993
+MD5 02cfdecda90458d6393781496ec6b48b kqemu-0.7.2.tar.gz 79314
diff --git a/app-emulation/qemu-softmmu/qemu-softmmu-0.7.2.ebuild b/app-emulation/qemu-softmmu/qemu-softmmu-0.7.2.ebuild
new file mode 100644
index 000000000000..f4d48d980f33
--- /dev/null
+++ b/app-emulation/qemu-softmmu/qemu-softmmu-0.7.2.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-softmmu/qemu-softmmu-0.7.2.ebuild,v 1.1 2005/09/11 02:25:08 lu_zero Exp $
+
+inherit eutils flag-o-matic linux-mod toolchain-funcs
+
+DESCRIPTION="Multi-platform & multi-targets cpu emulator and dynamic translator"
+HOMEPAGE="http://fabrice.bellard.free.fr/qemu/"
+SRC_URI="${HOMEPAGE}${P/-softmmu}.tar.gz
+ kqemu? ( ${HOMEPAGE}kqemu-${PV}.tar.gz )"
+#qvm86? ( http://dev.gentoo.org/~lu_zero/distfiles/qvm86-20050409.tar.bz2 )"
+#kqemu? ( http://fabrice.bellard.free.fr/qemu/kqemu-${PV%.*}-1.tar.gz )
+
+LICENSE="GPL-2 LGPL-2.1 KQEMU"
+SLOT="0"
+KEYWORDS="~x86 ~ppc -alpha -sparc ~amd64"
+IUSE="sdl kqemu" #qvm86 debug nptl qemu-fast nptlonly"
+RESTRICT="nostrip"
+
+DEPEND="virtual/libc
+ sdl? ( media-libs/libsdl )
+ !<=app-emulation/qemu-0.7.0
+ app-text/texi2html"
+RDEPEND="sdl? ( media-libs/libsdl )"
+
+S="${WORKDIR}/${P/-softmmu}"
+
+set_target_list() {
+ TARGET_LIST="i386-softmmu ppc-softmmu sparc-softmmu x86_64-softmmu"
+ export TARGET_LIST
+}
+
+pkg_setup() {
+ if [ "$(gcc-major-version)" == "4" ]; then
+ ewarn "Qemu could not build with GCC 4"
+ fi
+
+ MODULE_NAMES="$(useq kqemu && echo "kqemu(misc:${S}/kqemu)")"
+ # $(useq qvm86 && echo "qvm86(misc:${S}/qvm86)")"
+ #( use kqemu || use qvm86 ) && linux-mod_pkg_setup
+ use kqemu && linux-mod_pkg_setup
+
+ if use kqemu ; then
+ einfo "QEMU Accelerator enabled (USE=kqemu)"
+ einfo "kqemu is binary module with a restricted license."
+ einfo "Please read carefully the KQEMU license"
+ einfo "and ${HOMEPAGE}qemu-accel.html"
+ einfo "if you would like to see it released under the GPL"
+ fi
+}
+
+#RUNTIME_PATH="/emul/gnemul/"
+src_unpack() {
+ unpack ${A}
+
+ if use kqemu; then
+ mv ${WORKDIR}/kqemu ${S}
+ cd ${S}/kqemu
+ sed -i -e 's:#ifndef PAGE_KERNEL_EXEC:#if 1:' ${S}/kqemu/kqemu-linux.c
+ # The class_simple interfaces were removed in 2.6.13-rc1, leaving only
+ # GPL symbols behind, which this module can't use. Until there's a fix
+ # from Fabrice, kqemu+udev no worky.
+ fi
+ # if use qvm86; then
+# mv ${WORKDIR}/qvm86 ${S}
+# cd ${S}
+# epatch qvm86/patch.qvm86
+# fi
+ cd ${S}
+ #Fix errno mismatch on glibc-2.3.5
+
+ # Alter target makefiles to accept CFLAGS set via flag-o.
+ sed -i 's/^\(C\|OP_C\|HELPER_C\)FLAGS=/\1FLAGS+=/' \
+ Makefile Makefile.target tests/Makefile
+ # Ensure mprotect restrictions are relaxed for emulator binaries
+ [[ -x /sbin/paxctl ]] && \
+ sed -i 's/^VL_LDFLAGS=$/VL_LDFLAGS=-Wl,-z,execheap/' \
+ Makefile.target
+ # Prevent install of kernel module by qemu's makefile
+ sed -i 's/\(.\/install.sh\)/#\1/' Makefile
+}
+
+src_compile() {
+ #Let the application set its cflags
+ unset CFLAGS
+
+ # Switch off hardened tech
+ filter-flags -fpie -fstack-protector
+
+ myconf=""
+ if ! use sdl ; then
+ myconf="$myconf --disable-gfx-check"
+ fi
+ set_target_list
+# --interp-prefix=${RUNTIME_PATH}/qemu-%M
+ ./configure \
+ --prefix=/usr \
+ --target-list="${TARGET_LIST}" \
+ --enable-slirp \
+ --kernel-path=${KV_DIR} \
+ $(use_enable kqemu) \
+ ${myconf} \
+ $(use_enable sdl)\
+ || die "could not configure"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ make install \
+ prefix=${D}/usr \
+ bindir=${D}/usr/bin \
+ datadir=${D}/usr/share/qemu \
+ docdir=${D}/usr/share/doc/${P} \
+ mandir=${D}/usr/share/man || die
+
+ chmod -x ${D}/usr/share/man/*/*
+
+ if use kqemu ; then
+
+ linux-mod_src_install
+
+ # udev rule
+ dodir /etc/udev/rules.d/
+ echo 'KERNEL="kqemu*", NAME="%k", GROUP="qemu", MODE="0660"' \
+ > ${D}/etc/udev/rules.d/48-qemu.rules
+ enewgroup qemu
+
+ # Module doc
+ dodoc ${S}/kqemu/README
+
+ fi
+}
+
+pkg_postinst() {
+ einfo "You will need the Universal TUN/TAP driver compiled into"
+ einfo "kernel or as a module to use the virtual network device."
+ if use kqemu ; then
+ linux-mod_pkg_postinst
+ einfo "Make sure you have the kernel module loaded before running qemu"
+ einfo "and your user is in the qemu group"
+ fi
+}