summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-06-03 02:53:20 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-06-03 02:53:20 +0000
commit374b06953c1041eff535d1da3ac9d2e921382b98 (patch)
tree5eedba8c721b40f0363f342915e3ad78ec7ffbf2 /app-emulation/psemu-peopssoftgpu
parentdependency fix (diff)
downloadhistorical-374b06953c1041eff535d1da3ac9d2e921382b98.tar.gz
historical-374b06953c1041eff535d1da3ac9d2e921382b98.tar.bz2
historical-374b06953c1041eff535d1da3ac9d2e921382b98.zip
New package. Fixes #3266-#3274
Diffstat (limited to 'app-emulation/psemu-peopssoftgpu')
-rw-r--r--app-emulation/psemu-peopssoftgpu/ChangeLog13
-rw-r--r--app-emulation/psemu-peopssoftgpu/files/digest-psemu-peopssoftgpu-1.61
-rw-r--r--app-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.6.ebuild45
3 files changed, 59 insertions, 0 deletions
diff --git a/app-emulation/psemu-peopssoftgpu/ChangeLog b/app-emulation/psemu-peopssoftgpu/ChangeLog
new file mode 100644
index 000000000000..31b4b2978abd
--- /dev/null
+++ b/app-emulation/psemu-peopssoftgpu/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-emulation/psemu-peopssoftgpu
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/psemu-peopssoftgpu/ChangeLog,v 1.1 2002/06/03 02:53:20 rphillips Exp $
+
+*psemu-peopssoftgpu (2 June 2002)
+
+ 2 June 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-emulation/psemu-peopssoftgpu/files/digest-psemu-peopssoftgpu-1.6 b/app-emulation/psemu-peopssoftgpu/files/digest-psemu-peopssoftgpu-1.6
new file mode 100644
index 000000000000..5a96119dfe1f
--- /dev/null
+++ b/app-emulation/psemu-peopssoftgpu/files/digest-psemu-peopssoftgpu-1.6
@@ -0,0 +1 @@
+MD5 93a49d390ded0c2db945927e1306be08 PeopsSoftGpu106.tar.gz 614725
diff --git a/app-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.6.ebuild b/app-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.6.ebuild
new file mode 100644
index 000000000000..c85ddb3781a0
--- /dev/null
+++ b/app-emulation/psemu-peopssoftgpu/psemu-peopssoftgpu-1.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author Per Wigren <wigren@home.se>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.7 2002/05/18 17:25:12 agenkin Exp
+
+DESCRIPTION="P.E.Op.S Software GPU plugin"
+HOMEPAGE="http://peops.sourceforge.net"
+LICENSE="GPL-2"
+DEPEND="x11-libs/gtk+
+ dev-lang/nasm
+ sdl? ( media-libs/libsdl )"
+SRC_URI="http://telia.dl.sourceforge.net/sourceforge/peops/PeopsSoftGpu106.tar.gz"
+S=${WORKDIR}
+
+lowercase() {
+ for f in $*; do
+ mv "$f" "$(echo $f | tr A-Z a-z)"
+ done
+}
+
+src_compile() {
+ cd src
+ lowercase makes/mk.X11 Gpu.[ch] Stdafx.h Cfg.c Draw.c Key.c Menu.c \
+ Prim.c Soft.c
+ sed 's:CFLAGS =:CFLAGS +=:g' <makes/plg.mk >makes/plg.mk.tmp
+ mv -f makes/plg.mk.tmp makes/plg.mk
+
+ emake || die "Failed to make X11-version"
+
+ use sdl && (
+ sed 's:mk.x11:mk.fpse:g' <Makefile >Makefile.sdl
+ echo 'INCLUDE = `sdl-config --cflags`' >makes/mk.fpse.tmp
+ sed 's:-lSDL:`sdl-config --libs`:g' <makes/mk.fpse >>makes/mk.fpse.tmp
+ mv -f makes/mk.fpse.tmp makes/mk.fpse
+ make clean
+ emake -f Makefile.sdl || die "Failed to make SDL-version"
+ )
+}
+
+src_install () {
+ insinto /usr/lib/psemu/plugins/
+ doins src/libgpu*
+ dodoc readme_1_6.txt version_1_6.txt
+}
+