summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-23 22:51:04 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-23 22:51:04 +0000
commitad1aa59091df5f1c5ef32e0972b30bcfbb21468d (patch)
treee5c8e4268156395b4ad988c5a35855632bb27191 /app-emulation/point2play
parentQA - fix use invocation (diff)
downloadhistorical-ad1aa59091df5f1c5ef32e0972b30bcfbb21468d.tar.gz
historical-ad1aa59091df5f1c5ef32e0972b30bcfbb21468d.tar.bz2
historical-ad1aa59091df5f1c5ef32e0972b30bcfbb21468d.zip
patch this hippy crap #35755
Diffstat (limited to 'app-emulation/point2play')
-rw-r--r--app-emulation/point2play/ChangeLog6
-rw-r--r--app-emulation/point2play/Manifest11
-rw-r--r--app-emulation/point2play/files/1.3-fix-sound-test.patch19
-rw-r--r--app-emulation/point2play/point2play-1.3.ebuild7
4 files changed, 36 insertions, 7 deletions
diff --git a/app-emulation/point2play/ChangeLog b/app-emulation/point2play/ChangeLog
index 54663e90141a..e841acb9cdf6 100644
--- a/app-emulation/point2play/ChangeLog
+++ b/app-emulation/point2play/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/point2play
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.10 2004/06/23 22:24:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/ChangeLog,v 1.11 2004/06/23 22:51:04 vapier Exp $
+
+ 23 Jun 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/1.3-fix-sound-test.patch, point2play-1.3.ebuild:
+ Patch the sound test to actually work #35755.
*point2play-1.3 (23 Jun 2004)
diff --git a/app-emulation/point2play/Manifest b/app-emulation/point2play/Manifest
index d132fcd12a23..887b25c097f8 100644
--- a/app-emulation/point2play/Manifest
+++ b/app-emulation/point2play/Manifest
@@ -1,12 +1,12 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 4e2fe02181c2b8ed6ac57b73d22ad77a ChangeLog 1633
+MD5 d4db7af546aea12e5adda85c3db484e8 ChangeLog 1790
MD5 086d7322b591c18822e6a6ef25213c3b metadata.xml 465
MD5 399eb0652e453efce8c987716c1cbfef point2play-1.1.1-r1.ebuild 906
MD5 5bf426bb09f8557e11cfb1d7fd9863cd point2play-1.2.ebuild 901
MD5 76b3d98d84a14584b25d9e593575bbc4 point2play-1.2.1.ebuild 814
-MD5 22314e0254de33a418096827cb020042 point2play-1.3.ebuild 866
+MD5 159695e1ee9bc376b138b46741932548 point2play-1.3.ebuild 944
MD5 7d243e640984795605b7c4d91200ad47 point2play-1.2.2b-r2.ebuild 1026
MD5 e4ff3be195cda12b76cdca866100ecfb files/Point2Play 281
MD5 8f95e756e8e01ff5a51b2f52b32b2cbc files/1.1.1-python2.2.patch 1280
@@ -15,11 +15,12 @@ MD5 8f95e756e8e01ff5a51b2f52b32b2cbc files/1.2-python2.2.patch 1280
MD5 82ee0eecdabe531c9b1aabcd4c912548 files/digest-point2play-1.2 69
MD5 ebd7763c0f49a9cedfc2cd931c328117 files/digest-point2play-1.2.1 71
MD5 aacc93775598929262ccc93f7e7d91ae files/digest-point2play-1.3 69
+MD5 04e6a404729841723f5e82c2128f9337 files/1.3-fix-sound-test.patch 1070
MD5 ea2e65abe17a6dd0a9b7a36742acbdbf files/digest-point2play-1.2.2b-r2 68
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.9.8 (GNU/Linux)
-iD8DBQFA2gMqHTu7gpaalycRAi2UAKCJIcGdE+a7vzB8P7Q6ZQ81OVgPFwCdHL/+
-6jxwztM1drfTsHDwDGK9nx0=
-=lk61
+iD8DBQFA2glkHTu7gpaalycRAi/tAJ47zbpzsLPDZcpxcu63Y2Zpsww8EwCdHYBY
+1S9Q/OhfriHJAj5A57zgKqo=
+=6mvC
-----END PGP SIGNATURE-----
diff --git a/app-emulation/point2play/files/1.3-fix-sound-test.patch b/app-emulation/point2play/files/1.3-fix-sound-test.patch
new file mode 100644
index 000000000000..edd728860636
--- /dev/null
+++ b/app-emulation/point2play/files/1.3-fix-sound-test.patch
@@ -0,0 +1,19 @@
+--- usr/lib/transgaming_point2play/tests/test_sound.py.suckit 2004-06-22 01:28:14.000000000 -0400
++++ usr/lib/transgaming_point2play/tests/test_sound.py 2004-06-23 18:46:52.866931568 -0400
+@@ -30,14 +31,12 @@
+ except:
+ return ((_('Basic sound test'), _("Unable to open sound file,\nCan not test sound card"), 'red'),)
+ try:
+- audio_out = ossaudiodev.open('/dev/dsp', 'w')
++ audio_out = ossaudiodev.open('w')
+ except IOError, e:
+ return ((_('Basic sound test'), _('Unable to open /dev/dsp'), 'red'),)
+
+ try:
+- audio_out.setparameters(TestSound1.getframerate(), 16,
+- TestSound1.getnchannels(), ossaudiodev.AFMT_S16_LE, False)
+- #FIXME: use getsampwidth for 16 and AFMT_S16_LE
++ audio_out.setparameters(ossaudiodev.AFMT_S16_LE, TestSound1.getnchannels(), TestSound1.getframerate())
+ except:
+ audio_out.close()
+ return ((_('Basic sound test'), _('Unable to play sound, your\nSound card may not be configured correctly'), 'red'),)
diff --git a/app-emulation/point2play/point2play-1.3.ebuild b/app-emulation/point2play/point2play-1.3.ebuild
index 00b80235481b..583900b60566 100644
--- a/app-emulation/point2play/point2play-1.3.ebuild
+++ b/app-emulation/point2play/point2play-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.3.ebuild,v 1.1 2004/06/23 22:24:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-1.3.ebuild,v 1.2 2004/06/23 22:51:04 vapier Exp $
inherit eutils
@@ -29,6 +29,11 @@ pkg_nofetch() {
einfo "The archive should then be placed into ${DISTDIR}"
}
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-fix-sound-test.patch
+}
+
src_install() {
mv usr ${D}/
mv etc/X11/applnk ${D}/usr/share