summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-08 01:04:47 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-08 01:04:47 +0000
commitac4dd7531688535d5bc56a7e6660ff8da41fd12c (patch)
treec2918aae2cfd70461d24b04804fc1157907f1864 /app-emulation/point2play/point2play-2.0.1.ebuild
parentAdding ~mips keyword as per bug #82560 (diff)
downloadhistorical-ac4dd7531688535d5bc56a7e6660ff8da41fd12c.tar.gz
historical-ac4dd7531688535d5bc56a7e6660ff8da41fd12c.tar.bz2
historical-ac4dd7531688535d5bc56a7e6660ff8da41fd12c.zip
Version bump #95376 by Mike Hepple.
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'app-emulation/point2play/point2play-2.0.1.ebuild')
-rw-r--r--app-emulation/point2play/point2play-2.0.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-emulation/point2play/point2play-2.0.1.ebuild b/app-emulation/point2play/point2play-2.0.1.ebuild
new file mode 100644
index 000000000000..384fdc581e39
--- /dev/null
+++ b/app-emulation/point2play/point2play-2.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/point2play/point2play-2.0.1.ebuild,v 1.1 2005/06/08 01:04:47 vapier Exp $
+
+inherit eutils
+
+MY_P=${PN}-small-${PV}
+DESCRIPTION="graphical frontend for WineX"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="point2play"
+SLOT="0"
+KEYWORDS="-* ~amd64 x86"
+IUSE=""
+RESTRICT="fetch"
+
+RDEPEND="virtual/x11
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.4"
+ #>=x11-themes/gtk-engines-metal-2.2.0"
+
+S=${WORKDIR}
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Point2Play archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ echo
+ einfo "The archive should then be placed into ${DISTDIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/1.3.2-fix-sound-test.patch
+}
+
+src_install() {
+ mv usr "${D}"/ || die "mv usr"
+ mv etc/X11/applnk "${D}"/usr/share
+ make_desktop_entry Point2Play Point2Play /usr/lib/transgaming_point2play/pixmaps/tg_logo.png
+}