summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2011-11-11 14:20:20 +0000
committerVadim Kuznetsov <vadimk@gentoo.org>2011-11-11 14:20:20 +0000
commit1242242117b3e806b4124577d93cccad92d184d5 (patch)
tree5424fbe0b8d33ce969f00286d7eba687bb9deb07 /app-emulation/open-vm-tools
parentAdded me as maintainer (diff)
downloadhistorical-1242242117b3e806b4124577d93cccad92d184d5.tar.gz
historical-1242242117b3e806b4124577d93cccad92d184d5.tar.bz2
historical-1242242117b3e806b4124577d93cccad92d184d5.zip
version bump
Package-Manager: portage-2.1.10.33/cvs/Linux x86_64
Diffstat (limited to 'app-emulation/open-vm-tools')
-rw-r--r--app-emulation/open-vm-tools/ChangeLog9
-rw-r--r--app-emulation/open-vm-tools/files/network24
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20110923.491607.ebuild14
-rw-r--r--app-emulation/open-vm-tools/open-vm-tools-0.0.20111026.514583.ebuild120
4 files changed, 156 insertions, 11 deletions
diff --git a/app-emulation/open-vm-tools/ChangeLog b/app-emulation/open-vm-tools/ChangeLog
index 4df9e17ed965..47b855b664fc 100644
--- a/app-emulation/open-vm-tools/ChangeLog
+++ b/app-emulation/open-vm-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emulation/open-vm-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.54 2011/10/17 19:36:05 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/ChangeLog,v 1.55 2011/11/11 14:20:19 vadimk Exp $
+
+*open-vm-tools-0.0.20111026.514583 (11 Nov 2011)
+
+ 11 Nov 2011; Vadim Kuznetsov <vadimk@gentoo.org>
+ open-vm-tools-0.0.20110923.491607.ebuild,
+ +open-vm-tools-0.0.20111026.514583.ebuild, +files/network:
+ version bump
*open-vm-tools-0.0.20110923.491607 (17 Oct 2011)
diff --git a/app-emulation/open-vm-tools/files/network b/app-emulation/open-vm-tools/files/network
new file mode 100644
index 000000000000..dabd18326ae3
--- /dev/null
+++ b/app-emulation/open-vm-tools/files/network
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+#
+# net.eth0, net.eth1, network, wicd, NetworkManager
+service="net.eth0"
+
+if [ $(rc-service -e net.eth0) ]
+then
+ service="net.eth0"
+else
+ service="network"
+fi
+
+case "$1" in
+ suspend-vm)
+ rc-service $service stop
+ ;;
+ resume-vm)
+ rc-service $service start
+ ;;
+ *)
+ ;;
+esac
+
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20110923.491607.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20110923.491607.ebuild
index 665126c5d355..cd25980394db 100644
--- a/app-emulation/open-vm-tools/open-vm-tools-0.0.20110923.491607.ebuild
+++ b/app-emulation/open-vm-tools/open-vm-tools-0.0.20110923.491607.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20110923.491607.ebuild,v 1.1 2011/10/17 19:36:05 vadimk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20110923.491607.ebuild,v 1.2 2011/11/11 14:20:19 vadimk Exp $
EAPI="2"
@@ -18,7 +18,7 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="X doc fuse icu +pic unity xinerama"
+IUSE="X doc fuse icu +pic xinerama"
RDEPEND="app-emulation/open-vm-tools-kmod
dev-libs/glib:2
@@ -38,11 +38,6 @@ RDEPEND="app-emulation/open-vm-tools-kmod
)
fuse? ( sys-fs/fuse )
icu? ( dev-libs/icu )
- unity? (
- dev-libs/uriparser
- media-libs/libpng
- x11-libs/libXScrnSaver
- )
xinerama? ( x11-libs/libXinerama )
"
@@ -56,8 +51,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
pkg_setup() {
- use unity && ! use X && die 'The Unity USE flag requires "X" USE flag as well'
- use unity && ! use xinerama && die 'The Unity USE flag requires xinerame USE="xinerama" as well'
+ #use unity && ! use X && die 'The Unity USE flag requires "X" USE flag as well'
+ #use unity && ! use xinerama && die 'The Unity USE flag requires xinerame USE="xinerama" as well'
enewgroup vmware
}
@@ -84,7 +79,6 @@ src_configure() {
$(use_with X gtkmm) \
$(use_with icu) \
$(use_with pic) \
- $(use_enable unity) \
$(use_enable xinerama multimon)
# Bugs 260878, 326761
diff --git a/app-emulation/open-vm-tools/open-vm-tools-0.0.20111026.514583.ebuild b/app-emulation/open-vm-tools/open-vm-tools-0.0.20111026.514583.ebuild
new file mode 100644
index 000000000000..afc114915bd7
--- /dev/null
+++ b/app-emulation/open-vm-tools/open-vm-tools-0.0.20111026.514583.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/open-vm-tools/open-vm-tools-0.0.20111026.514583.ebuild,v 1.1 2011/11/11 14:20:19 vadimk Exp $
+
+EAPI="2"
+
+inherit eutils pam versionator
+
+MY_DATE="$(get_version_component_range 3)"
+MY_BUILD="$(get_version_component_range 4)"
+MY_PV="${MY_DATE:0:4}.${MY_DATE:4:2}.${MY_DATE:6:2}-${MY_BUILD}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Opensourced tools for VMware guests"
+HOMEPAGE="http://open-vm-tools.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X doc fuse icu +pic xinerama"
+
+RDEPEND="app-emulation/open-vm-tools-kmod
+ dev-libs/glib:2
+ dev-libs/libdnet
+ sys-apps/ethtool
+ sys-process/procps
+ virtual/pam
+ X? (
+ dev-cpp/gtkmm:2.4
+ x11-base/xorg-server
+ x11-drivers/xf86-input-vmmouse
+ x11-drivers/xf86-video-vmware
+ x11-libs/gtk+:2
+ x11-libs/libnotify
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ fuse? ( sys-fs/fuse )
+ icu? ( dev-libs/icu )
+ xinerama? ( x11-libs/libXinerama )
+ "
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-util/pkgconfig
+ virtual/linux-sources
+ sys-apps/findutils
+ "
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ #use unity && ! use X && die 'The Unity USE flag requires "X" USE flag as well'
+ #use unity && ! use xinerama && die 'The Unity USE flag requires xinerame USE="xinerama" as well'
+
+ enewgroup vmware
+}
+
+src_prepare() {
+ #epatch "${FILESDIR}/default-scripts.patch"
+ #epatch "${FILESDIR}/checkvm-pie-safety.patch"
+ #sed -i -e 's/proc-3.2.7/proc/g' configure || die "sed configure failed"
+ # Do not filter out Werror
+ # Upstream Bug http://sourceforge.net/tracker/?func=detail&aid=2959749&group_id=204462&atid=989708
+ # sed -i -e 's/CFLAGS=.*Werror/#&/g' configure || die "sed comment out Werror failed"
+ sed -i -e 's:\(TEST_PLUGIN_INSTALLDIR=\).*:\1\$libdir/open-vm-tools/plugins/tests:g' configure || die "sed test_plugin_installdir failed"
+}
+
+src_configure() {
+ econf \
+ --with-procps \
+ --with-dnet \
+ --without-kernel-modules \
+ $(use_enable doc docs) \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_with X x) \
+ $(use_with X gtk2) \
+ $(use_with X gtkmm) \
+ $(use_with icu) \
+ $(use_with pic) \
+ $(use_enable xinerama multimon)
+
+ # Bugs 260878, 326761
+ find ./ -name Makefile | xargs sed -i -e 's/-Werror//g' || die "sed out Werror failed"
+}
+
+src_compile() {
+ emake || die "failed to compile"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "failed to install"
+
+ rm "${D}"/etc/pam.d/vmtoolsd
+ pamd_mimic_system vmtoolsd auth account
+
+ rm "${D}"/usr/$(get_libdir)/*.la
+ rm "${D}"/usr/$(get_libdir)/open-vm-tools/plugins/common/*.la
+
+ newinitd "${FILESDIR}/open-vm-tools.initd" vmware-tools || die "failed to newinitd"
+ newconfd "${FILESDIR}/open-vm.confd" vmware-tools || die "failed to newconfd"
+
+ exeinto /etc/vmware-tools/scripts/vmware/
+ doexe "${FILESDIR}"/network
+
+ if use X;
+ then
+ fperms 4755 "/usr/bin/vmware-user-suid-wrapper" || die
+
+ dobin "${S}"/scripts/common/vmware-xdg-detect-de
+
+ insinto /etc/xdg/autostart
+ doins "${FILESDIR}/open-vm-tools.desktop" || die "failed to install .desktop"
+
+ elog "To be able to use the drag'n'drop feature of VMware for file"
+ elog "exchange, please add the users to the 'vmware' group."
+ fi
+ elog "Add 'vmware-tools' service to the default runlevel."
+}