summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-01-27 18:18:12 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-01-27 18:18:12 +0000
commitd4f36f9d8ea05a53ba9aede4dde5934cfff3c4e5 (patch)
tree65013a867c3e3a80830bee30df9187fa69c33827 /app-emulation/mol
parentbetter RDEPEND (diff)
downloadhistorical-d4f36f9d8ea05a53ba9aede4dde5934cfff3c4e5.tar.gz
historical-d4f36f9d8ea05a53ba9aede4dde5934cfff3c4e5.tar.bz2
historical-d4f36f9d8ea05a53ba9aede4dde5934cfff3c4e5.zip
Added nopriority patches to fix bug #75254.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-emulation/mol')
-rw-r--r--app-emulation/mol/ChangeLog8
-rw-r--r--app-emulation/mol/Manifest12
-rw-r--r--app-emulation/mol/files/mol-0.9.70-nopriority.patch63
-rw-r--r--app-emulation/mol/files/mol-0.9.71_pre1-nopriority.patch63
-rw-r--r--app-emulation/mol/mol-0.9.70.ebuild3
-rw-r--r--app-emulation/mol/mol-0.9.71_pre1.ebuild3
6 files changed, 144 insertions, 8 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
index 4de98b94cb44..0506dea29046 100644
--- a/app-emulation/mol/ChangeLog
+++ b/app-emulation/mol/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/mol
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.41 2005/01/18 12:04:42 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/ChangeLog,v 1.42 2005/01/27 18:18:12 josejx Exp $
+
+ 28 Jan 2005; Joseph Jezak <josejx@gentoo.org>
+ +files/mol-0.9.70-nopriority.patch,
+ +files/mol-0.9.71_pre1-nopriority.patch, mol-0.9.70.ebuild,
+ mol-0.9.71_pre1.ebuild:
+ Added nopriority patches to fix bug #75254.
*mol-0.9.71_pre1 (18 Jan 2005)
diff --git a/app-emulation/mol/Manifest b/app-emulation/mol/Manifest
index 3904b587e611..a4c20e828a58 100644
--- a/app-emulation/mol/Manifest
+++ b/app-emulation/mol/Manifest
@@ -1,8 +1,10 @@
+MD5 bd7d894e95effc2a5f228b24e42b2717 ChangeLog 8336
+MD5 21e8bed87e5fa4da6b0a02fe7133e31b mol-0.9.70.ebuild 3938
MD5 3263d375abba2d098c636efc2b135ea5 metadata.xml 333
-MD5 01acda05cf5e3a7ed2788201ff3b9f36 mol-0.9.70.ebuild 3895
-MD5 98e30b0826c20a57ad2a628ad147a95a mol-0.9.71_pre1.ebuild 4008
-MD5 1aedd398b68c42b5d0abd177cc62ed69 ChangeLog 8114
-MD5 3944510308e77b92ac85c07708947ad0 files/digest-mol-0.9.70 64
-MD5 0ea7bd65a5ff4666665a71fb9652aae8 files/mol-0.9.70-makefile-fix.patch 924
+MD5 bed6f1ce7cb68d6a2f960221656931c9 mol-0.9.71_pre1.ebuild 4051
+MD5 934e9ecf483ff3c4e34bb6307212d776 files/mol-0.9.70-nopriority.patch 1853
MD5 2f8f758938db9b3cb5a13c0b33d989e3 files/mol-module-fix.patch 327
MD5 453e05b555f037270dd6da665e100aa8 files/digest-mol-0.9.71_pre1 69
+MD5 0ea7bd65a5ff4666665a71fb9652aae8 files/mol-0.9.70-makefile-fix.patch 924
+MD5 3944510308e77b92ac85c07708947ad0 files/digest-mol-0.9.70 64
+MD5 3bf68312e4299f777065f55eea5297fa files/mol-0.9.71_pre1-nopriority.patch 1861
diff --git a/app-emulation/mol/files/mol-0.9.70-nopriority.patch b/app-emulation/mol/files/mol-0.9.70-nopriority.patch
new file mode 100644
index 000000000000..9f0a5883a5c0
--- /dev/null
+++ b/app-emulation/mol/files/mol-0.9.70-nopriority.patch
@@ -0,0 +1,63 @@
+diff -Naur src/drivers/disk/ablk.c src/drivers/disk/ablk.c
+--- src/drivers/disk/ablk.c 2005-01-07 16:25:34.540100128 +1100
++++ src/drivers/disk/ablk.c 2005-01-07 16:28:05.243189776 +1100
+@@ -216,7 +216,7 @@
+ io_thread( void *dummy )
+ {
+ char ch;
+- setpriority( PRIO_PROCESS, getpid(), -19 );
++ /* setpriority( PRIO_PROCESS, getpid(), -19 ); */
+
+ for( ;; ) {
+ read( ablk.ctrl_pipe[0], &ch, 1 );
+diff -Naur src/drivers/osi_sound.c src/drivers/osi_sound.c
+--- src/drivers/osi_sound.c 2005-01-07 16:25:34.491107576 +1100
++++ src/drivers/osi_sound.c 2005-01-07 16:27:30.586458400 +1100
+@@ -676,7 +676,7 @@
+ static void
+ audio_thread( void *dummy )
+ {
+- setpriority( PRIO_PROCESS, getpid(), -20 );
++ /* setpriority( PRIO_PROCESS, getpid(), -20 ); */
+
+ LOCK;
+ if( ss.ringbuf )
+@@ -695,7 +695,7 @@
+ ss.startboingbuf = NULL;
+ }
+ UNLOCK;
+- setpriority( PRIO_PROCESS, getpid(), 0 );
++ /* setpriority( PRIO_PROCESS, getpid(), 0 ); */
+ }
+
+
+@@ -770,7 +770,7 @@
+ ss.started = 0;
+
+ LOCK;
+- setpriority( PRIO_PROCESS, getpid(), ss.save_priority );
++ /* setpriority( PRIO_PROCESS, getpid(), ss.save_priority ); */
+
+ ss.thread_running = -1;
+ irq_line_low( ss.irq );
+@@ -795,7 +795,7 @@
+ ss.dbuf_go = 0;
+
+ ss.save_priority = getpriority( PRIO_PROCESS, pid );
+- setpriority( PRIO_PROCESS, pid, -12 );
++ /* setpriority( PRIO_PROCESS, pid, -12 ); */
+
+ if( ss.thread_running ) {
+ /* jump start already running thread */
+diff -Naur src/main/async.c src/main/async.c
+--- src/main/async.c 2005-01-07 16:25:34.661081736 +1100
++++ src/main/async.c 2005-01-07 16:26:15.242912360 +1100
+@@ -191,7 +191,7 @@
+ char ack_char;
+
+ /* Increase priority to reduce latency */
+- setpriority( PRIO_PROCESS, getpid(), -17 );
++ /* setpriority( PRIO_PROCESS, getpid(), -17 ); */
+
+ while( !cancel_poll_thread ) {
+ if( (num_pending=poll(ufds, num_poll, -1)) < 0 ) {
diff --git a/app-emulation/mol/files/mol-0.9.71_pre1-nopriority.patch b/app-emulation/mol/files/mol-0.9.71_pre1-nopriority.patch
new file mode 100644
index 000000000000..43017d938640
--- /dev/null
+++ b/app-emulation/mol/files/mol-0.9.71_pre1-nopriority.patch
@@ -0,0 +1,63 @@
+diff -Naur src/drivers/disk/ablk.c src/drivers/disk/ablk.c
+--- src/drivers/disk/ablk.c 2005-01-07 16:25:34.540100128 +1100
++++ src/drivers/disk/ablk.c 2005-01-07 16:28:05.243189776 +1100
+@@ -216,7 +216,7 @@
+ io_thread( void *dummy )
+ {
+ char ch;
+- setpriority( PRIO_PROCESS, getpid(), -19 );
++ /* setpriority( PRIO_PROCESS, getpid(), -19 ); */
+
+ for( ;; ) {
+ read( ablk.ctrl_pipe[0], &ch, 1 );
+diff -Naur src/drivers/sound/sound.c src/drivers/sound/sound.c
+--- src/drivers/sound/sound.c 2005-01-07 16:25:34.491107576 +1100
++++ src/drivers/sound/sound.c 2005-01-07 16:27:30.586458400 +1100
+@@ -248,7 +248,7 @@
+ static void
+ audio_thread( void *dummy )
+ {
+- setpriority( PRIO_PROCESS, getpid(), -20 );
++ /* setpriority( PRIO_PROCESS, getpid(), -20 ); */
+
+ LOCK;
+ if( ss.ringbuf )
+@@ -267,7 +267,7 @@
+ ss.startboingbuf = NULL;
+ }
+ UNLOCK;
+- setpriority( PRIO_PROCESS, getpid(), 0 );
++ /* setpriority( PRIO_PROCESS, getpid(), 0 ); */
+ }
+
+
+@@ -341,7 +341,7 @@
+ ss.started = 0;
+
+ LOCK;
+- setpriority( PRIO_PROCESS, getpid(), ss.save_priority );
++ /* setpriority( PRIO_PROCESS, getpid(), ss.save_priority ); */
+
+ ss.thread_running = -1;
+ irq_line_low( ss.irq );
+@@ -366,7 +366,7 @@
+ ss.dbuf_go = 0;
+
+ ss.save_priority = getpriority( PRIO_PROCESS, pid );
+- setpriority( PRIO_PROCESS, pid, -12 );
++ /* setpriority( PRIO_PROCESS, pid, -12 ); */
+
+ if( ss.thread_running ) {
+ /* jump start already running thread */
+diff -Naur src/main/async.c src/main/async.c
+--- src/main/async.c 2005-01-07 16:25:34.661081736 +1100
++++ src/main/async.c 2005-01-07 16:26:15.242912360 +1100
+@@ -195,7 +195,7 @@
+ char ack_char;
+
+ /* Increase priority to reduce latency */
+- setpriority( PRIO_PROCESS, getpid(), -17 );
++ /* setpriority( PRIO_PROCESS, getpid(), -17 ); */
+
+ while( !cancel_poll_thread ) {
+ if( (num_pending=poll(ufds, num_poll, -1)) < 0 ) {
diff --git a/app-emulation/mol/mol-0.9.70.ebuild b/app-emulation/mol/mol-0.9.70.ebuild
index 205b85514045..fcd1f57c5a5c 100644
--- a/app-emulation/mol/mol-0.9.70.ebuild
+++ b/app-emulation/mol/mol-0.9.70.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.70.ebuild,v 1.11 2005/01/18 12:04:42 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.70.ebuild,v 1.12 2005/01/27 18:18:12 josejx Exp $
inherit flag-o-matic eutils
@@ -41,6 +41,7 @@ src_unpack() {
sed -i "s#VENDOR :=#VENDOR := -gentoo#" Makefile.top || die
epatch ${FILESDIR}/${P}-makefile-fix.patch
epatch ${FILESDIR}/${PN}-module-fix.patch
+ epatch ${FILESDIR}/${P}-nopriority.patch
}
src_compile() {
diff --git a/app-emulation/mol/mol-0.9.71_pre1.ebuild b/app-emulation/mol/mol-0.9.71_pre1.ebuild
index db2e068a9362..12f41565de91 100644
--- a/app-emulation/mol/mol-0.9.71_pre1.ebuild
+++ b/app-emulation/mol/mol-0.9.71_pre1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.71_pre1.ebuild,v 1.1 2005/01/18 12:04:42 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/mol/mol-0.9.71_pre1.ebuild,v 1.2 2005/01/27 18:18:12 josejx Exp $
inherit flag-o-matic eutils
@@ -34,6 +34,7 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${PN}-module-fix.patch
+ epatch ${FILESDIR}/${P}-nopriority.patch
# dhcp config fix and show dchpd messages on starting mol
sed -i "s:#ddns-update-style:ddns-update-style:g" Doc/config/dhcpd-mol.conf || die