summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Chamberlain <daybird@gentoo.org>2002-05-05 06:28:54 +0000
committerDavid Chamberlain <daybird@gentoo.org>2002-05-05 06:28:54 +0000
commit6263c25349170cb0367823550a3b216f1447b526 (patch)
tree812164888f0f7bc5fb91ade1b84c9746f24cee17 /app-emulation/mol
parentnew eclass for ebuilds for perl modules (diff)
downloadhistorical-6263c25349170cb0367823550a3b216f1447b526.tar.gz
historical-6263c25349170cb0367823550a3b216f1447b526.tar.bz2
historical-6263c25349170cb0367823550a3b216f1447b526.zip
mac-on-linux ebuild added
Diffstat (limited to 'app-emulation/mol')
-rw-r--r--app-emulation/mol/ChangeLog8
-rw-r--r--app-emulation/mol/files/digest-mol-0.9.631
-rw-r--r--app-emulation/mol/mol-0.9.63.ebuild32
3 files changed, 41 insertions, 0 deletions
diff --git a/app-emulation/mol/ChangeLog b/app-emulation/mol/ChangeLog
new file mode 100644
index 000000000000..771e5ad28c90
--- /dev/null
+++ b/app-emulation/mol/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for app-emulation/mol
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+
+*mol-0.9.63 (5 May 2002)
+
+ 5 May 2002; David Chamberlain <daybird@gentoo.org> ChangeLog :
+
+ Initial version (post ppc/x86 portage merge)
diff --git a/app-emulation/mol/files/digest-mol-0.9.63 b/app-emulation/mol/files/digest-mol-0.9.63
new file mode 100644
index 000000000000..7d1379ead763
--- /dev/null
+++ b/app-emulation/mol/files/digest-mol-0.9.63
@@ -0,0 +1 @@
+MD5 83c170398cec1f3249f61be1b7f30fa8 mol-0.9.63.tgz 1149432
diff --git a/app-emulation/mol/mol-0.9.63.ebuild b/app-emulation/mol/mol-0.9.63.ebuild
new file mode 100644
index 000000000000..697cfe625504
--- /dev/null
+++ b/app-emulation/mol/mol-0.9.63.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author David Chamberlain <daybird@gentoo.org>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="MOL (Mac-on-Linux) is a PPC-only program to run Mac OS <=9.2 natively within Linux"
+SRC_URI="ftp://ftp.nada.kth.se/pub/home/f95-sry/Public/mac-on-linux/${P}.tgz"
+HOMEPAGE="http://www.maconlinux.net/"
+
+DEPEND=""
+
+src_compile() {
+
+ ./configure --prefix=/usr || die "This is a ppc-only package (time to buy that iBook, no?)"
+ make || die "Failed to compile MOL"
+}
+
+src_install() {
+
+ make install || die "Failed to install MOL"
+
+ dodoc 0README BUILDING COPYING COPYRIGHT CREDITS Doc/*
+
+}
+
+pkg_postinst() {
+ einfo "Mac-on-Linux is now installed. To run, use the command startmol"
+ einfo "You might want to configure video modes first with molvconfig"
+ einfo "Other configuration is in /etc/molrc. For more info see:"
+ einfo " www.maconlinux.net"
+ einfo "Also try man molrc, man molvconfig, man startmol"
+}