summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlain Penders <alain@gentoo.org>2003-03-23 17:45:22 +0000
committerAlain Penders <alain@gentoo.org>2003-03-23 17:45:22 +0000
commitcd240813e6a53e4a03a659674e1c9b684ec60fc2 (patch)
treee76b054de79321e7eda9ee2f3eeb2c7ffb547d89 /app-emulation/hercules
parentversion bump (diff)
downloadhistorical-cd240813e6a53e4a03a659674e1c9b684ec60fc2.tar.gz
historical-cd240813e6a53e4a03a659674e1c9b684ec60fc2.tar.bz2
historical-cd240813e6a53e4a03a659674e1c9b684ec60fc2.zip
Hercules 2.17.1-r1
Diffstat (limited to 'app-emulation/hercules')
-rw-r--r--app-emulation/hercules/ChangeLog7
-rw-r--r--app-emulation/hercules/files/digest-hercules-2.17.1-r11
-rw-r--r--app-emulation/hercules/hercules-2.17.1-r1.ebuild57
3 files changed, 64 insertions, 1 deletions
diff --git a/app-emulation/hercules/ChangeLog b/app-emulation/hercules/ChangeLog
index f79110f34713..2f723051e953 100644
--- a/app-emulation/hercules/ChangeLog
+++ b/app-emulation/hercules/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/hercules
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.5 2003/03/09 00:00:11 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/ChangeLog,v 1.6 2003/03/23 17:45:22 alain Exp $
+
+*hercules-2.17.1-r1 (22 Mar 2003)
+
+ 22 Mar 2003; Alain Penders <alain@gentoo.org> :
+ Integrated changes provided by Todd Wright <wylie@geekasylum.org>
*hercules-2.17.1 (09 Mar 2003)
diff --git a/app-emulation/hercules/files/digest-hercules-2.17.1-r1 b/app-emulation/hercules/files/digest-hercules-2.17.1-r1
new file mode 100644
index 000000000000..d6dfdd90eeda
--- /dev/null
+++ b/app-emulation/hercules/files/digest-hercules-2.17.1-r1
@@ -0,0 +1 @@
+MD5 e98138eb45d114f2c4a805db91fe308c hercules-2.17.1.tar.gz 1172656
diff --git a/app-emulation/hercules/hercules-2.17.1-r1.ebuild b/app-emulation/hercules/hercules-2.17.1-r1.ebuild
new file mode 100644
index 000000000000..bf3590e31356
--- /dev/null
+++ b/app-emulation/hercules/hercules-2.17.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/hercules/hercules-2.17.1-r1.ebuild,v 1.1 2003/03/23 17:45:22 alain Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Hercules System/370, ESA/390 and zArchitecture Mainframe Emulator"
+SRC_URI="http://www.conmicro.cx/hercules/${P}.tar.gz"
+HOMEPAGE="http://www.conmicro.cx/hercules/"
+LICENSE="QPL-1.0"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/glibc
+ sys-apps/bzip2"
+
+src_compile() {
+ local mycflags
+ mycflags="${CFLAGS}"
+ unset CFLAGS ; unset CXXFLAGS
+
+ econf \
+ --enable-optimization="${mycflags}" \
+ --enable-cckd-bzip2 \
+ --enable-het-bzip2 \
+ --enable-setuid-hercifc \
+ --enable-custom="Gentoo Linux ${PF}.ebuild" \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install
+ dodoc INSTALL
+ dohtml -r html/
+ insinto /usr/share/hercules
+ doins hercules.cnf
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Hercules System/370, ESA/390 and zArchitecture Mainframe"
+ einfo "Emulator has been installed. Some useful utility files have"
+ einfo "been placed in /usr/share/hercules. For detailed configuration"
+ einfo "and operating instructions, see http://www.conmicro.cx/hercules"
+ einfo
+ einfo "In order to use Hercules you will need a guest operating"
+ einfo "system. There are several flavours of 'Linux for S/390' and"
+ einfo "'Linux for zSeries' available, or if you want that 'Big Iron'"
+ einfo "feel, you can download several real mainframe operating systems"
+ einfo "such as OS/360, DOS/VS, MVS, or VM370 from http://www.cbttape.org"
+ einfo
+ einfo "Hercules is also capable of runing OS/390, z/OS, and z/VM with an"
+ einfo "appropriate liscense."
+ einfo
+}