summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-16 17:33:44 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-16 17:33:44 +0000
commit86fed452c9fc7442a9f38d265441da251dd84c22 (patch)
tree3f355403e5acb7ea2365215ac031a93954b63045 /app-emulation/cedega
parentModified to use new wxwidgets eclass. Fixes bug# 60529 (diff)
downloadhistorical-86fed452c9fc7442a9f38d265441da251dd84c22.tar.gz
historical-86fed452c9fc7442a9f38d265441da251dd84c22.tar.bz2
historical-86fed452c9fc7442a9f38d265441da251dd84c22.zip
allow people to verify their download
Diffstat (limited to 'app-emulation/cedega')
-rw-r--r--app-emulation/cedega/cedega-4.0.1.ebuild9
-rw-r--r--app-emulation/cedega/files/digest-cedega-4.0.12
-rw-r--r--app-emulation/cedega/files/remove-watermark.sh16
3 files changed, 22 insertions, 5 deletions
diff --git a/app-emulation/cedega/cedega-4.0.1.ebuild b/app-emulation/cedega/cedega-4.0.1.ebuild
index de66a3f9e4c4..318ac9354af8 100644
--- a/app-emulation/cedega/cedega-4.0.1.ebuild
+++ b/app-emulation/cedega/cedega-4.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-4.0.1.ebuild,v 1.4 2004/08/16 15:27:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-4.0.1.ebuild,v 1.5 2004/08/16 17:30:16 vapier Exp $
MY_P="cedega_${PV}-1.i386"
DESCRIPTION="Cedega replaces WineX, a distribution of Wine with enhanced DirectX for gaming"
@@ -30,9 +30,10 @@ pkg_nofetch() {
ewarn "Please note that for some stupid reason Transgaming has"
ewarn "started watermarking their downloads."
ewarn "http://transgaming.org/forum/viewtopic.php?t=660"
- ewarn "This means you will have to rebuild the digest file"
- ewarn "before emerging it. Just run this command:"
- ewarn "ebuild /usr/portage/app-emulation/${PN}/${PF}.ebuild digest"
+ ewarn
+ ewarn "To remove the simple watermark and verify the"
+ ewarn "authenticity of your download, just do this:"
+ ewarn "sh /usr/portage/app-emulation/${PN}/files/remove-watermark.sh ${DISTDIR}/${MY_P}.tgz"
}
src_install() {
diff --git a/app-emulation/cedega/files/digest-cedega-4.0.1 b/app-emulation/cedega/files/digest-cedega-4.0.1
index 9feb103b57d2..9a4603f0a593 100644
--- a/app-emulation/cedega/files/digest-cedega-4.0.1
+++ b/app-emulation/cedega/files/digest-cedega-4.0.1
@@ -1 +1 @@
-MD5 30b245977dfa50e7d1adadd9ad4822d2 cedega_4.0.1-1.i386.tgz 7384181
+MD5 c6333bfe0af7005b918d0ec08f3d8299 cedega_4.0.1-1.i386.tgz 7384181
diff --git a/app-emulation/cedega/files/remove-watermark.sh b/app-emulation/cedega/files/remove-watermark.sh
new file mode 100644
index 000000000000..f3384adc473f
--- /dev/null
+++ b/app-emulation/cedega/files/remove-watermark.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+
+file="$1"
+if [ ! -e "${file}" ] ; then
+ echo "The file '${file}' doesn't seem to exist."
+ echo "Aborting!"
+ exit 1
+fi
+
+dd \
+ if=/dev/zero \
+ of="${file}" \
+ seek=16 \
+ count=20 \
+ bs=1 \
+ conv=notrunc