summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-10-24 13:26:25 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-10-24 13:26:25 +0000
commitb49ccde56bf256e9f2c0a3d2d306f5e55e4363e9 (patch)
treeff60bfee38b1e9276ae44a3dd859f3675fbdddf9 /app-emulation/bochs
parentbochs debugger (diff)
downloadhistorical-b49ccde56bf256e9f2c0a3d2d306f5e55e4363e9.tar.gz
historical-b49ccde56bf256e9f2c0a3d2d306f5e55e4363e9.tar.bz2
historical-b49ccde56bf256e9f2c0a3d2d306f5e55e4363e9.zip
debugger use flag
Diffstat (limited to 'app-emulation/bochs')
-rw-r--r--app-emulation/bochs/ChangeLog5
-rw-r--r--app-emulation/bochs/Manifest4
-rw-r--r--app-emulation/bochs/bochs-2.1.1.ebuild13
3 files changed, 15 insertions, 7 deletions
diff --git a/app-emulation/bochs/ChangeLog b/app-emulation/bochs/ChangeLog
index 0a5e4f3d3087..b474a2f65fba 100644
--- a/app-emulation/bochs/ChangeLog
+++ b/app-emulation/bochs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-emulation/bochs
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.28 2004/09/23 22:43:09 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/ChangeLog,v 1.29 2004/10/24 13:26:25 lu_zero Exp $
+
+ 24 Oct 2004; Luca Barbato <lu_zero@gentoo.org> bochs-2.1.1.ebuild:
+ Added debugger useflag, should address the bug #25227
24 Sep 2004; Luca Barbato <lu_zero@gentoo.org> :
Start using wxwidgets eclass
diff --git a/app-emulation/bochs/Manifest b/app-emulation/bochs/Manifest
index 40226b985122..b2c240922f9b 100644
--- a/app-emulation/bochs/Manifest
+++ b/app-emulation/bochs/Manifest
@@ -1,6 +1,6 @@
-MD5 3841cb0d67368c64603cebdff688f6a2 bochs-2.1.1.ebuild 2157
+MD5 0982856ae3e27a8068bfd27ca140263c bochs-2.1.1.ebuild 2276
MD5 7b1a83153db2e0c2dd02e9aa8a44e9af bochs-2.1.ebuild 2117
-MD5 1408689bf4717d5c24e0d6b94f116ad8 ChangeLog 2968
+MD5 a594d5caae2cdfc4e2dfeeb6739287ab ChangeLog 3094
MD5 099a43e5f7fbd47b87e5111225933b89 bochs-1.4.ebuild 1273
MD5 17d388b4c5102e31cba4d15dd835d18d bochs-2.0.2.ebuild 2068
MD5 898131aae735c3477ff2f9c6882f1178 metadata.xml 223
diff --git a/app-emulation/bochs/bochs-2.1.1.ebuild b/app-emulation/bochs/bochs-2.1.1.ebuild
index 7c7711811689..7eb218efa94c 100644
--- a/app-emulation/bochs/bochs-2.1.1.ebuild
+++ b/app-emulation/bochs/bochs-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.9 2004/09/23 22:43:09 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/bochs/bochs-2.1.1.ebuild,v 1.10 2004/10/24 13:26:25 lu_zero Exp $
inherit eutils wxwidgets
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/bochs/${P}.tar.gz
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86 ~ppc alpha ~sparc ~amd64"
-IUSE="sdl wxwindows readline gtk2"
+IUSE="sdl wxwindows readline gtk2 debugger"
DEPEND="virtual/libc
virtual/x11
@@ -43,9 +43,14 @@ src_compile() {
[ "$ARCH" == "x86" ] \
&& myconf="--enable-idle-hack --enable-fast-function-calls"
myconf="${myconf} `use_with sdl`"
- use wxwindows && myconf="${myconf} --with-gtk --with-wx"
- use wxwindows || myconf="${myconf} --without-gtk --without-wx"
myconf="${myconf} `use_enable readline`"
+ use wxwindows && \
+ myconf="${myconf} --with-gtk --with-wx"
+ use wxwindows || \
+ myconf="${myconf} --without-gtk --without-wx"
+ use bochs-debugger && \
+ myconf="$myconf --enable-debugger --enable-disasm
+ --enable-x86-debugger"
./configure \
--enable-fpu --enable-cdrom --enable-control-panel \