summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-05-29 21:43:47 +0000
committerUlrich Müller <ulm@gentoo.org>2007-05-29 21:43:47 +0000
commit9c5dc10262bc9a61d428c4a3a6cc5631aa659ec1 (patch)
tree73b6219b2793b3c9cd12602341b2639e3a64df25 /app-emacs/gnuserv
parentMake source use flag quieter. (diff)
downloadhistorical-9c5dc10262bc9a61d428c4a3a6cc5631aa659ec1.tar.gz
historical-9c5dc10262bc9a61d428c4a3a6cc5631aa659ec1.tar.bz2
historical-9c5dc10262bc9a61d428c4a3a6cc5631aa659ec1.zip
Fix file collisions with XEmacs, bug #177936.
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'app-emacs/gnuserv')
-rw-r--r--app-emacs/gnuserv/ChangeLog11
-rw-r--r--app-emacs/gnuserv/files/digest-gnuserv-3.12.7-r13
-rw-r--r--app-emacs/gnuserv/files/gnuserv-3.12.7-path-xemacs.patch20
-rw-r--r--app-emacs/gnuserv/gnuserv-3.12.7-r1.ebuild35
4 files changed, 68 insertions, 1 deletions
diff --git a/app-emacs/gnuserv/ChangeLog b/app-emacs/gnuserv/ChangeLog
index aad241249a3e..52bfb924054a 100644
--- a/app-emacs/gnuserv/ChangeLog
+++ b/app-emacs/gnuserv/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-emacs/gnuserv
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnuserv/ChangeLog,v 1.14 2007/05/19 16:02:05 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnuserv/ChangeLog,v 1.15 2007/05/29 21:43:47 ulm Exp $
+
+*gnuserv-3.12.7-r1 (29 May 2007)
+
+ 29 May 2007; Ulrich Mueller <ulm@gentoo.org>
+ +files/gnuserv-3.12.7-path-xemacs.patch, +gnuserv-3.12.7-r1.ebuild:
+ Binary programs moved to new package app-emacs/gnuserv-programs to avoid
+ file collisions with XEmacs, bug #177936. Search for gnuserv binary also in
+ XEmacs directory; use system-configuration to determine exec-path in
+ gnuserv.el.
19 May 2007; Ulrich Mueller <ulm@gentoo.org> gnuserv-3.12.7.ebuild:
Add IUSE="X" and missing libXau dependency. Add messages to die commands.
diff --git a/app-emacs/gnuserv/files/digest-gnuserv-3.12.7-r1 b/app-emacs/gnuserv/files/digest-gnuserv-3.12.7-r1
new file mode 100644
index 000000000000..2283b4bb90f4
--- /dev/null
+++ b/app-emacs/gnuserv/files/digest-gnuserv-3.12.7-r1
@@ -0,0 +1,3 @@
+MD5 b1522454fbccab33fb271f6a46afc3e9 gnuserv-3.12.7.tar.gz 93709
+RMD160 2fd5a28fb86cc05c26da50cab8d9ee036f2e2d00 gnuserv-3.12.7.tar.gz 93709
+SHA256 08242167b863e41bbfdaf4429500018c2b2beb50b82791fa148df66eba433d2a gnuserv-3.12.7.tar.gz 93709
diff --git a/app-emacs/gnuserv/files/gnuserv-3.12.7-path-xemacs.patch b/app-emacs/gnuserv/files/gnuserv-3.12.7-path-xemacs.patch
new file mode 100644
index 000000000000..2e7299ca17c9
--- /dev/null
+++ b/app-emacs/gnuserv/files/gnuserv-3.12.7-path-xemacs.patch
@@ -0,0 +1,20 @@
+--- gnuserv.el~ 2004-10-19 10:50:01.000000000 +0200
++++ gnuserv.el 2007-05-25 22:49:01.000000000 +0200
+@@ -733,7 +733,16 @@
+ (unless leave-dead
+ (setq gnuserv-string ""
+ gnuserv-current-client nil)
+- (let ((process-connection-type t))
++ (let* ((process-connection-type t)
++ (xe-sysconf
++ ;; XEmacs uses i*86-pc-linux instead of i*86-pc-linux-gnu
++ ;; Do they want to be deliberately incompatible? :-(
++ (replace-regexp-in-string
++ "^\\([^-]+-[^-]+-[^-]+\\)-.*$" "\\1" system-configuration))
++ (exec-path
++ (append exec-path
++ (file-expand-wildcards
++ (concat "/usr/lib/xemacs-*/" xe-sysconf)))))
+ (setq gnuserv-process
+ (start-process "gnuserv" nil gnuserv-program)))
+ (set-process-sentinel gnuserv-process 'gnuserv-sentinel)
diff --git a/app-emacs/gnuserv/gnuserv-3.12.7-r1.ebuild b/app-emacs/gnuserv/gnuserv-3.12.7-r1.ebuild
new file mode 100644
index 000000000000..85fbf39624ff
--- /dev/null
+++ b/app-emacs/gnuserv/gnuserv-3.12.7-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gnuserv/gnuserv-3.12.7-r1.ebuild,v 1.1 2007/05/29 21:43:47 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="Attach to an already running Emacs"
+HOMEPAGE="http://meltin.net/hacks/emacs/"
+SRC_URI="http://meltin.net/hacks/emacs/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| ( ~app-emacs/gnuserv-programs-${PV} virtual/xemacs )"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-path-xemacs.patch"
+}
+
+src_compile() {
+ elisp-comp *.el || die "elisp-comp failed"
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ dodoc ChangeLog README README.orig || die "dodoc failed"
+}