summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-11-16 18:55:16 +0000
committerUlrich Müller <ulm@gentoo.org>2010-11-16 18:55:16 +0000
commit40c44b0f267479329df77f079dd6681d1b031c8e (patch)
tree0fe09fe36b673f677f8ae955bc3dc3ea84a4ca1a /app-emacs/auto-complete
parentx86 stable per bug 345501 (diff)
downloadhistorical-40c44b0f267479329df77f079dd6681d1b031c8e.tar.gz
historical-40c44b0f267479329df77f079dd6681d1b031c8e.tar.bz2
historical-40c44b0f267479329df77f079dd6681d1b031c8e.zip
Initial import, from Emacs overlay. Bug 297155.
Package-Manager: portage-2.1.9.24/cvs/Linux x86_64
Diffstat (limited to 'app-emacs/auto-complete')
-rw-r--r--app-emacs/auto-complete/ChangeLog12
-rw-r--r--app-emacs/auto-complete/Manifest15
-rw-r--r--app-emacs/auto-complete/auto-complete-1.3.ebuild32
-rw-r--r--app-emacs/auto-complete/files/50auto-complete-gentoo.el3
-rw-r--r--app-emacs/auto-complete/metadata.xml5
5 files changed, 67 insertions, 0 deletions
diff --git a/app-emacs/auto-complete/ChangeLog b/app-emacs/auto-complete/ChangeLog
new file mode 100644
index 000000000000..1de295cc63f1
--- /dev/null
+++ b/app-emacs/auto-complete/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-emacs/auto-complete
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auto-complete/ChangeLog,v 1.1 2010/11/16 18:55:16 ulm Exp $
+
+*auto-complete-1.3 (16 Nov 2010)
+
+ 16 Nov 2010; Ulrich Mueller <ulm@gentoo.org>
+ +files/50auto-complete-gentoo.el, +auto-complete-1.3.ebuild,
+ +metadata.xml:
+ Initial import, from Emacs overlay. Ebuild contributed by Andrey Astafiev
+ <elnull@gmail.com>, with changes by me; bug 297155.
+
diff --git a/app-emacs/auto-complete/Manifest b/app-emacs/auto-complete/Manifest
new file mode 100644
index 000000000000..0af2e4cf28f1
--- /dev/null
+++ b/app-emacs/auto-complete/Manifest
@@ -0,0 +1,15 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+AUX 50auto-complete-gentoo.el 157 RMD160 a94287633b82fa4e4d8f5df7cd4c68baf88fc866 SHA1 397e97425b9c3a25bc0f2d95ac14c792c2707111 SHA256 fde9551212b22c48cf0502d1393a5618e6642e23c21a814415b514e8734b77f4
+DIST auto-complete-1.3.tar.bz2 138002 RMD160 015a3c08f35dc9b6ce79b453ebc9704a346d92fa SHA1 b8ff9e83ad87391bb971b21a749370c198f0c546 SHA256 a46f212923c32c3e4924fb7f320c9eec7da477eb60a582c85e7735d60f839864
+EBUILD auto-complete-1.3.ebuild 840 RMD160 c9633082823bbc8a7543250648700d0b37d6c43c SHA1 9a728988f837119432c61bbd9f5a35c1fc411471 SHA256 7b791c4bd020d0e80c42dd28b0090bff7436cfe3419f0d0d78290a0d6762f8fe
+MISC ChangeLog 508 RMD160 9389ba608128d253312bc59bcab8e3afb83b6230 SHA1 0fb16b10b30642490f8a2d74cf6538e2c34fba62 SHA256 c707d592ff4b7f41629dcb591564903d29d216abfab29daec31601e321355bd2
+MISC metadata.xml 158 RMD160 415d172437ca754d24fc5ab186ba8e77934d96e4 SHA1 61f6eff9729cd87a725c2a70c81aca4270a17fc4 SHA256 1393bdef3a74343fdb40a112c7096a1af16f67e7a43413250de28dfe73810eab
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v2.0.16 (GNU/Linux)
+
+iEYEARECAAYFAkzi1FUACgkQOeoy/oIi7uz6uACfViyQ1N+8+/wT1FC1QWteG7NO
+tKUAoIN58rk4aimlBBgIRckc1vpth0KV
+=i0Fa
+-----END PGP SIGNATURE-----
diff --git a/app-emacs/auto-complete/auto-complete-1.3.ebuild b/app-emacs/auto-complete/auto-complete-1.3.ebuild
new file mode 100644
index 000000000000..542575d5a79a
--- /dev/null
+++ b/app-emacs/auto-complete/auto-complete-1.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/auto-complete/auto-complete-1.3.ebuild,v 1.1 2010/11/16 18:55:16 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Auto-complete package"
+HOMEPAGE="http://cx4a.org/software/auto-complete/
+ http://github.com/m2ym/auto-complete/"
+SRC_URI="http://cx4a.org/pub/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3 FDL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_ja"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_install() {
+ elisp_src_install
+
+ # install dictionaries
+ insinto "${SITEETC}/${PN}"
+ doins -r dict || die
+
+ dodoc README.txt TODO.txt etc/test.txt || die
+ cd doc
+ dodoc index.txt manual.txt demo.txt changes.txt *.png || die
+ if use linguas_ja; then
+ dodoc index.ja.txt manual.ja.txt changes.ja.txt || die
+ fi
+}
diff --git a/app-emacs/auto-complete/files/50auto-complete-gentoo.el b/app-emacs/auto-complete/files/50auto-complete-gentoo.el
new file mode 100644
index 000000000000..c380d11b3a1e
--- /dev/null
+++ b/app-emacs/auto-complete/files/50auto-complete-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'auto-complete-mode "auto-complete" "AutoComplete mode" t)
+(setq ac-dictionary-directories "@SITEETC@/dict")
diff --git a/app-emacs/auto-complete/metadata.xml b/app-emacs/auto-complete/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/auto-complete/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>