summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Chandler <sethbc@gentoo.org>2003-03-21 23:18:06 +0000
committerSeth Chandler <sethbc@gentoo.org>2003-03-21 23:18:06 +0000
commit7001434fa4ec895028ba549e0cfb6cdcab6ed9aa (patch)
tree2a35d1078a54f3d63a4971969b8bef3711abbe63 /app-editors
parentadding media-libs/libart_lgpl to depend, fixes bug #17052 (diff)
downloadhistorical-7001434fa4ec895028ba549e0cfb6cdcab6ed9aa.tar.gz
historical-7001434fa4ec895028ba549e0cfb6cdcab6ed9aa.tar.bz2
historical-7001434fa4ec895028ba549e0cfb6cdcab6ed9aa.zip
added ne to portage
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/ne/ChangeLog9
-rw-r--r--app-editors/ne/files/digest-ne-1.191
-rw-r--r--app-editors/ne/ne-1.19.ebuild38
3 files changed, 48 insertions, 0 deletions
diff --git a/app-editors/ne/ChangeLog b/app-editors/ne/ChangeLog
new file mode 100644
index 000000000000..a9718d5fa7ed
--- /dev/null
+++ b/app-editors/ne/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-editors/ne
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ChangeLog,v 1.1 2003/03/21 23:18:06 sethbc Exp $
+
+*ne-1.19 (21 Mar 2003)
+
+ 21 Mar 2003; Seth Chandler <sethbc@gentoo.org>; ne-1.19.ebuild:
+ initial import thx to Marc Heerdink <marc@koelkast.net>
+
diff --git a/app-editors/ne/files/digest-ne-1.19 b/app-editors/ne/files/digest-ne-1.19
new file mode 100644
index 000000000000..8dc217285975
--- /dev/null
+++ b/app-editors/ne/files/digest-ne-1.19
@@ -0,0 +1 @@
+MD5 31c2d12ac1c8f4a1c5127a587ceb245d ne-1.19.tar.gz 521719
diff --git a/app-editors/ne/ne-1.19.ebuild b/app-editors/ne/ne-1.19.ebuild
new file mode 100644
index 000000000000..5bb4db32c58b
--- /dev/null
+++ b/app-editors/ne/ne-1.19.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/ne/ne-1.19.ebuild,v 1.1 2003/03/21 23:18:06 sethbc Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="ne is the nice editor, easy to use for the beginner and powerful for the wizard"
+SRC_URI="http://ne.dsi.unimi.it/${P}.tar.gz"
+HOMEPAGE="http://ne.dsi.unimi.ti/"
+
+DEPEND="ncurses? ( >=sys-libs/ncurses-5.2 )"
+PROVIDE="virtual/editor"
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="GPL-2"
+IUSE="ncurses"
+
+src_compile() {
+ if [ "`use ncurses`" ]; then
+ emake -C src ne CFLAGS="${CFLAGS} -DNODEBUG -D_POSIX_C_SOURCE=199506L" LIBS="-lncurses" || die
+ else
+ emake -C src net CFLAGS="${CFLAGS} -DNODEBUG -DTERMCAP -D_POSIX_C_SOURCE=199506L" LIBS="" || die
+ fi
+}
+
+src_install() {
+ gunzip doc/ne.info*gz
+
+ into /usr
+
+ dobin src/ne
+ doman doc/ne.1
+ doinfo doc/*.info*
+ dohtml doc/*.html
+ dodoc CHANGES COPYING README
+ dodoc doc/*.txt doc/*.ps doc/*.texinfo doc/default.*
+}
+