summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-07-23 06:33:42 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-07-23 06:33:42 +0000
commit28d85974dab6b27ab6ed124f067f219a73ce4757 (patch)
treed9174d088fe9127c4ba8c61855d79a65a22e5795 /app-editors
parentVersion bump of gtkguitune to 0.7. This closes Bug #45340 (diff)
downloadhistorical-28d85974dab6b27ab6ed124f067f219a73ce4757.tar.gz
historical-28d85974dab6b27ab6ed124f067f219a73ce4757.tar.bz2
historical-28d85974dab6b27ab6ed124f067f219a73ce4757.zip
Added patch by Jon Oberheide <jon@oberheide.org> (via email). uses different inline method for >=gcc-3.1 compilers
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/lfhex/ChangeLog9
-rw-r--r--app-editors/lfhex/Manifest11
-rw-r--r--app-editors/lfhex/files/digest-lfhex-0.3.7-r11
-rw-r--r--app-editors/lfhex/files/lfhex-gcc3-inline-fix.patch19
-rw-r--r--app-editors/lfhex/lfhex-0.3.7-r1.ebuild41
5 files changed, 76 insertions, 5 deletions
diff --git a/app-editors/lfhex/ChangeLog b/app-editors/lfhex/ChangeLog
index e46e7c49b176..388ee9b916d3 100644
--- a/app-editors/lfhex/ChangeLog
+++ b/app-editors/lfhex/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/lfhex
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/ChangeLog,v 1.4 2004/07/18 05:57:25 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/ChangeLog,v 1.5 2004/07/23 06:33:42 dragonheart Exp $
+
+*lfhex-0.3.7-r1 (23 Jul 2004)
+
+ 23 Jul 2004; Daniel Black <dragonheart@gentoo.org>
+ +files/lfhex-gcc3-inline-fix.patch, +lfhex-0.3.7-r1.ebuild:
+ Added patch by Jon Oberheide <jon@oberheide.org> (via email). Uses different
+ inline method for >=gcc-3.1 compilers.
18 Jul 2004; Daniel Black <dragonheart@gentoo.org> lfhex-0.3.7.ebuild:
x86 stable
diff --git a/app-editors/lfhex/Manifest b/app-editors/lfhex/Manifest
index 5ec41f31bfde..3bf0249b20c2 100644
--- a/app-editors/lfhex/Manifest
+++ b/app-editors/lfhex/Manifest
@@ -2,13 +2,16 @@
Hash: SHA1
MD5 b0376a3a63911905d80b073b56812ff7 lfhex-0.3.7.ebuild 765
+MD5 cabd6d04682d7c7062eb9420bf873152 lfhex-0.3.7-r1.ebuild 873
MD5 6d796b061ed1c1337ef157a5f74dab35 metadata.xml 403
-MD5 228fe74904c76a99d37fdddf45722865 ChangeLog 598
+MD5 101967d26ac87b9fd36e5cfa56d61b9d ChangeLog 865
MD5 278540748b028890d6885b09b0ab834c files/digest-lfhex-0.3.7 62
+MD5 ee28bebce85257e0e2fc93bc323d4e9b files/lfhex-gcc3-inline-fix.patch 539
+MD5 278540748b028890d6885b09b0ab834c files/digest-lfhex-0.3.7-r1 62
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
-iD8DBQFA+hMJmdTrptrqvGERAsQqAJ9RTz4ZPDk+R9MCXTtMKxa8DZxLYACcCtMb
-W4cfmvJi7QsvlqiQrCTogNk=
-=BqAI
+iD8DBQFBALMgmdTrptrqvGERAljEAJ92+0ls7N/EFlxEiEzIG/WTlC+4mwCeLy8f
+cdtnr0fCLHjEB7a7ncC/2Qo=
+=qC3A
-----END PGP SIGNATURE-----
diff --git a/app-editors/lfhex/files/digest-lfhex-0.3.7-r1 b/app-editors/lfhex/files/digest-lfhex-0.3.7-r1
new file mode 100644
index 000000000000..fe1f0f8739bd
--- /dev/null
+++ b/app-editors/lfhex/files/digest-lfhex-0.3.7-r1
@@ -0,0 +1 @@
+MD5 203051364839fa48b9e030d44e84e648 lfhex-0.3.7.tar.gz 69947
diff --git a/app-editors/lfhex/files/lfhex-gcc3-inline-fix.patch b/app-editors/lfhex/files/lfhex-gcc3-inline-fix.patch
new file mode 100644
index 000000000000..c03754e884af
--- /dev/null
+++ b/app-editors/lfhex/files/lfhex-gcc3-inline-fix.patch
@@ -0,0 +1,19 @@
+diff -ur lfhex-0.3.7.old/src/reader.hpp lfhex-0.3.7.new/src/reader.hpp
+--- lfhex-0.3.7.old/src/reader.hpp 2004-02-12 23:28:32.000000000 -0500
++++ lfhex-0.3.7.new/src/reader.hpp 2004-07-22 18:06:55.038879120 -0400
+@@ -34,9 +34,13 @@
+ #include "local.h"
+
+ #ifdef DEBUG
+-#define INLINE
++# define INLINE
+ #else
+-#define INLINE inline
++# if defined(__GNUC__) && __GNUC__ == 3 && __GNUC_MINOR__ >= 1
++# define INLINE __attribute__((always_inline))
++# else
++# define INLINE inline
++# endif
+ #endif
+
+ typedef vector<uchar> ReadBuffer;
diff --git a/app-editors/lfhex/lfhex-0.3.7-r1.ebuild b/app-editors/lfhex/lfhex-0.3.7-r1.ebuild
new file mode 100644
index 000000000000..60f9dcb6b083
--- /dev/null
+++ b/app-editors/lfhex/lfhex-0.3.7-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/lfhex/lfhex-0.3.7-r1.ebuild,v 1.1 2004/07/23 06:33:42 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="A fast, efficient hex-editor with support for large files and comparing binary files"
+HOMEPAGE="http://freshmeat.net/projects/lfhex"
+SRC_URI="http://home.earthlink.net/~eyekode/data/${P}.tar.gz"
+LICENSE="QPL-1.0"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+RDEPEND=">=x11-libs/qt-3
+ virtual/x11"
+
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison
+ sys-apps/grep
+ sys-apps/net-tools"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/lfhex-gcc3-inline-fix.patch
+}
+
+src_compile() {
+ econf || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin bin/lfhex
+ dodoc LICENSE.QPL
+ dodoc README
+ dodoc README.install
+}