summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-03-17 13:46:44 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-03-17 13:46:44 +0000
commit1f429b6a3b9058f37247bfdde55d710afe3d3892 (patch)
tree20106e4c57375a596f7691badd81908f2f4c38fd /app-editors
parentRemove unneeded files. (diff)
downloadhistorical-1f429b6a3b9058f37247bfdde55d710afe3d3892.tar.gz
historical-1f429b6a3b9058f37247bfdde55d710afe3d3892.tar.bz2
historical-1f429b6a3b9058f37247bfdde55d710afe3d3892.zip
Added workaround to prevent segfaults on ppc.
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/qemacs/ChangeLog7
-rw-r--r--app-editors/qemacs/Manifest9
-rw-r--r--app-editors/qemacs/files/qemacs-0.3.1-gcc-3.4.patch2
-rw-r--r--app-editors/qemacs/files/qemacs-ppc-segfault.patch39
-rw-r--r--app-editors/qemacs/qemacs-0.3.1-r1.ebuild5
-rw-r--r--app-editors/qemacs/qemacs-0.3.1.ebuild5
6 files changed, 59 insertions, 8 deletions
diff --git a/app-editors/qemacs/ChangeLog b/app-editors/qemacs/ChangeLog
index d77b333450a0..4d3f4b654cab 100644
--- a/app-editors/qemacs/ChangeLog
+++ b/app-editors/qemacs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/qemacs
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.13 2005/03/06 02:49:03 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.14 2005/03/17 13:46:43 josejx Exp $
+
+ 17 Mar 2005; Joseph Jezak <josejx@gentoo.org>
+ files/qemacs-0.3.1-gcc-3.4.patch, +files/qemacs-ppc-segfault.patch,
+ qemacs-0.3.1.ebuild, qemacs-0.3.1-r1.ebuild:
+ Added workaround to prevent segfaults on ppc.
06 Mar 2005; Joseph Jezak <josejx@gentoo.org>
+files/qemacs-0.3.1-gcc-3.4.patch, qemacs-0.3.1-r1.ebuild,
diff --git a/app-editors/qemacs/Manifest b/app-editors/qemacs/Manifest
index 4091d174847b..e9c39767d580 100644
--- a/app-editors/qemacs/Manifest
+++ b/app-editors/qemacs/Manifest
@@ -1,10 +1,11 @@
-MD5 6e9a68c3f1caad8c40517369f1b9b5b4 ChangeLog 1917
-MD5 c4e8fec24213e4e8f81ead2c822b0607 qemacs-0.3.1-r1.ebuild 1197
-MD5 22f1ca0663e65cbadeaa0eb965f7198c qemacs-0.3.1.ebuild 1151
+MD5 203010d8b94b2b6ffd6c0d525f9fa57f ChangeLog 2131
+MD5 d655335395140037a868fb820f86594f qemacs-0.3.1-r1.ebuild 1265
+MD5 3dbfaafc44125a56bb3a6357be47030f qemacs-0.3.1.ebuild 1219
MD5 26f2791358b330724fe8dfa7a4dba22a files/qemacs-0.3.1-configure-gentoo.patch 496
+MD5 4087c1cb48fcda9de6fe14a956748b1a files/qemacs-ppc-segfault.patch 918
MD5 a4c613ab493b62325669d8d1353c8b2e files/qemacs-Makefile-gentoo.patch 421
MD5 1bef560680eaab10f0524f228c5dc6eb files/digest-qemacs-0.3.1 64
MD5 635697c90ee6f2498f3f566a0932f2c2 files/qemacs-0.3.1-make_backup.patch 2141
-MD5 13fe113a6019ae0b378ef1ecc736fb81 files/qemacs-0.3.1-gcc-3.4.patch 243
+MD5 fe9962c046aca07cf1ede091345ea97a files/qemacs-0.3.1-gcc-3.4.patch 249
MD5 1bef560680eaab10f0524f228c5dc6eb files/digest-qemacs-0.3.1-r1 64
MD5 e7a9a6e25a384848c2b87891e7e7c973 files/qemacs-0.3.1-tty_utf8.patch 952
diff --git a/app-editors/qemacs/files/qemacs-0.3.1-gcc-3.4.patch b/app-editors/qemacs/files/qemacs-0.3.1-gcc-3.4.patch
index 121988feec24..4506b9e3ab5a 100644
--- a/app-editors/qemacs/files/qemacs-0.3.1-gcc-3.4.patch
+++ b/app-editors/qemacs/files/qemacs-0.3.1-gcc-3.4.patch
@@ -4,7 +4,7 @@
*q++ = l1;
i++;
found:
-+ ;
++ break;
}
}
return q - buf_out;
diff --git a/app-editors/qemacs/files/qemacs-ppc-segfault.patch b/app-editors/qemacs/files/qemacs-ppc-segfault.patch
new file mode 100644
index 000000000000..de6c420c5d3b
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-ppc-segfault.patch
@@ -0,0 +1,39 @@
+--- qe.c.old 2005-03-13 14:37:22.967682048 +1100
++++ qe.c 2005-03-13 14:37:56.866528640 +1100
+@@ -6165,16 +6165,16 @@
+ { NULL },
+ };
+
+-#if defined(__GNUC__) || defined(__TINYC__)
++/*#if defined(__GNUC__) || defined(__TINYC__)
+ static inline void init_all_modules(void)
+ {
+ int (*initcall)(void);
+ void **ptr;
+
+ ptr = (void **)&__initcall_first;
+- for(;;) {
++ for(;;) {*/
+ /* NOTE: if bound checking is on, a '\0' is inserted between
+- each initialized 'void *' */
++ each initialized 'void *' *//*
+ #if defined(__BOUNDS_CHECKING_ON)
+ ptr = (void **)((long)ptr + (2 * sizeof(void *)));
+ #else
+@@ -6186,14 +6186,14 @@
+ initcall();
+ }
+ }
+-#else
++#else*/
+ /* cannot use elf sections, so we initialize the modules manually */
+ static inline void init_all_modules(void)
+ {
+ x11_init();
+ c_init();
+ }
+-#endif
++//#endif
+
+ #ifdef CONFIG_DLL
+
diff --git a/app-editors/qemacs/qemacs-0.3.1-r1.ebuild b/app-editors/qemacs/qemacs-0.3.1-r1.ebuild
index dbc68c98b1fc..4cf38995791f 100644
--- a/app-editors/qemacs/qemacs-0.3.1-r1.ebuild
+++ b/app-editors/qemacs/qemacs-0.3.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1-r1.ebuild,v 1.2 2005/03/06 02:49:03 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1-r1.ebuild,v 1.3 2005/03/17 13:46:43 josejx Exp $
inherit eutils
@@ -23,6 +23,9 @@ src_unpack() {
epatch ${FILESDIR}/${P}-configure-gentoo.patch
epatch ${FILESDIR}/${P}-make_backup.patch
epatch ${FILESDIR}/${PN}-0.3.1-gcc-3.4.patch
+ if use ppc; then
+ epatch ${FILESDIR}/${PN}-ppc-segfault.patch
+ fi
use unicode && epatch ${FILESDIR}/${P}-tty_utf8.patch
}
diff --git a/app-editors/qemacs/qemacs-0.3.1.ebuild b/app-editors/qemacs/qemacs-0.3.1.ebuild
index 9a71686a97b3..ae54874f794b 100644
--- a/app-editors/qemacs/qemacs-0.3.1.ebuild
+++ b/app-editors/qemacs/qemacs-0.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1.ebuild,v 1.15 2005/03/06 02:49:03 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1.ebuild,v 1.16 2005/03/17 13:46:43 josejx Exp $
inherit eutils
@@ -22,6 +22,9 @@ src_unpack() {
epatch ${FILESDIR}/qemacs-Makefile-gentoo.patch
epatch ${FILESDIR}/qemacs-${PV}-configure-gentoo.patch
epatch ${FILESDIR}/${P}-gcc-3.4.patch
+ if use ppc; then
+ epatch ${FILESDIR}/${PN}-ppc-segfault.patch
+ fi
use unicode && epatch ${FILESDIR}/${P}-tty_utf8.patch
}