summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-07-14 20:42:14 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-07-14 20:42:14 +0000
commit90c65945fadfa29795cdcca5d6806fa0b92759a7 (patch)
tree80c0d7d3728635536642a6cabd5b2ee484d6d33a /app-editors/xwpe/xwpe-1.5.29a.ebuild
parentLICENSE, KEYWORDS and SLOT tags added (diff)
downloadhistorical-90c65945fadfa29795cdcca5d6806fa0b92759a7.tar.gz
historical-90c65945fadfa29795cdcca5d6806fa0b92759a7.tar.bz2
historical-90c65945fadfa29795cdcca5d6806fa0b92759a7.zip
New version.
Diffstat (limited to 'app-editors/xwpe/xwpe-1.5.29a.ebuild')
-rw-r--r--app-editors/xwpe/xwpe-1.5.29a.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-editors/xwpe/xwpe-1.5.29a.ebuild b/app-editors/xwpe/xwpe-1.5.29a.ebuild
new file mode 100644
index 000000000000..cd0cf0530f77
--- /dev/null
+++ b/app-editors/xwpe/xwpe-1.5.29a.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xwpe/xwpe-1.5.29a.ebuild,v 1.1 2002/07/14 20:42:14 stroke Exp $
+
+DESCRIPTION="An IDE to Develop in text and graphical mode"
+HOMEPAGE="http://www.identicalsoftware.com/xwpe/"
+
+LICENSE="GPL-2"
+
+DEPEND=">=sys-libs/gpm-1.20.0 \
+ >=sys-libs/ncurses-5.2 \
+ >=sys-libs/zlib-1.1.4"
+
+RDEPEND="${DEPEND}"
+SLOT="0"
+KEYWORDS="*"
+
+SRC_URI="http://www.identicalsoftware.com/xwpe/${P}.tar.gz"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=${D}/usr/share/info \
+ --mandir=${D}/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr install || die
+ dodoc INSTALL README CHANGELOG
+}