summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-08-14 08:42:49 +0000
committerAli Polatel <hawking@gentoo.org>2008-08-14 08:42:49 +0000
commit7484b18bf92fe2e4ac371c946210413f08fa3385 (patch)
tree10fe6a36e6d2e36ddb4bb2c6a7e0bcd628b1a235 /app-editors/vim/vim-7.2.ebuild
parentFix up interprolog and mt options. (diff)
downloadhistorical-7484b18bf92fe2e4ac371c946210413f08fa3385.tar.gz
historical-7484b18bf92fe2e4ac371c946210413f08fa3385.tar.bz2
historical-7484b18bf92fe2e4ac371c946210413f08fa3385.zip
Version bump. Fixing bugs 227453, 232890, 234652 and 234587.
Package-Manager: portage-2.2_rc7.wrabbit
Diffstat (limited to 'app-editors/vim/vim-7.2.ebuild')
-rw-r--r--app-editors/vim/vim-7.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-editors/vim/vim-7.2.ebuild b/app-editors/vim/vim-7.2.ebuild
new file mode 100644
index 000000000000..e22a1b7e1205
--- /dev/null
+++ b/app-editors/vim/vim-7.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-7.2.ebuild,v 1.1 2008/08/14 08:39:26 hawking Exp $
+
+inherit vim
+
+VIM_VERSION="7.2"
+VIM_GENTOO_PATCHES="vim-${VIM_VERSION}-gentoo-patches.tar.bz2"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz
+ ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-extra.tar.gz
+ mirror://gentoo/${VIM_GENTOO_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+DEPEND="${DEPEND}
+ !minimal? ( ~app-editors/vim-core-${PV} )"
+RDEPEND="${RDEPEND}
+ !<app-editors/nvi-1.81.5-r4
+ !minimal? ( ~app-editors/vim-core-${PV} )"