summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-18 02:58:29 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-18 02:58:29 +0000
commite042f7e67542c708c457ba4375e46c1986c168c7 (patch)
tree02ef21693b9e5f232234c0f28ca719fef2e5d55a /app-editors/nano/nano-1.2.5.ebuild
parentupstream update,removed very old 2.0.22 version,added amd64 support,updated i... (diff)
downloadhistorical-e042f7e67542c708c457ba4375e46c1986c168c7.tar.gz
historical-e042f7e67542c708c457ba4375e46c1986c168c7.tar.bz2
historical-e042f7e67542c708c457ba4375e46c1986c168c7.zip
Version bump.
Diffstat (limited to 'app-editors/nano/nano-1.2.5.ebuild')
-rw-r--r--app-editors/nano/nano-1.2.5.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-editors/nano/nano-1.2.5.ebuild b/app-editors/nano/nano-1.2.5.ebuild
new file mode 100644
index 000000000000..3d0f9fef2af7
--- /dev/null
+++ b/app-editors/nano/nano-1.2.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/nano/nano-1.2.5.ebuild,v 1.1 2005/05/18 02:58:29 vapier Exp $
+
+inherit eutils
+
+MY_P=${PN}-${PV/_}
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="http://www.nano-editor.org/"
+SRC_URI="http://www.nano-editor.org/dist/v1.2/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 mips ppc sparc x86"
+IUSE="nls build spell justify debug slang ncurses"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ nls? ( sys-devel/gettext )
+ slang? ( sys-libs/slang )"
+PROVIDE="virtual/editor"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf=""
+ use build && myconf="${myconf} --disable-wrapping-as-root"
+ use ncurses || myconf="${myconf} $(use_with slang)"
+
+ econf \
+ --bindir=/bin \
+ --enable-color \
+ --enable-multibuffer \
+ --enable-nanorc \
+ $(use_enable justify) \
+ $(use_enable spell) \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ ${myconf} \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use build ; then
+ rm -r "${D}"/usr/share
+ else
+ cat "${FILESDIR}"/nanorc-* >> nanorc.sample
+ dodoc ChangeLog README nanorc.sample AUTHORS BUGS NEWS TODO
+ dohtml *.html
+ insinto /etc
+ newins nanorc.sample nanorc
+ fi
+
+ dodir /usr/bin
+ dosym /bin/nano /usr/bin/nano
+}