summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-08-27 12:04:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-08-27 12:04:47 +0000
commita2a05829c91c7264c701e07560d58f49042ab0bc (patch)
tree9b0a4c3ad862edcf600d4b0b8c1578d901e83f84 /app-editors/mp
parentfix typo reported in bug #60039 (diff)
downloadhistorical-a2a05829c91c7264c701e07560d58f49042ab0bc.tar.gz
historical-a2a05829c91c7264c701e07560d58f49042ab0bc.tar.bz2
historical-a2a05829c91c7264c701e07560d58f49042ab0bc.zip
fix up gmp symlink and tidy src_compile
Diffstat (limited to 'app-editors/mp')
-rw-r--r--app-editors/mp/ChangeLog5
-rw-r--r--app-editors/mp/Manifest4
-rw-r--r--app-editors/mp/mp-3.3.1.ebuild22
3 files changed, 18 insertions, 13 deletions
diff --git a/app-editors/mp/ChangeLog b/app-editors/mp/ChangeLog
index 1ae07f810527..961dbd84c81a 100644
--- a/app-editors/mp/ChangeLog
+++ b/app-editors/mp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-editors/mp
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/ChangeLog,v 1.22 2004/08/27 11:55:54 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/ChangeLog,v 1.23 2004/08/27 12:04:47 mr_bones_ Exp $
+
+ 27 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org> mp-3.3.1.ebuild:
+ fix up gmp symlink and tidy src_compile
27 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org> mp-3.3.1.ebuild:
fix typo reported in bug #60039
diff --git a/app-editors/mp/Manifest b/app-editors/mp/Manifest
index 7a75e24ab317..318eb56b9d3d 100644
--- a/app-editors/mp/Manifest
+++ b/app-editors/mp/Manifest
@@ -1,6 +1,6 @@
-MD5 fedf5a3add1ca96d5639f2b5127602a1 ChangeLog 2369
+MD5 cd964c3b054baab52a233f88ea1ef959 ChangeLog 2484
MD5 166ede21d137a702e20f482c011b4a0e mp-3.1.9.ebuild 671
-MD5 538d4b1ba89850b8f1a6ea16c6ad3791 mp-3.3.1.ebuild 1190
+MD5 b8b900f65e76347ed4ffe5627ab0dcb1 mp-3.3.1.ebuild 1153
MD5 e4600d51770bb9fb9d083ebfb0633aab mp-3.2.10.ebuild 945
MD5 41e6961673db80bbad7fed0132594910 mp-3.2.11.ebuild 1034
MD5 1652522405f5936eb29776ef8d5ffa5b metadata.xml 310
diff --git a/app-editors/mp/mp-3.3.1.ebuild b/app-editors/mp/mp-3.3.1.ebuild
index 8604ff5f804e..2253f3c56300 100644
--- a/app-editors/mp/mp-3.3.1.ebuild
+++ b/app-editors/mp/mp-3.3.1.ebuild
@@ -1,16 +1,16 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.3.1.ebuild,v 1.4 2004/08/27 11:55:54 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-3.3.1.ebuild,v 1.5 2004/08/27 12:04:47 mr_bones_ Exp $
DESCRIPTION="Minimum Profit: A text editor for programmers"
HOMEPAGE="http://www.triptico.com/software/mp.html"
-SRC_URI="http://www.triptico.com/download/mp-3.3.1.tar.gz"
+SRC_URI="http://www.triptico.com/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~sparc ~amd64"
-
IUSE="ncurses gtk"
+
DEPEND="virtual/libc
ncurses? ( sys-libs/ncurses )
gtk? ( >=x11-libs/gtk+-1.2* )
@@ -21,14 +21,16 @@ RDEPEND="${DEPEND}
src_compile() {
local myconf
- if use ncurses && use gtk ; then
- sh config.sh ${myconf}|| die "Configure Failed"
- elif use ncurses || ! use gtk ; then
+ if use gtk ; then
+ if use ncurses ; then
+ sh config.sh ${myconf}|| die "Configure Failed"
+ else
+ myconf="${myconf} --without-curses"
+ sh config.sh ${myconf} || die "Configure Failed"
+ fi
+ else
myconf="${myconf} --without-gtk"
sh config.sh ${myconf} || die "Configure Failed"
- elif use gtk && ! use ncurses ; then
- myconf="${myconf} --without-curses"
- sh config.sh ${myconf} || die "Configure Failed"
fi
echo ${CFLAGS} >> config.cflags
emake || die "Compile Failed"
@@ -36,7 +38,7 @@ src_compile() {
src_install() {
dobin mp || die "Install Failed"
- dosym mp ${DESTTREE}/bin/gmp
+ use gtk && dosym mp "${DESTTREE}/bin/gmp"
dodoc AUTHORS README Changelog mprc.sample
doman mp.1
}